Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th September 2009, 23:23
dlucy dlucy is offline
Junior Member
 
Join Date: Jul 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default Can I upgrade to PHP 5.2 easily?

I have ISPConfig 3.0.1.4 installed on CentOS 5.3 (using the excellent perfect server instructions).

Some of the software I want to install for clients on this server requires PHP 5.2. Is there a safe, simple way to upgrade my server to PHP 5.2 without jeopardizing ISPConfig and its components?
Reply With Quote
Sponsored Links
  #2  
Old 28th September 2009, 15:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,499 Times in 4,328 Posts
Default

As far as I know, centos does not offer nwer php packages. Regarding ispconfig, it does not matter which php 5 version you use.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 23rd February 2010, 13:08
tp4 tp4 is offline
Junior Member
 
Join Date: Feb 2010
Posts: 2
Thanks: 0
Thanked 2 Times in 1 Post
Default

This tutorial: http://wiki.centos.org/HowTos/PHP_5.1_To_5.2 worked for my CentOS 5.3 + ISPConfig 2.2.32 setup, it should work for ISPConfig 3 too i guess.

PHP was upgraded from 5.1.6 to 5.2.10, ISPConfig's PHP v5.2.9 was left intact and everything was runnig ok afterwards.

rgds,
tp4
Reply With Quote
The Following 2 Users Say Thank You to tp4 For This Useful Post:
falko (24th February 2010), modir (28th December 2010)
  #4  
Old 28th December 2010, 17:43
modir modir is offline
Junior Member
 
Join Date: Dec 2009
Posts: 22
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Could this link be added to the "The Perfect Server - CentOS 5.5 x86_64 [ISPConfig 3]" guide?

I think many could benefit from it.
Reply With Quote
  #5  
Old 3rd May 2011, 09:57
mxtdn mxtdn is offline
Junior Member
 
Join Date: Dec 2008
Posts: 16
Thanks: 2
Thanked 0 Times in 0 Posts
Default help me please

Quote:
Originally Posted by tp4 View Post
This tutorial: http://wiki.centos.org/HowTos/PHP_5.1_To_5.2 worked for my CentOS 5.3 + ISPConfig 2.2.32 setup, it should work for ISPConfig 3 too i guess.

PHP was upgraded from 5.1.6 to 5.2.10, ISPConfig's PHP v5.2.9 was left intact and everything was runnig ok afterwards.

rgds,
tp4
my problem when i use command:
#yum update

Quote:
---> Package perl-MIME-Lite.noarch 0:3.027-1.el5.rf set to be updated
--> Processing Dependency: perl(Email:ate::Format) >= 1.000 for package: perl-MIME-Lite
---> Package perl-Test-Pod.noarch 0:1.45-1.el5.rf set to be updated
--> Processing Dependency: perl(Pod::Simple) >= 3.07 for package: perl-Test-Pod
--> Processing Dependency: php = 5.1.6 for package: php-eaccelerator
---> Package poppler-utils.x86_64 0:0.5.4-4.4.el5_5.14 set to be updated
---> Package python-libs.x86_64 0:2.4.3-43.el5 set to be updated
---> Package xorg-x11-drv-qxl.x86_64 0:0.0.12-1.2.el5 set to be updated
--> Running transaction check
---> Package PyQt.x86_64 0:3.16-4 set to be updated
--> Processing Dependency: qt >= 3.3.6 for package: PyQt
--> Processing Dependency: sip for package: PyQt
--> Processing Dependency: libqui.so.1()(64bit) for package: PyQt
--> Processing Dependency: libqt-mt.so.3()(64bit) for package: PyQt
---> Package perl-Email-Date-Format.noarch 0:1.002-1.el5.rf set to be updated
---> Package perl-Pod-Simple.noarch 0:3.15-1.el5.rf set to be updated
--> Processing Dependency: perl(Pod::Escapes) >= 1.04 for package: perl-Pod-Simple
--> Processing Dependency: php = 5.1.6 for package: php-eaccelerator
--> Running transaction check
---> Package perl-Pod-Escapes.noarch 0:1.04-5.el5.kb set to be updated
--> Processing Dependency: php = 5.1.6 for package: php-eaccelerator
---> Package qt.x86_64 1:3.3.6-23.el5 set to be updated
---> Package sip.x86_64 0:4.4.5-3 set to be updated
--> Finished Dependency Resolution
php-eaccelerator-5.1.6_0.9.5.2-4.el5.rf.x86_64 from installed has depsolving problems
--> Missing Dependency: php = 5.1.6 is needed by package php-eaccelerator-5.1.6_0.9.5.2-4.el5.rf.x86_64 (installed)
Error: Missing Dependency: php = 5.1.6 is needed by package php-eaccelerator-5.1.6_0.9.5.2-4.el5.rf.x86_64 (installed)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
please help me !
Thanks
Reply With Quote
  #6  
Old 6th May 2011, 16:18
-crisstm- -crisstm- is offline
Banned
 
Join Date: Jul 2008
Posts: 78
Thanks: 3
Thanked 1 Time in 1 Post
 
Default php53

if you want may upgrade to php5.3
http://www.webtatic.com/packages/php53/
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 17:26
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 08:20
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06
ispconfig php 5 errors itamarjp Installation/Configuration 8 25th April 2008 10:20
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18


All times are GMT +2. The time now is 22:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.