Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th September 2009, 04:15
darkhoros darkhoros is offline
Junior Member
 
Join Date: Sep 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default disable SpamAssassin and ClamAV and amavis

Hi,
I have already read the other posts related to same issue and googled enough, but no clear and direct how to, and I just got my ispconfig 3 installed on a vps and I am so afraid to miss things up.

So as title says how to disable all 3 services( SpamAssassin and ClamAV and amavis), as I only need the apache and mysql service on this vps for a high traffic web site, no email options is needed, and when ever things change i can re-enable what I need of them.

Help is apriciated alot.

Thank you all.
Reply With Quote
Sponsored Links
  #2  
Old 25th September 2009, 13:29
damir damir is offline
Senior Member
 
Join Date: Jun 2006
Posts: 375
Thanks: 11
Thanked 51 Times in 42 Posts
Default

Disable the mail module in ispconfig3 under System/Edit Server and than shutdown the services on the server.
Reply With Quote
  #3  
Old 25th September 2009, 13:40
darkhoros darkhoros is offline
Junior Member
 
Join Date: Sep 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,
first of all thank you for your kind reply, but I only need to disable these 3 services, I need the mail module running, just in case, I only need to free up the ram that these 3 services consume as they run.

Thank you.
Reply With Quote
  #4  
Old 26th September 2009, 12:52
robertlouwen robertlouwen is offline
Senior Member
 
Join Date: Apr 2009
Location: Brielle, Netherlands
Posts: 141
Thanks: 20
Thanked 3 Times in 2 Posts
Default

Hello Darkhoros,

I am a Linux noob but I think when you use :

"chkconfig --levels 235 amavisd on"
"chkconfig --levels 235 clamd.amavisd on"

to start ClamAV and Amavis at bootup

and:

"/etc/init.d/amavisd start"
"/etc/init.d/clamd.amavisd start"

to start ClamAV and Amavis again when manualy stopped.

You can use:

"chkconfig --levels 235 amavisd off"
"chkconfig --levels 235 clamd.amavisd off"

to prevent ClamAV and Amavis starting at bootup.
__________________
With Respect, Robert
------------------------------------------------
Fedora 15 - ISPConfig v3.0.3.3
On Dell Optiplex GX270, Pentium 4, 2.8 GHz, 1024 Mb
Reply With Quote
  #5  
Old 27th September 2009, 02:42
darkhoros darkhoros is offline
Junior Member
 
Join Date: Sep 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Talking

Hi,
Thank you for your reply, it gave me some light.

ok I used this to stop current running services.

server# /etc/init.d/amavis stop
server# /etc/init.d/clamav-daemon stop
server# /etc/init.d/spamassassin stop

they stopped and free about 150 MB of ram, very nice, I then editied the apache2.conf file and raise its resources, things went much better from there.

I think using your way to exclude them from start up on boot will work once I change the services name, but I will try this later once I make sure that every thing is stable with my setup.

Again thank you for lighting the way for me.
Reply With Quote
  #6  
Old 7th October 2009, 09:16
mdjhomes mdjhomes is offline
Junior Member
 
Join Date: Oct 2009
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
Default

Thanks for the info, I appreciate it.
Reply With Quote
  #7  
Old 12th December 2009, 09:09
phor phor is offline
Junior Member
 
Join Date: Dec 2006
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Isn't there a way to deactivate these 3 services and leave mail function working? When I simply stop the services, mails are deferred or rather aren't delivered.

I want to use Mail but have no need for spam and virus checking.
Reply With Quote
  #8  
Old 19th December 2009, 12:15
bnight bnight is offline
Junior Member
 
Join Date: Dec 2009
Posts: 4
Thanks: 0
Thanked 3 Times in 3 Posts
 
Default

Hi phor,

I have the same problem as you have and I make some tests about howto disable Amavis on ISPConfig 3.

Here is what you have to do to achieve this:

Edit: /etc/postfix/main.cf

Coment this two lines:

content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings

Looks like this:

#content_filter = amavis:[127.0.0.1]:10024
#receive_override_options = no_address_mappings

Edit: /etc/postfix/master.cf

And comment all lines bellow:

amavis unix - - - - 2 smtp

Looks like this:

#amavis unix - - - - 2 smtp
# -o smtp_data_done_timeout=1200
# -o smtp_send_xforward_command=yes

#127.0.0.1:10025 inet n - - - - smtpd
# -o content_filter=
# -o local_recipient_maps=
# -o relay_recipient_maps=
# -o smtpd_restriction_classes=
# -o smtpd_client_restrictions=
# -o smtpd_helo_restrictions=
# -o smtpd_sender_restrictions=
# -o smtpd_recipient_restrictions=permit_mynetworks,rej ect
# -o mynetworks=127.0.0.0/8
# -o strict_rfc821_envelopes=yes
# -o receive_override_options=no_unknown_recipient_chec ks,no_header_body_checks
# -o smtpd_bind_address=127.0.0.1

Now stop amavis-new and clamd:

/etc/init.d/amavis stop
/etc/init.d/clamav-daemon stop
/etc/init.d/clamav-freshclam stop

Now disable amavis and clamd form starting on system boot:
chkconfig --levels 235 amavis off
chkconfig --levels 235 clamav-daemon off
chkconfig --levels 235 clamav-freshclam off


Now you can restart postfix:

/etc/init.d/postfix restart


And you have working postfix without Amavis and Clamd.

Good Luck.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains spamassassin don't tag clark61 HOWTO-Related Questions 3 9th April 2009 12:53
Amavis trouble with Postfix lordshadow Installation/Configuration 27 26th August 2008 19:19
Update CLAM and Spamassassin herbie HOWTO-Related Questions 1 9th February 2007 09:13
Amavis smtp Problems Wiesemarc Server Operation 3 14th September 2006 18:08
Postfix + Amavis + SpamAssassin + ClamAV michele HOWTO-Related Questions 4 1st July 2006 14:36


All times are GMT +2. The time now is 06:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.