Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd September 2009, 13:33
tssk tssk is offline
Junior Member
 
Join Date: Sep 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Missing configuration files in 3.0.1.4

Hello,

yesterday I tried to install ISPC3 on Debian Stable with postfix but I got several error messages. All was about missing files to copy. After some investigation I found out there are no files in ispconfig3_install/config/maildrop and ispconfig3_install/config/postfix .

Is this OK? (I assume not but I better ask as I am new to the ISPC.)

If this is bug where should I report it?

Thank you,

Tomas Safarik
Reply With Quote
Sponsored Links
  #2  
Old 23rd September 2009, 11:25
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,774
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

There are no files missing in ISPConfig and there is no such bug known. Especially as ISPConfig never had any files in folders like ispconfig3_install/config/maildrop or ispconfig3_install/config/postfix. I guess you installed ISPConfig wrong.

Please follow exactly the ispconfig 3 perfect server guide abd make sure that you execute the install.php exactly as described there. It is needed that you enter the install folder with cd and then execute php install.php!
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 23rd September 2009, 13:40
tssk tssk is offline
Junior Member
 
Join Date: Sep 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello till,

thanks for you reply.

I was following step by step installation documentation in ispconfig3_install/docs/INSTALL_DEBIAN_5.0.txt (except for omitting the quota settings but I don't think this should have influence on postfix configuration).

Quote:
It is needed that you enter the install folder with cd and then execute php install.php!
I did run it exactly this way.

I wonder why are the folders like ispconfig3_install/config/postfix/ even there if no files belongs to them? Why was I getting errors during installation that PHP is unable to find file and copy it to /etc/postfix/main.cf? (Unfortunatelly I didn't save the messages. But I can run the installation again and see if I can reproduce the problem.) And why postfix is not able to run with "fatal: open /etc/postfix/main.cf: No such file or directory" error message?

I'll try to find out what I did wrong. So please take my post just like information.

Thank you

Tomas Safarik
Reply With Quote
  #4  
Old 24th September 2009, 14:49
tssk tssk is offline
Junior Member
 
Join Date: Sep 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Hello,

I did the installation again and the error was:
Code:
Warning: copy(/etc/postfix/main.cf): failed to open stream: No such file or directory in /root/ispconfig3_install/install/lib/installer_base.lib.php on line 488
So I found the problem was that the initial postfix configuration was wrong - missong main.cf file and installation script couldn't modify it. So the problem was on my system not in the ISPConfig.

So thanks again for your reply.

Tomas Safarik
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
All my mail is going to /var/mail/vmail _sluimers_ Installation/Configuration 21 10th January 2011 13:21
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 17:26
Apache wont serve my files anymore:( wotIsCmd Server Operation 2 17th July 2009 20:24
The system is currently updating the configuration files. warlock General 8 21st February 2009 18:15
Help....package missing sbovisjb1 Installation/Configuration 3 31st March 2006 11:14


All times are GMT +2. The time now is 12:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.