#1  
Old 24th September 2009, 23:44
sfunk1x sfunk1x is offline
Member
 
Join Date: Jun 2009
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default PureFTPd / MySQL / CentOS 5.3

Hey all, back again!

This time, I've followed this how-to (yes, I know it's for centos 5.0 and I'm running 5.3):

http://www.howtoforge.com/virtual_ho...ysql_centos5.0


The package installed OK and I was able to add the user & db no problem - edited the pure-ftpd.conf file without issue and edited the pureftpd-mysql.conf file without issue. Passwords match, I can log into the ftpd db without issue with the user that I created.

The problem is that when I connect to the FTP server it immediately disconnects after the user enters a password:

1. Connect to ftp via ftp client
2. Prompted for username - entered
3. Prompted for password - entered
4. Disconnected with the following messages:

Code:
421 Service not available, remote server has closed connection
Login failed.
No control connection for command: No such file or directory
This was rcv'd by just using ftp localhost at console (locally, obviously).. from remote, you see this:

Code:
331 User sean OK. Password required
Password:
Connection closed by remote host.
In /var/log/messages (pureftpd.log is completely empty, which doesn't help):

Code:
Sep 24 14:40:47 host pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
Sep 24 14:41:53 host pure-ftpd: (?@xx.xxx.xxx.xxx) [INFO] New connection from xx.xxx.xxx.xxx
There are no errors saying mysql couldn't authenticate or if there was a problem creating the folder or not.

Anyone have any thoughts on what I may have missed?

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 25th September 2009, 05:51
sfunk1x sfunk1x is offline
Member
 
Join Date: Jun 2009
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Solved.

I had set my home directory in the ftpuser table to be /home/sean, when that folder was my system user folder. Apparently there was a permissions problem (although that was not in the logs at all) and immediately killed the connection.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Centos 5.2 + ISPConfig 3 tutorial - Problem with email tanakskool Server Operation 1 3rd June 2009 16:22
have the problem with mydns on CentOS 5.3 x86_64 thaibinhtt Installation/Configuration 1 26th May 2009 08:59
PHP & PowerDNS and PowerAdmin on CentOS 5.3 need_a_linux_brain HOWTO-Related Questions 9 4th May 2009 15:42
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 09:11
Install ISPConfig on CentOS Server, in brief gfts Tips/Tricks/Mods 11 4th April 2006 08:29


All times are GMT +2. The time now is 16:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.