Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th March 2010, 12:23
Wired_Eyed Wired_Eyed is offline
Junior Member
 
Join Date: Mar 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Question Dont know how its running..

Ok, well im all square-eyed now, spent far too much time on this when it should be easy apparently, haha..

Im hosting 2 websites and and using no-ip for simplistic reasons
one of them has email..

i followed this guide here
http://www.howtoforge.com/virtual-us...dora-12-x86_64
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Fedora 12 x86_64)

First problems first....

followed the guide to the T but adjusted where required due to only being i686.

Problem arises here @ section

"16 Populate The Database And Test"

followed the guide and was told to do the following...

Code:
INSERT INTO `users` (`email`, `password`, `quota`) VALUES ('sales@example.com', ENCRYPT('secret'), 10485760);
MySQL spits our the following
Code:
ERROR 1054 (42S22): Unknown column 'quota' in 'field list'
no idea whats wrong there or where to start looking to fix


------------------------------------------------------------------------------------------------

Second problem

no-ip handles the domains external dns for other internet users to find and view and email to.

issue is the bind dns problem which is totally wacked...
let me explain..

i have 3 pc's, 1 is a server - others are browsing & gaming machines...

server has 2 nic's in it..
other details are as follows

192.168.1.2 = adsl2+ router

server pc
192.168.1.1 = eth1 - goes to the router
192.168.0.1 = eth0 - goes to network switch

browsing pc
192.168.0.12

gaming pc
192.168.0.14

with the gateway & dns for the internal pc's being

192.168.0.1 = eth0
...

I have routing sorted, kinda...

eg,
internal network pc's can say browse the 2 hosted sites - but not the internet.
The server pc cannot browse the net either

what i cannot figure out for the life of me is how to use bind correctly..
or howto configure resolve.conf and hosts etc..

basically i want the internal pc's to use 192.168.0.1 as the dns & Gateway &
if they visit either of the hosted domains

example.com axample.com

they are routed to that and not to the web then back to my router login..

I also still want the internal pc's of course to browse the web too though..

Some more information incase its a simple error

ifconfig
Code:
eth0 Link encap:Ethernet HWaddr 00:02:44:67:9E:8B
inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::202:44ff:fe67:9e8b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:84047 errors:0 dropped:0 overruns:0 frame:0
TX packets:81387 errors:0 dropped:0 overruns:0 carrier:0
collisions:6034 txqueuelen:1000
RX bytes:7183332 (6.8 MiB) TX bytes:11576500 (11.0 MiB)
Interrupt:10 Base address:0x6000

eth1 Link encap:Ethernet HWaddr 00:04:5A:6A:29:40
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::204:5aff:fe6a:2940/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:14934 errors:0 dropped:0 overruns:0 frame:0
TX packets:16016 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:6973047 (6.6 MiB) TX bytes:2577524 (2.4 MiB)
Interrupt:11 Base address:0xe000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1890 errors:0 dropped:0 overruns:0 frame:0
TX packets:1890 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:205230 (200.4 KiB) TX bytes:205230 (200.4 KiB)
Route

Code:
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 complex.example 255.255.255.0 UG 0 0 0 eth1
192.168.1.0 * 255.255.255.0 U 0 0 0 eth1
192.168.0.0 * 255.255.255.0 U 0 0 0 eth0
default 192.168.1.2 0.0.0.0 UG 0 0 0 eth1
/var/named/chroot//etc/named.conf
Code:
options {
directory "/etc";
pid-file "/var/run/named/named.pid";
};

zone "www.example.net" {
type master;
file "/var/named/www.example.net.hosts";
};
zone "www.axample.net" {
type master;
file "/var/named/www.axample.net.hosts";
};
zone "." {
type hint;
file "/var/named/db.cache";
};
/var/hosts
Code:
# hostname complex.example.net added to /etc/hosts by anaconda
127.0.0.1 localhost.localdomain localhost complex.example.net
192.168.1.1 complex.example.net localhost
::1 localhost6.localdomain6 localhost6 complex.example.net
/var/resolv.conf
Code:
# Generated by NetworkManager


# No nameservers found; try putting DNS servers into your
# ifcfg files in /etc/sysconfig/network-scripts like so:
#
# DNS1=xxx.xxx.xxx.xxx
# DNS2=xxx.xxx.xxx.xxx
# DOMAIN=lab.foo.com bar.foo.com
Reply With Quote
Sponsored Links
  #2  
Old 15th March 2010, 14:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

Quote:
Originally Posted by Wired_Eyed View Post
Ok, well im all square-eyed now, spent far too much time on this when it should be easy apparently, haha..

Im hosting 2 websites and and using no-ip for simplistic reasons
one of them has email..

i followed this guide here
http://www.howtoforge.com/virtual-us...dora-12-x86_64
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Fedora 12 x86_64)

First problems first....

followed the guide to the T but adjusted where required due to only being i686.

Problem arises here @ section

"16 Populate The Database And Test"

followed the guide and was told to do the following...

Code:
INSERT INTO `users` (`email`, `password`, `quota`) VALUES ('sales@example.com', ENCRYPT('secret'), 10485760);
MySQL spits our the following
Code:
ERROR 1054 (42S22): Unknown column 'quota' in 'field list'
no idea whats wrong there or where to start looking to fix
Apparently something went wrong when you created the users table:

Code:
CREATE TABLE users (
email varchar(80) NOT NULL,
password varchar(20) NOT NULL,
quota bigint(20) DEFAULT '10485760',
PRIMARY KEY (email)
) TYPE=MyISAM;
Do you have phpMyAdmin installed? Please check if the quota column exists.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 4 TPS mail problem Hagforce HOWTO-Related Questions 13 10th February 2010 18:23
High on Lenny - Lvm Mount Problem Serverman Technical 1 23rd June 2009 16:26
Xen on Ubuntu kmand HOWTO-Related Questions 17 5th March 2009 18:43
install Net::DNS chrno Installation/Configuration 4 5th September 2006 17:01
WARNING: services not running MicCo Installation/Configuration 31 4th September 2006 12:16


All times are GMT +2. The time now is 21:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.