Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th April 2006, 20:23
palkat palkat is offline
Member
 
Join Date: Aug 2005
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
Default Webmail Relay Error

Here is a new issue that poped up today.
I get this when sending email any one that is not on my ispconfig server, IE: hotmail, aol, local isp's, etc....
---
It was not possible to send this e-mail

SMTP Error: Recipient not accepted. Verify your relay rules

« Back
---
I always email to hotmail with no issues till today..any advice? I get this on any hotmail address or other domains in general.

Last edited by palkat; 17th April 2006 at 21:10.
Reply With Quote
Sponsored Links
  #2  
Old 17th April 2006, 21:43
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

Do you have this only with webmail or also with your pop3 e-mailclient?
Did you change your /etc/postfix/main.cf file?
Please check it and if you need to change it, restart postfix!

Maybe it is possible that your server is blacklisted due an open relay.
(I do not hope so)

You can check if you have an open relay at:
http://www.abuse.net/relay.html


Hans
Reply With Quote
  #3  
Old 18th April 2006, 00:12
palkat palkat is offline
Member
 
Join Date: Aug 2005
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
Default

It is also doing it in my pop3/e-mail client software of outlook and mac mail on my mac. so it is not just web mail.

I have not made any changes to my main.cf sense i built this system, and that was months ago where as this problem just started.

I did reboot my router and it all kicked in with one exception..so my router was causing 95% of it.

now the remaining problem is i can use my pop3/outlook mail program using my ispconfig server smtp server to send to HOTMAIL and i get it. BUT when i use the web mail to send to HOTMAIL hot mail never gets it. (note: aol and others get my web mail but not hotmail)

here is a copy of the mail log after i sent a message in WEBMAIL to my HOTMAIL account (still yet to get the message in hotmail)

---
Apr 17 17:01:22 server pop3d: Connection, ip=[::ffff:127.0.0.1]
Apr 17 17:01:22 server pop3d: LOGIN, user=one***.com_****, ip=[::ffff:127.0.0.1]
Apr 17 17:01:22 server pop3d: LOGOUT, user=one***.com_****, ip=[::ffff:127.0.0.1], top=0, retr=0, time=0
Apr 17 17:01:35 server postfix/smtpd[8386]: connect from localhost[127.0.0.1]
Apr 17 17:01:35 server postfix/smtpd[8386]: A1C6034128: client=localhost[127.0.0.1]
Apr 17 17:01:35 server postfix/cleanup[8428]: A1C6034128: message-id=<20060417230135.A1C6034128@one****.com>
Apr 17 17:01:35 server postfix/qmgr[6053]: A1C6034128: from=<****@one****.com>, size=740, nrcpt=1 (queue active)
Apr 17 17:01:35 server postfix/smtpd[8386]: disconnect from localhost[127.0.0.1]
Apr 17 17:01:35 server pop3d: Connection, ip=[::ffff:127.0.0.1]
Apr 17 17:01:35 server postfix/smtp[8429]: warning: connect to private/tlsmgr: No such file or directory
Apr 17 17:01:35 server pop3d: LOGIN, user=one***.com_****, ip=[::ffff:127.0.0.1]
Apr 17 17:01:35 server pop3d: LOGOUT, user=one***.com_****, ip=[::ffff:127.0.0.1], top=0, retr=0, time=0
Apr 17 17:01:36 server postfix/smtp[8429]: warning: connect to private/tlsmgr: No such file or directory
Apr 17 17:01:36 server postfix/smtp[8429]: warning: problem talking to server private/tlsmgr: No such file or directory
Apr 17 17:01:36 server postfix/smtp[8429]: warning: no entropy for TLS key generation: disabling TLS support
Apr 17 17:01:37 server postfix/smtp[8429]: A1C6034128: to=<*****@hotmail.com>, relay=mx3.hotmail.com[65.54.245.72], delay=2, status=sent (250 <20060417230135.A1C6034128@one*****.com> Queued mail for delivery)
Apr 17 17:01:37 server postfix/qmgr[6053]: A1C6034128: removed
Apr 17 17:01:39 server pop3d: Connection, ip=[::ffff:68.35.83.14]

---

Last edited by palkat; 18th April 2006 at 01:12.
Reply With Quote
  #4  
Old 18th April 2006, 07:17
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Exclamation

To be honest with you,

Normally i do not use Hotmail, but i wanted to check wat was happening...
I did a test and i discovered that when i send an e-mail to hotmail, it will never reach the mailbox...
I guess we need a little help here.


Hans

Last edited by Hans; 18th April 2006 at 08:02.
Reply With Quote
  #5  
Old 18th April 2006, 10:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Please ask Hotmail why they are blocking emails that originate directly from localhost. Maybe it's because of missing SPF records or PTR records or some other stupid spam rule...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 18th April 2006, 14:51
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

Yes we should do that.

In The Netherlands a lot of people can only send e-mail using the SMTP-server of their Internet Service Provider.
Otherwise they will have always a Relay error.
Reason for this is an ANTI-SPAM policy.

My instruction to my clients:
Use the POP3-server at my server and use your own SMTP-server.

Maybe this is NOT a sulution for the problem, but it is a practical one.

Hans
Reply With Quote
  #7  
Old 18th April 2006, 15:10
palkat palkat is offline
Member
 
Join Date: Aug 2005
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Please ask Hotmail why they are blocking emails that originate directly from localhost. Maybe it's because of missing SPF records or PTR records or some other stupid spam rule...
Done...now wait and hear their pre-recorded lame answer that is way off beat.

in the meantime Falko, is there a way to trick the webmail in ISPConfig to get the messages through being as the messages DO GO THROUGH when i use the ispconfig servers SMTP via Outlook?
Reply With Quote
  #8  
Old 18th April 2006, 20:24
palkat palkat is offline
Member
 
Join Date: Aug 2005
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Okay I found something out...I can get mail in hotmail when i address to multiple people in a field like to or cc but ONLY as long as the hotmail address is not last and here is why.

I found in AOL mail & hotmail looking at the headers of message's sent from my ISPConfig's webmail that it is putting quotes and @domain.com added to the end of the last email address in the address field.

here is an example of one that i got in hotmail because the hotmail address was not the last address:

---

From : Shane O'Neill <shane@*******.com>
Reply-To : "Shane O'Neill" <shane@*******.com>
Sent : Tuesday, April 18, 2006 5:13 AM
TO: *****@hotmail.com, "*****@aim.com"@on****cs.com
Subject : webmail sent tuesday! test 2
---

If you notice in bold it puts in quotes and adds my servers domain to the last address.
What is causing this???
Reply With Quote
  #9  
Old 18th April 2006, 22:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by palkat
in the meantime Falko, is there a way to trick the webmail in ISPConfig to get the messages through being as the messages DO GO THROUGH when i use the ispconfig servers SMTP via Outlook?
You can relay through another mail server: http://www.howtoforge.com/forums/sho...4&postcount=18

Quote:
If you notice in bold it puts in quotes and adds my servers domain to the last address.
What is causing this???
What are the values of append_at_myorigin and append_dot_mydomain in /etc/postfix/main.cf? Do you have something like
Code:
canonical_maps = hash:/etc/postfix/canonical
in /etc/postfix/main.cf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 19th April 2006, 01:15
palkat palkat is offline
Member
 
Join Date: Aug 2005
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by falko
What are the values of append_at_myorigin and append_dot_mydomain in /etc/postfix/main.cf?
I do not have append_at_myorigin or append_dot_mydomain
in my /etc/postfix/main.cf


Quote:
Originally Posted by falko
Do you have something like
Code:
canonical_maps = hash:/etc/postfix/canonical
in /etc/postfix/main.cf?
Yes i have this exactly.


here is my main.cf:
---
readme_directory = /usr/share/doc/packages/postfix/README_FILES
inet_protocols = all
biff = no
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
#virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
myhostname = $mydomain
program_directory = /usr/lib/postfix
inet_interfaces = all
masquerade_domains =
#mydestination = $myhostname, localhost.$mydomain
defer_transports =
disable_dns_lookups = no
relayhost =
mailbox_command =
mailbox_transport =
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
# smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_ relay_domains
smtpd_recipient_restrictions =
reject_invalid_hostname,
reject_unknown_recipient_domain,
reject_unauth_pipelining,
permit_mynetworks,
permit_sasl_authenticated,
reject_unauth_destination,
reject_rbl_client relays.ordb.org,
reject_rbl_client opm.blitzed.org,
reject_rbl_client list.dsbl.org,
reject_rbl_client sbl.spamhaus.org,
reject_rbl_client blackholes.easynet.nl,
reject_rbl_client cbl.abuseat.org,
permit
smtp_sasl_auth_enable = no
smtpd_sasl_auth_enable = yes
smtpd_use_tls = yes
smtp_use_tls = yes
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000
mydomain = oneillpcs.com
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_tls_auth_only = no
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 10 perfect setup error .. keybd_user Installation/Configuration 6 9th April 2006 17:06
Fresh Install on Debian cksrealm Installation/Configuration 12 22nd February 2006 16:14
Installation Fails... :( cyberstorm Installation/Configuration 1 15th January 2006 18:07
Could not make OpenSSL yontengyatso Installation/Configuration 3 3rd November 2005 10:50
Install stop at uuwish, UUDeview SeaWolf Installation/Configuration 6 4th October 2005 23:53


All times are GMT +2. The time now is 13:15.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.