Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd September 2009, 21:30
vrsho vrsho is offline
Junior Member
 
Join Date: Sep 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default problem with mailserver: Connection dropped by IMAP server

Hello.. i have a problem with mailserver.
I have all configured like on this tutorial but i always get this error when i try to login via squirrelmail "ERROR: Connection dropped by IMAP server.".

Mail.log
Quote:
Sep 21 19:00:36 server imapd: LOGOUT, ip=[::1], rcvd=53, sent=332
Sep 21 19:00:46 server imapd: Connection, ip=[::1]
Sep 21 19:00:46 server imapd: chdir drodles.com/vanja/: No such file or directory
When im sending a welcome mail to this user, i get this:
Quote:
Message contents

This is the mail system at host drodles.com.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<vanja@drodles.com>: unknown user: "vanja"

sry for my bad english
Reply With Quote
Sponsored Links
  #2  
Old 24th September 2009, 14:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

What's in /etc/postfix/main.cf?

Does vanja@drodles.com exist in the database?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 24th September 2009, 19:17
vrsho vrsho is offline
Junior Member
 
Join Date: Sep 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

here is thee postfix main config:
Quote:
readme_directory = /usr/share/doc/postfix
html_directory = /usr/share/doc/postfix/html
myhostname = server.drodles.com
mydestination = server.drodles.com, localhost, localhost.drodles.com
mynetworks = 127.0.0.0/8
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /home/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated
smtpd_use_tls = yes
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_create_maildirsize = yes
virtual_maildir_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota."
virtual_overquota_bounce = yes
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
relayhost = mail.t-com.hr
mailbox_command = procmail -a "$EXTENSION"
smtpd_sasl_security_options =
fallback_relay = mail.t-com.hr
Yes..the user exist in the database.. thanks


EDIT: In Outlook Express i get this error: "Your IMAP server wishes to alert you to the following: Account's MailBox directory is not owned by the corect UID or GID.

Last edited by vrsho; 24th September 2009 at 19:35.
Reply With Quote
  #4  
Old 25th September 2009, 13:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

What's the output of
Code:
ls -la /home/vmail/
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 27th September 2009, 01:43
FXFman1209 FXFman1209 is offline
Junior Member
 
Join Date: Sep 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am having this same problem. It seems like when mail is being sent to someone, the maildir is not being created because there are no files in /home/vmail.

What exactly should I be looking for to fix this?
Reply With Quote
  #6  
Old 27th September 2009, 01:53
FXFman1209 FXFman1209 is offline
Junior Member
 
Join Date: Sep 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well actually, for some reason, mine just magically started working...

However when I log into squirrelmail, it just shows me a blank page. This is what the mail log says:

Sep 26 18:52:49 pegasus imapd: Connection, ip=[::1]
Sep 26 18:52:49 pegasus imapd: LOGIN, user=fxfitz@**.com, ip=[::1], port=[40348], protocol=IMAP
Sep 26 18:52:49 pegasus imapd: LOGOUT, user=fxfitz@**.com, ip=[::1], headers=0, body=0, rcvd=30, sent=238, time=0


So for some reason it is logging me out right away. Any ideas??
Reply With Quote
  #7  
Old 27th September 2009, 13:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Please make sure you introduced no syntax error when you edited the change_sqlpass plugin.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 28th September 2009, 20:51
FXFman1209 FXFman1209 is offline
Junior Member
 
Join Date: Sep 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

What do you mean the no syntax error??
Reply With Quote
  #9  
Old 29th September 2009, 15:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
 
Default

Maybe you forgot a quotation mark or something like that when you modified the config.php file.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail not working epicuniversal General 5 13th June 2009 09:24
Centos 5.2 + ISPConfig 3 tutorial - Problem with email tanakskool Server Operation 1 3rd June 2009 17:22
Connection dropped by IMAP server gublym Server Operation 5 23rd January 2009 10:47
ERROR: Connection dropped by IMAP server. spaceuser HOWTO-Related Questions 2 15th June 2008 07:53
Problems with Postfix Mysql Courier PatrickAdrichem Installation/Configuration 3 13th April 2007 16:44


All times are GMT +2. The time now is 06:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.