Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 27th August 2005, 17:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,597 Times in 4,407 Posts
Default

Quote:
Originally Posted by Roman
I have a router sitting on a static IP (216.188.249.98) and server connected to the router and assigned the 192.168.1.2. In order to see my website inside the firewall (router) I have to type 192.168.1.2 and not www.rcbazaar.com. Linksys told me that this is OK, but I really think there must be a way to work around this. Our mail accounts are hosted outside our intranet with a web hosting company, which is also holding our DNS record.
Is it possible that all the problems with sendmail are actually DNS problems and how can I test this?

Appreciate you help !

Roman
You can test if this are DNS or routing problems:

Please try to connect to the yahoo mailserver via telnet on the shell of your server. Enter the command:

Code:
telnet mx4.mail.yahoo.com 25
When you got an answer from the serve, you can close the connection by typing "quit".

The testsession should look similar like this:

Code:
# telnet mx4.mail.yahoo.com 25
Trying 68.142.202.12...
Connected to mta-v4.mail.vip.mud.yahoo.com.
Escape character is '^]'.
220 mta230.mail.mud.yahoo.com ESMTP YSmtp service ready
quit
221 mta230.mail.mud.yahoo.com
Connection closed by foreign host.
If not, please post the output in the forum.
Reply With Quote
Sponsored Links
  #12  
Old 27th August 2005, 18:25
Roman Roman is offline
Junior Member
 
Join Date: Aug 2005
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

It only comes to:

[root@www ~]# telnet mx4.mail.yahoo.com 25
Trying 68.142.202.11...

and then stays there. On my router I have both ports 25 and 110 TCP enabled.
I guess we are getting closer to the real problem.
??

Thanks,
Roman
Reply With Quote
  #13  
Old 27th August 2005, 18:35
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,597 Times in 4,407 Posts
Default

Quote:
Originally Posted by Roman
It only comes to:

[root@www ~]# telnet mx4.mail.yahoo.com 25
Trying 68.142.202.11...

and then stays there. On my router I have both ports 25 and 110 TCP enabled.
I guess we are getting closer to the real problem.
??
Name resolution works on your server, beacuse it resolves mx4.mail.yahoo.com to the correct IP 68.142.202.11

Yes were getting closer It seems you have firewall or something like that in your router enabled, that blocks outbound connections (YourServer => Internet) on Port 25.
Reply With Quote
  #14  
Old 28th August 2005, 08:29
Roman Roman is offline
Junior Member
 
Join Date: Aug 2005
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Since I don't have a DNS running on my machine, does it mean that yahoo gets resolved externally? If so, than it does go out through 25, right? Is it possible that some of the settings I made in Evolution have messed up the sendmail?

Thanks,

Roman
Reply With Quote
  #15  
Old 28th August 2005, 11:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,597 Times in 4,407 Posts
Default

Quote:
Originally Posted by Roman
Since I don't have a DNS running on my machine, does it mean that yahoo gets resolved externally?
Yes. But in many cases you set the nmeserver simply to the IP of your router and the router (gateway) resolves the names for you.

Quote:
Originally Posted by Roman
If so, than it does go out through 25, right?
No, nameservice is port 53.

Quote:
Originally Posted by Roman
Is it possible that some of the settings I made in Evolution have messed up the sendmail?
No, your problems have nothing to do with sendmail. We tried to connect via telnet on port 25, telnet is independant from sendmail, and the connection was not possible. It is a problem with your router or another firewall or maybe your internet provider blocks connections on port 25 to other servers that the mailrelay of your provider.
Reply With Quote
  #16  
Old 30th August 2005, 05:36
Roman Roman is offline
Junior Member
 
Join Date: Aug 2005
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Very impressive. I would have never expected my ISP provider to block traffic on port 25.
As soon as I called them and they changed the setting, everything worked like a champ.

Thank you very much

Roman
Reply With Quote
  #17  
Old 1st September 2005, 00:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

Quote:
Originally Posted by Roman
I would have never expected my ISP provider to block traffic on port 25.
I have the same problem here in my Internetcafé that I have to use during my holidays. I hope some day an internet connection will be as common as a shower in an accommodation...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[error] an unkown filter was not added: PHP Arien Installation/Configuration 12 7th October 2006 15:17
PHP not working jefash General 10 28th May 2006 09:48
Cannot compile new PHP with apxs olli Installation/Configuration 11 4th March 2006 16:32
Multiple domains jysse Installation/Configuration 2 10th August 2005 12:22
Apache + PHP lola Server Operation 1 25th April 2005 14:41


All times are GMT +2. The time now is 02:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.