#1  
Old 25th April 2006, 21:00
provell provell is offline
Member
 
Join Date: Apr 2006
Posts: 97
Thanks: 0
Thanked 0 Times in 0 Posts
Default can not send mail

Hy everyone,


I just did the "The Perfect Setup - Debian Sarge (3.1)"
Then I dit an error free install of ISPCONFIG.
Set up the correct ports on the firewall.

All looked well until i tryed to send and receive email.
Checking out the forum everyone had different problems.
And at least they had error messages, I DON'T!!
It is hard to troubleshout without error messages.


Here is the thing:

I am able te receive email from everyone outside my domain.
I can send my self an email
I can send other users in my domain an email.
I can receive email from other users in my domain.
But I can not send email to others outside my domain,
to blabla@yahoo.com for example.

The big problem here is that the email is send, thus gets out of my outbox.
But I do not get a send error or a "could not deliver" or some other error??
It just disapeers???
The same thing hapens when I use webmail (so it can't be a local setting on my desktop).

I have checked the the mail.log and there I see something hapening but I can not understand it.

Mail.log:
websrv1 postfix/smtpd[1215]: connect from unknown[10.0.0.150]
websrv1 postfix/smtpd[1215]: 5B0D2D20C8: client=unknown[10.0.0.150], sasl_method=LOGIN, sasl_username=scarto
websrv1 postfix/cleanup[1218]: 5B0D2D20C8: message-id=<004a01c6687d$8888b860$9600000a@winxp>
websrv1 postfix/qmgr[32679]: 5B0D2D20C8: from=<info@scarto.xs4all.nl>, size=1343, nrcpt=1 (queue active)
websrv1 postfix/smtpd[1215]: disconnect from unknown[10.0.0.150]
websrv1 postfix/smtp[1219]: connect to yahoo.com[216.109.112.135]: server dropped connection without sending the initial SMTP greeting (port 25)

Mail.log
websrv1 postfix/smtp[1219]: connect to yahoo.com[66.94.234.13]: Connection timed out (port 25)
websrv1 postfix/smtp[1219]: 5B0D2D20C8: to=<scartomail@yahoo.com>, relay=none, delay=31, status=deferred (connect to yahoo.com[66.94.234.13]: Connection timed out)


Time out??
I have disabled the firewall on the server and only use the ports in the adsl-router. port 25/tcp, 110/tcp and just to be sure 143/tcp.

If anybody would be so kind to tell me where to find the anwser for this problem, I would be verrrrry thankfull!!
Reply With Quote
Sponsored Links
  #2  
Old 25th April 2006, 21:57
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Is your server hosted in a datacenter or on a DSL line?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 25th April 2006, 22:36
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default port 25 blocked ?

It's possible that if your server is at home, your ISP is blocking your port 25.
Which means that you can only send e-mail using the SMTP-server of your own ISP-provider. Like here in the Netherlands, most ISP's do so.
The reason is an anti-SPAM policy.

I do not say that it is your problem, but please check this out, it is good to know.

Hans
Reply With Quote
  #4  
Old 26th April 2006, 12:43
provell provell is offline
Member
 
Join Date: Apr 2006
Posts: 97
Thanks: 0
Thanked 0 Times in 0 Posts
Default smtp handshake

Hy geys, thanks for the response.

Yes, I am using an ADSL line and a certified router.

For the port isue I called my ISP and they sayd that the port should be open.
The even tested this and were able to telnet directly on port 25 to my postfix server.
So the port 25 blocked is defently not an isue here.

I have done some checking myself on the SMTP connection and read about a SMTP handshake.
My ISP is XS4ALL.NL.
The gave me a host/DNS name of SCARTO.XS4ALL.NL
I have named my server WEBSRV1 with the extension SCARTO.XS4ALL.NL
Thus the whole dns string to reach my postfix server would be:
WEBSRV1.SCARTO.XS4ALL.NL

This is dns string is not reachable from the internet and might be a problem for the "SMTP greeting (port 25)".
I wil try to change my host name from WEBSRV1 to SCARTO and wil do the same thing for my domain name.
From SCARTO.XS4ALL.NL to XS4ALL.NL.
(should have done that during installation of course)

As this server is not setup with ISPCONFIG would you be so kind to tell me what config files I have to change to make this happen?
Or is the advise to start all over again a better idea?
Reply With Quote
  #5  
Old 26th April 2006, 14:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by provell
I have done some checking myself on the SMTP connection and read about a SMTP handshake.
My ISP is XS4ALL.NL.
The gave me a host/DNS name of SCARTO.XS4ALL.NL
I have named my server WEBSRV1 with the extension SCARTO.XS4ALL.NL
Thus the whole dns string to reach my postfix server would be:
WEBSRV1.SCARTO.XS4ALL.NL

This is dns string is not reachable from the internet and might be a problem for the "SMTP greeting (port 25)".
Then you must create a DNS record for WEBSRV1.SCARTO.XS4ALL.NL. Ask your provider to do so.

Quote:
Originally Posted by provell
As this server is not setup with ISPCONFIG would you be so kind to tell me what config files I have to change to make this happen?
Or is the advise to start all over again a better idea?
If you don't want to create a DNS record for WEBSRV1.SCARTO.XS4ALL.NL, then you must edit /etc/postfix/main.cf, /etc/hostname and maybe /etc/hosts. Restart Postfix afterwards.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 26th April 2006, 16:25
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Talking

XS4ALL is not blocking ports indeed.
I have XS4ALL at home too
Reply With Quote
  #7  
Old 26th April 2006, 17:41
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,033
Thanks: 261
Thanked 150 Times in 130 Posts
Default

XS4all (in Holland) is one of the few ISP's that still got all ports open (I also have XS4all)

Also.. Make sure that you have a working SPF record if you send mail to Yahoo and or Hotmail.. If you do not have this, the email will never arrive!

If you do have a SPF record, the email might (will) be in the 'bulk' mailbox, so have a look in there!

Did you try emailing to a non yahoo/hotmail email address? If not.. Give it a test.. Your email might work fine!

Last edited by edge; 26th April 2006 at 17:44.
Reply With Quote
  #8  
Old 27th April 2006, 17:23
provell provell is offline
Member
 
Join Date: Apr 2006
Posts: 97
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Thanks!!

Thanks for all the advise.

I did some extra googling on the email-log messages.
And it all came down to a closed port 25.
Although I had a portforwarding rule on my router and it was reachable from the internet with telnet.

So I thought what happens if I close the port(delete the forwarding rule).
Ha!!! Same error messages in my log.

So I went back to the shop where I bougt the router a few days ago and returned it.
I got a brand new router, installed it, and.... ta ta ta !!! It worked.
All the test mails that were still in my que were send.

PFFFFF Wow

Whel thanks anyway, I now have a beatifull ISPCONFIG running on my DEBIAN machine.
thanks for the help all of you, hope to be of any help soon to.

Rgds Edo
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Not receiving any incoming mail. Jcorrea920 General 11 3rd April 2010 13:08
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
send and receve mail on centos 4.3 tesquenure Installation/Configuration 11 25th April 2006 21:15
Read but not send mail briggers HOWTO-Related Questions 24 7th April 2006 19:22
Mail server jas_esp Server Operation 1 7th December 2005 18:17


All times are GMT +2. The time now is 23:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.