Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #31  
Old 21st September 2009, 17:35
soch soch is offline
Junior Member
 
Join Date: Sep 2009
Posts: 23
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Antennipasi View Post
mydns.conf seems ok.

Go to http://networking.ringofsaturn.com/Tools/dig.php

and enter "@externalIPofrouter domain1.com" ,does it answer?

Is your workstation behind same router? If so, can you ssh to server with externalIPofrouter? Forward port 22 before testing.

If you can do that, maybe problem is in your workstations name resolution. Try to edit host-file and put "externalIPofrouter domain1.com" there.
output of above website's dig:
; (1 server found)
;; global options: printcmd
;; connection timed out; no servers could be reached

Yes, it's the same router. No I am unable to ssh, it times out. I did fwd port 22. I put a line in /etc/hosts file.
Reply With Quote
Sponsored Links
  #32  
Old 21st September 2009, 17:52
giftsnake giftsnake is offline
Senior Member
 
Join Date: Jan 2009
Posts: 108
Thanks: 15
Thanked 9 Times in 8 Posts
Default

what you have:
Router port forwarding settings:
ameserver - TCP 53 -> 53
nameserver1 - UDP 53 -> 53
HTTP - TCP Any -> 80
HTTP Web Access - TCP Any -> 3127-3128
TCP Any -> 80-81
TCP Any -> 8080
TCP Any -> 8000
TCP Any -> 8888
HTTP Secondary - TCP Any -> 8080
HTTPS - TCP Any -> 443
HTTPS Secondary - TCP Any -> 8443


what you need:
HTTP - TCP: 80 -> 80
HTTPS - TCP 443 -> 443
HTTP - TCP: 8080 -> 8080
HTTPS - TCP: 8443 -> 8443
SSH - TCP: 22 -> 22
NAMESERVER - TCP: 53 -> 53

NOTHING else
all the "any -> xyz" forwardings do bad things!
Reply With Quote
The Following User Says Thank You to giftsnake For This Useful Post:
soch (21st September 2009)
  #33  
Old 21st September 2009, 19:10
soch soch is offline
Junior Member
 
Join Date: Sep 2009
Posts: 23
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Here's my latest router settings:
nameserver - TCP 53 -> 53
http - TCP 80 -> 80
TCP 443 -> 443
TCP 8080 -> 8080
TCP 8443 -> 8443
TCP 22 -> 22
Reply With Quote
  #34  
Old 21st September 2009, 20:32
Antennipasi Antennipasi is offline
ISPConfig Developer
 
Join Date: Dec 2008
Location: Finland
Posts: 67
Thanks: 6
Thanked 13 Times in 12 Posts
Default

Quote:
Originally Posted by soch View Post
Here's my latest router settings:
Is it working now? Clearly previous external dig-tets showed your router did not let outer world in.
Althought UDP for nameserver is not strictly needed, i would recommend to enable it too.
Reply With Quote
  #35  
Old 22nd September 2009, 00:45
soch soch is offline
Junior Member
 
Join Date: Sep 2009
Posts: 23
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Antennipasi View Post
Is it working now? Clearly previous external dig-tets showed your router did not let outer world in.
Althought UDP for nameserver is not strictly needed, i would recommend to enable it too.
No, its not working. When I put external IP it takes me to my router admin login page.

Added UDP for port 53.

External dig:
Output of dig W.X.Y.Z

Code:
; <<>> DiG 9.4.3-P2 <<>> W.X.Y.Z
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 42185
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;W.X.Y.Z.			IN	A

;; AUTHORITY SECTION:
.			10740	IN	SOA	A.ROOT-SERVERS.NET. NSTLD.VERISIGN-GRS.COM. 2009092101 1800 900 604800 86400
;; Query time: 0 msec
;; SERVER: 71.252.219.43#53(71.252.219.43)
;; WHEN: Mon Sep 21 17:41:48 2009
;; MSG SIZE  rcvd: 104
Reply With Quote
  #36  
Old 22nd September 2009, 10:41
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,485
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

Maybe your internet access provider is blockin these ports?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #37  
Old 22nd September 2009, 10:56
soch soch is offline
Junior Member
 
Join Date: Sep 2009
Posts: 23
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Maybe your internet access provider is blockin these ports?
I have Verizon FiOS. Has any one had luck with this service?

--Edit: Looks like verizon fios blocks port 80. I will try to use no-ip.

Can´t figure out how to do port 80 redirect in godaddy.com :-( The no-ip setup required me to purchase the domain name from no-ip.com !!!

Changed the default port 80 to 8088 under /usr/local/ispconfig/server/conf# vi vhost.conf.master
---EDIT: no I didn´t have to. I am forwarding WAN 8088 to LAN 80 in my router.

Ended up using dyndns.com free dns service. That part worked. The long website name (domain1.doesntexit.com) translates to http://W.X.Y.Z:60111, where W.X.Y.Z is the external IP of my router.

The part still not working is the access from outside to the internally hosted website (via ispconfig). I wonder if Verizon blocks all outside http access unless business account is purchased. The port forward looks like as below in my router:
web - TCP 60111 -> 80
nameserver - TCP 53 -> 53
My browser complains with ¨can't establish a connection to the server at W.X.Y.Z:60111¨

Last edited by soch; 23rd September 2009 at 10:58.
Reply With Quote
  #38  
Old 24th September 2009, 06:06
soch soch is offline
Junior Member
 
Join Date: Sep 2009
Posts: 23
Thanks: 6
Thanked 0 Times in 0 Posts
Default Problem solved!!!

Finally, found the solution.

It was a problem in the Verizon Westell 9100 router.

I had to put the webserver in the DMZ zone fully exposed to the internet. Port forwarding doesn't work.

Now when I type http://domain1.com it takes me to my webpage from outside. But when I type http://www.domain1.com it gives me a generic ISPConfig screen. I will try to put the snapshot. Looks like it is reading the index.html instead of index.php.
Attached Images
 
Reply With Quote
  #39  
Old 24th September 2009, 10:30
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,485
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

Just deelete the index.html file when ypou upload your website content.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #40  
Old 24th September 2009, 15:22
soch soch is offline
Junior Member
 
Join Date: Sep 2009
Posts: 23
Thanks: 6
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by till View Post
Just deelete the index.html file when ypou upload your website content.
Thats the first thing I did. I have my own index.php & related files & Drupal pages under /var/www/clients/client0/web1. I will investigate more and see what the problem is.

Q: Where are the index pages & sub-directories supposed to be? In /var/www/clients/client0/web1 or under /var/www/clients/client0/web1/web folder? Where in ISPConfig is this specified?

Last edited by soch; 24th September 2009 at 16:02.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Relay access denied when using SMTP to external recipients Kamran Shah Installation/Configuration 111 14th May 2014 18:10
Can't access my website "the normal way" LinuxDuud General 3 13th December 2006 10:59
access website via intranet resnostyle General 1 29th October 2006 19:03
Website access by IP gundamf90 Installation/Configuration 3 28th October 2006 17:12
ISPConfig slow on external access mphayesuk General 7 17th August 2006 10:28


All times are GMT +2. The time now is 15:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.