Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 18th September 2009, 19:54
soch soch is offline
Junior Member
 
Join Date: Sep 2009
Posts: 23
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
But now MyDNS is running. Isn't that what you wanted?

Yes, that is one of the required steps as per the instructions. And thanks for letting me know that bind9 was running. I must have mistakenly installed it when things didn't work in the first attempt. I will remove the package.

But the problem I am having is that the nameserver is not responding. intodns.com still gives the same error for my website:
HTML Code:
"Mismatched NS records  	WARNING: One or more of your nameservers did not return any of your NS records.
Error 	DNS servers responded 	ERROR: One or more of your nameservers did not respond:
The ones that did not responded are:w.x.y.z - external IP address of my router"

Code:
root@server1:~# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State                                                                                                    PID/Program name
tcp        0      0 server1.domainXYZ:10024 *:*                     LISTEN                                                                                                   2682/amavisd (maste
tcp        0      0 server1.domainXYZ:10025 *:*                     LISTEN                                                                                                   3501/master
tcp        0      0 *:mysql                 *:*                     LISTEN                                                                                                   2759/mysqld
tcp        0      0 server1.domainXYZ:spamd *:*                     LISTEN                                                                                                   2841/spamd.pid
tcp        0      0 *:sunrpc                *:*                     LISTEN                                                                                                   2197/portmap
tcp        0      0 *:http-alt              *:*                     LISTEN                                                                                                   4016/apache2
tcp        0      0 *:www                   *:*                     LISTEN                                                                                                   4016/apache2
tcp        0      0 *:1008                  *:*                     LISTEN                                                                                                   2527/ypbind
tcp        0      0 *:ftp                   *:*                     LISTEN                                                                                                   3517/pure-ftpd (SER
tcp        0      0 server1.domainXY:domain *:*                     LISTEN                                                                                                   3426/mydns
tcp        0      0 server1.domainXY:domain *:*                     LISTEN                                                                                                   3426/mydns
tcp        0      0 *:ssh                   *:*                     LISTEN                                                                                                   2478/sshd
tcp        0      0 server1.domainXYZ.c:ipp *:*                     LISTEN                                                                                                   3864/cupsd
tcp        0      0 *:smtp                  *:*                     LISTEN                                                                                                   3501/master
tcp        0      0 *:https                 *:*                     LISTEN                                                                                                   4016/apache2
tcp        0    300 server1.domainXYZ.c:ssh 192.168.1.4:3253        ESTABLISHED                                                                                              5279/0
tcp6       0      0 [::]:imaps              [::]:*                  LISTEN                                                                                                   3367/couriertcpd
tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN                                                                                                   3411/couriertcpd
tcp6       0      0 [::]:pop3               [::]:*                  LISTEN                                                                                                   3386/couriertcpd
tcp6       0      0 [::]:imap2              [::]:*                  LISTEN                                                                                                   3342/couriertcpd
tcp6       0      0 [::]:ftp                [::]:*                  LISTEN                                                                                                   3517/pure-ftpd (SER
tcp6       0      0 localhost:domain        [::]:*                  LISTEN                                                                                                   3426/mydns
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN                                                                                                   2478/sshd
tcp6       0      0 localhost:ipp           [::]:*                  LISTEN                                                                                                   3864/cupsd
root@server1:~# netstat -tap | grep dns
tcp        0      0 server1.domainXY:domain *:*                     LISTEN                                                                                                   3426/mydns
tcp        0      0 server1.domainXY:domain *:*                     LISTEN                                                                                                   3426/mydns
tcp6       0      0 localhost:domain        [::]:*                  LISTEN                                                                                                   3426/mydns
root@server1:~#

Last edited by soch; 18th September 2009 at 20:31.
Reply With Quote
Sponsored Links
  #22  
Old 20th September 2009, 10:47
soch soch is offline
Junior Member
 
Join Date: Sep 2009
Posts: 23
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Any other suggestions?

I am stuck here. I tried going over the steps in the howto pages on ubuntu & ispconfig3. But I have the same problem.
Reply With Quote
  #23  
Old 20th September 2009, 14:05
giftsnake giftsnake is offline
Senior Member
 
Join Date: Jan 2009
Posts: 108
Thanks: 15
Thanked 9 Times in 8 Posts
Default

if things dont work out i would restart from scratch.
Reply With Quote
  #24  
Old 20th September 2009, 20:23
soch soch is offline
Junior Member
 
Join Date: Sep 2009
Posts: 23
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by giftsnake View Post
if things dont work out i would restart from scratch.
This is my second attempt.
Reply With Quote
  #25  
Old 20th September 2009, 20:38
giftsnake giftsnake is offline
Senior Member
 
Join Date: Jan 2009
Posts: 108
Thanks: 15
Thanked 9 Times in 8 Posts
Default

Quote:
Originally Posted by soch View Post
2. I have forwarded all the requests on port 80 to my ubuntu server internal IP address in the router firewall settings.
you will have to forward port 53 for the nameserver
Reply With Quote
The Following User Says Thank You to giftsnake For This Useful Post:
soch (21st September 2009)
  #26  
Old 21st September 2009, 06:09
soch soch is offline
Junior Member
 
Join Date: Sep 2009
Posts: 23
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by giftsnake View Post
you will have to forward port 53 for the nameserver
I added port 53 for UPD & TCP. My router port forwarding looks as below:

HTML Code:
Local Host=a.b.c.d 	
Local Address=a.b.c.d 	
Network Address =Any 	
Public IP Address =any	

Protocols 
HTTPS - TCP Any -> 443
HTTP - TCP Any -> 80
HTTP Web Access - TCP Any -> 3127-3128
        TCP Any -> 80-81
        TCP Any -> 8080
        TCP Any -> 8000
        TCP Any -> 8888
HTTP Secondary - TCP Any -> 8080
nameserver - TCP 53 -> 53
nameserver1 - UDP 53 -> 53

Where a.b.c.d is the internal IP address of the ubuntu server running ispconfig.
Still the same problem.
Reply With Quote
  #27  
Old 21st September 2009, 06:43
Antennipasi Antennipasi is offline
ISPConfig Developer
 
Join Date: Dec 2008
Location: Finland
Posts: 67
Thanks: 6
Thanked 13 Times in 12 Posts
Default

What does "dig @localhost domain1.com " show now?
If it works, then problem could be in /etc/mydns.conf, please show what it says in sections "# GENERAL OPTIONS" and "# ESOTERICA"
Reply With Quote
The Following User Says Thank You to Antennipasi For This Useful Post:
soch (21st September 2009)
  #28  
Old 21st September 2009, 06:59
soch soch is offline
Junior Member
 
Join Date: Sep 2009
Posts: 23
Thanks: 6
Thanked 0 Times in 0 Posts
Default

My ISP changed my external IP address. So I had to change the ns1 & ns2 settings on godaddy.com. It will take a day or two to propagate. I also changed all the records in ISPConfig to reflect the new external IP address.

After adding the port 53 on my router I see better results with dig:
Code:
dig @localhost domain1.com

; <<>> DiG 9.5.1-P2 <<>> @localhost domain1.com
; (2 servers found)
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 36685
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;domain1.com.		IN	A

;; ANSWER SECTION:
domain1.com.	86400	IN	A	W.X.Y.Z

;; AUTHORITY SECTION:
domain1.com.	86400	IN	NS	ns1.domain1.com.
domain1.com.	86400	IN	NS	ns2.domain1.com.

;; ADDITIONAL SECTION:
ns1.domain1.com.	86400	IN	A	W.X.Y.Z
ns2.domain1.com.	86400	IN	A	W.X.Y.Z

;; Query time: 4 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Sun Sep 20 22:05:54 2009
;; MSG SIZE  rcvd: 118


Now the other problem, that was working earlier, I see is when I use http://internalIPoftheserver, my website loads. But when I use http://externalIPofrouter, it does not load.

The DNS records are as follows:
A mail W.X.Y.Z 0
A ns1 W.X.Y.Z 0
A ns2 W.X.Y.Z 0
A domain1.com. W.X.Y.Z 0
A www W.X.Y.Z 0
MX domain1.com. mail.domain1.com 10
NS domain1.com. ns1.domain1.com. 0
NS domain1.com. ns2.domain1.com. 0

Note: I had to put dots at the end of ns1.domain1.com under the DATA column. Otherwise dig was reporting it as ns1.doamin1.com.domain1.com.

Router port forwarding settings:
ameserver - TCP 53 -> 53
nameserver1 - UDP 53 -> 53
HTTP - TCP Any -> 80
HTTP Web Access - TCP Any -> 3127-3128
TCP Any -> 80-81
TCP Any -> 8080
TCP Any -> 8000
TCP Any -> 8888
HTTP Secondary - TCP Any -> 8080
HTTPS - TCP Any -> 443
HTTPS Secondary - TCP Any -> 8443

Last edited by soch; 21st September 2009 at 07:11.
Reply With Quote
  #29  
Old 21st September 2009, 07:41
soch soch is offline
Junior Member
 
Join Date: Sep 2009
Posts: 23
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Antennipasi View Post
If it works, then problem could be in /etc/mydns.conf, please show what it says in sections "# GENERAL OPTIONS" and "# ESOTERICA"
# GENERAL OPTIONS

user = nobody # Run with the permissions of this user
group = nogroup # Run with the permissions of this group
listen = * # Listen on these addresses ('*' for all)
no-listen = # Do not listen on these addresses

# ESOTERICA

log = LOG_DAEMON # Facility to use for program output (LOG_*/stdout/stderr)
pidfile = /var/run/mydns.pid # Path to PID file
timeout = 120 # Number of seconds after which queries time out
multicpu = 1 # Number of CPUs installed on your system
recursive = # Location of recursive resolver
allow-axfr = yes # Should AXFR be enabled?
allow-tcp = yes # Should TCP be enabled?
allow-update = no # Should DNS UPDATE be enabled?
ignore-minimum = no # Ignore minimum TTL for zone?
soa-table = dns_soa # Name of table containing SOA records
rr-table = dns_rr # Name of table containing RR data
soa-where = server_id = 1 # Extra WHERE clause for SOA queries
rr-where = server_id = 1 # Extra WHERE clause for RR queries
use-soa-active = yes # To fix bug 295 where active or inactive status is ignored.
use-rr-active = yes# To fix bug 295 where active or inactive status is ignored.
Reply With Quote
  #30  
Old 21st September 2009, 08:07
Antennipasi Antennipasi is offline
ISPConfig Developer
 
Join Date: Dec 2008
Location: Finland
Posts: 67
Thanks: 6
Thanked 13 Times in 12 Posts
 
Default

Quote:
Originally Posted by soch View Post
Now the other problem, that was working earlier, I see is when I use http://internalIPoftheserver, my website loads. But when I use http://externalIPofrouter, it does not load.
mydns.conf seems ok.

Go to http://networking.ringofsaturn.com/Tools/dig.php

and enter "@externalIPofrouter domain1.com" ,does it answer?

Is your workstation behind same router? If so, can you ssh to server with externalIPofrouter? Forward port 22 before testing.

If you can do that, maybe problem is in your workstations name resolution. Try to edit host-file and put "externalIPofrouter domain1.com" there.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Relay access denied when using SMTP to external recipients Kamran Shah Installation/Configuration 111 14th May 2014 18:10
Can't access my website "the normal way" LinuxDuud General 3 13th December 2006 10:59
access website via intranet resnostyle General 1 29th October 2006 19:03
Website access by IP gundamf90 Installation/Configuration 3 28th October 2006 17:12
ISPConfig slow on external access mphayesuk General 7 17th August 2006 10:28


All times are GMT +2. The time now is 04:15.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.