#1  
Old 1st June 2010, 00:46
edi00 edi00 is offline
Member
 
Join Date: May 2010
Posts: 41
Thanks: 7
Thanked 0 Times in 0 Posts
Default /index.shtml Auto execution

I have another problem with SSI which will not automatically execute /index.shtml

if I type domain.com/index.shtml it works.

if I type domain.com/ only it does not work and I see an error message in error.log "Directory index forbidden by Options directive: /var/www/airpatrol.us/web/"

my vhost SSI enable looks like this:
Code:
        # ssi enabled
        AddType text/html .shtml
        AddOutputFilter INCLUDES .shtml
        Options +Includes +Indexes
I have added "+Indexes" as shown above and the error.log message changed to "(13)Permission denied: Can't open directory for index: /var/www/airpatrol.us/web/"

And terminal shows error "403 You are not permitted to access the requested URL."

I have tried root/root and client1/web4 and chmod 755, 644 and some others without any positive result.

What am I doing wrong?
Reply With Quote
Sponsored Links
  #2  
Old 1st June 2010, 01:27
CSsab CSsab is offline
Senior Member
 
Join Date: Apr 2010
Posts: 174
Thanks: 19
Thanked 32 Times in 27 Posts
Default working directory

Hi edi00,
I am thinking that your working directory is /var/www/clients/client1/web4/web

cd /var/www/clients/client1/web4/web
ls
and see what is in there.
Reply With Quote
  #3  
Old 1st June 2010, 03:26
edi00 edi00 is offline
Member
 
Join Date: May 2010
Posts: 41
Thanks: 7
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by CSsab View Post
Hi edi00,
I am thinking that your working directory is /var/www/clients/client1/web4/web

cd /var/www/clients/client1/web4/web
ls
and see what is in there.
That is where the /index.shtlm is.
It is strange that error is complaining about the /var/www/airpatrol.us/web/ which is DocummentRoot

Code:
    <Directory /var/www/airpatrol.us/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all

        # ssi enabled
        AddType text/html .shtml
        AddOutputFilter INCLUDES .shtml
        Options +Includes +Indexes
    </Directory>
    <Directory /var/www/clients/client1/web4/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
        
        # ssi enabled
        AddType text/html .shtml
        AddOutputFilter INCLUDES .shtml
        Options +Includes +Indexes
    </Directory>

I do not understand why the vhost has double directory. I am using client/client1/web4/web since DocumentRoot does not exist. If I want to CD to DocumentRoot the airpatrol.us is simlink directly to web4.
Reply With Quote
  #4  
Old 1st June 2010, 06:16
BorderAmigos BorderAmigos is offline
Senior Member
 
Join Date: Apr 2008
Location: San Diego & Tijuana
Posts: 302
Thanks: 26
Thanked 33 Times in 31 Posts
Send a message via MSN to BorderAmigos Send a message via Yahoo to BorderAmigos
Default

You need to add index.shtml to the DirectoryIndex directive.

/var/www/client/client1/web4/web is the actual directory.
/var/www/airpatrol.us/web/ is a symbolic link.
__________________
System6Hosting.com, ISPConfig 3, Debian.
Reply With Quote
The Following User Says Thank You to BorderAmigos For This Useful Post:
athul (9th February 2012)
  #5  
Old 1st June 2010, 07:25
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,408
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Quote:
I do not understand why the vhost has double directory.
Because apache differentiates between the symlink path and the real path and to ensure that everything works as expected, it is nescessary that all options are set for both paths.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 1st June 2010, 12:00
edi00 edi00 is offline
Member
 
Join Date: May 2010
Posts: 41
Thanks: 7
Thanked 0 Times in 0 Posts
Default

[QUOTE=BorderAmigos;229835]You need to add index.shtml to the DirectoryIndex directive./QUOTE]


I love when an advise works.
Thanks BorderAmigos!

Last edited by edi00; 1st June 2010 at 12:05.
Reply With Quote
  #7  
Old 1st June 2010, 12:01
edi00 edi00 is offline
Member
 
Join Date: May 2010
Posts: 41
Thanks: 7
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by till View Post
Because apache differentiates between the symlink path and the real path and to ensure that everything works as expected, it is nescessary that all options are set for both paths.
Thanks till to confirm my suspicion!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Auto Login in Gnome nightfire Desktop Operation 1 13th May 2008 22:27
2.3.2-dev: auto respond checkbox Tripple2 General 2 2nd October 2007 17:15
vhcs2 auto responder not working Reptile Installation/Configuration 30 7th September 2007 06:39
Auto Whitelist chappy81 HOWTO-Related Questions 2 29th April 2007 20:31
Auto login? dansaycool Desktop Operation 3 16th June 2006 21:47


All times are GMT +2. The time now is 13:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.