Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd April 2006, 14:22
skdb skdb is offline
Member
 
Join Date: Mar 2006
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default After Debian postfix / currior install, can not get external mail

Hi,
This is driving me up the wall and I can not find why this is not working...
If anyone can help...

I have Debian sarge 3.1, and in the middle of converting my "Confixx" management to "ISPconfig" and started with the Mail stuff.
After reading and following the "Perfect Debian Install" for the Postfix and Currior, everything seemed to be working:

Quote:
Connected to localhost.
Escape character is '^]'.
220 217-20-115-98.internetserviceteam.com ESMTP Postfix
ehlo localhost
250-217-20-115-98.internetserviceteam.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
quit
221 Bye
Connection closed by foreign host.
But when trying to check external mail as before with Outlook, I have changed the connect from standard to SSL connect and all I get is the User Login screen saying:

Quote:
-ERR Maildir: No such file or directory.
My postfix main.cf:

Quote:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version

#smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_banner = $myhostname ESMTP $mail_name
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

myhostname = 217-20-115-98.internetserviceteam.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
#myorigin = /etc/mailname
mydestination = 217-20-115-98.internetserviceteam.com, localhost.internetserviceteam.com, , localhost
relayhost =
mynetworks = 127.0.0.0/8
# mailbox_command = procmail -a "$EXTENSION"
mailbox_command = /usr/bin/procmail
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
#home_mailbox = Maildir/

smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain =
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination

smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

### CONFIXX POSTFIX ENTRY ###

virtual_maps = hash:/etc/postfix/confixx_virtualUsers, hash:/etc/postfix/confixx_localDomains

### /CONFIXX POSTFIX ENTRY ###
There are no errors in the mail log, just:

Quote:
Apr 23 14:17:41 217-20-115-98 courierpop3login: Connection, ip=[::ffff:84.130.80.180]
Apr 23 14:19:14 217-20-115-98 courierpop3login: Connection, ip=[::ffff:84.130.80.180]
Just conections and disconnects....

Can anyone help??
Reply With Quote
Sponsored Links
  #2  
Old 23rd April 2006, 16:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Quote:
Originally Posted by skdb
-ERR Maildir: No such file or directory.
The Maildir of the user in question is created when the first email arrives. So please send him a test mail first and then try again to fetch mails.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 23rd April 2006, 17:44
skdb skdb is offline
Member
 
Join Date: Mar 2006
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The Mail is being delivered to /var/mail/XXXX and each User has already test mails available.

The /Maildir option is commented out in the Postfix because Virtual Users are being used.

But why is the POP looking for the Mail in "Maildir" when ist not set???
Reply With Quote
  #4  
Old 23rd April 2006, 18:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Quote:
Originally Posted by skdb
But why is the POP looking for the Mail in "Maildir" when ist not set???
Courier always uses Maildir. If you want to use mbox, you need another POP3 daemon, as described on http://www.howtoforge.com/perfect_setup_debian_sarge_p4
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 23rd April 2006, 18:30
skdb skdb is offline
Member
 
Join Date: Mar 2006
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default

As I said before, I am trying to convert from ConfiXX to Ispconfig, this is probably why the mail was being delivered to the mail folder....

Falco, I appriciate your help but all I am doing is following your Guide for the perfect Debian to try and set the ISPConfig up along side Confixx so I dont have offline time, I can just switch from one to the other but at the moment, SMTP or POP cannot be used.

I dont use Linux that often so I can only follow guides or use Google and learn as I go along...

For info, I have added the "Maildir/" to postfix and sent test mails, I recieved the following back...any ideas?

Quote:
<web3p2@217-20-115-98.internetserviceteam.com>: maildir delivery failed: create
/XnirvanaX/Maildir/tmp/1145808899.P31683.217-20-115-98.internetserviceteam.com:
Permission denied

<web3p5@217-20-115-98.internetserviceteam.com>: maildir delivery failed: create
/XnirvanaX/Maildir/tmp/1145808899.P31687.217-20-115-98.internetserviceteam.com:
Permission denied

<web3p3@217-20-115-98.internetserviceteam.com>: maildir delivery failed: create
/XnirvanaX/Maildir/tmp/1145808899.P31685.217-20-115-98.internetserviceteam.com:
Permission denied

<web3p6@217-20-115-98.internetserviceteam.com>: maildir delivery failed: create
/XnirvanaX/Maildir/tmp/1145808900.P31689.217-20-115-98.internetserviceteam.com:
Permission denied

<web3p1@217-20-115-98.internetserviceteam.com>: maildir delivery failed: create
/XnirvanaX/Maildir/tmp/1145808899.P31682.217-20-115-98.internetserviceteam.com:
Permission denied
Reply With Quote
  #6  
Old 23rd April 2006, 19:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

The user you're sending a mail doesn'T have permissions to write to /XnirvanaX/Maildir/tmp/1145808899.P31683.217-20-115-98.internetserviceteam.com.
Do /XnirvanaX and /XnirvanaX/Maildir belong to the correct user?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 23rd April 2006, 19:24
skdb skdb is offline
Member
 
Join Date: Mar 2006
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thats my problem, XnirvanaX is not a registered User!
I dont know where this comes from...should I send a Test mail from the same server? if so how?
Is there somewhere where I can see where this User is?
Reply With Quote
  #8  
Old 24th April 2006, 10:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
 
Default

Then try with existing users.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Not receiving any incoming mail. Jcorrea920 General 11 3rd April 2010 13:08
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
Postfix mail is held in queue indefinitely... squallbsr Server Operation 9 15th January 2006 19:13
postfix starts and stops why lhatle Installation/Configuration 2 21st December 2005 15:20
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 14:42


All times are GMT +2. The time now is 22:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.