Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st September 2009, 16:14
medienlounge medienlounge is offline
Junior Member
 
Join Date: May 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default Apache Problem with HA Load Balancer

Hi all,
i followed the tutorial:
High-Availability Load Balancer (With Failover and Session Support) With HAProxy/Heartbeat On Debian Lenny

Right now i get a Problem that apache is running no more (either on lb1 and lb2).
when i try to start i get:

Code:
(98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
 failed!
Any ideas, or is that a normal behavior, and if, i also can´t get a website displayed with the virtual ip, although i can ping the ip
Reply With Quote
Sponsored Links
  #2  
Old 2nd September 2009, 14:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

HAProxy is listening on port 80 already. You must run Apache on different servers, as shown in the tutorial.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 3rd September 2009, 09:56
medienlounge medienlounge is offline
Junior Member
 
Join Date: May 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok, thanks for the reply.
i only had a few other services running on the 2 loadbalancers and would like it to be still availible, such as munin or nagios ....

any suggestion, that i can still use it, or do i have to transfer the setup to another server?

i can switch the apache in the lb to e.g. port 81 or 8080?

But what i want is that i can still access the vhosts of the lb on port 80.
so i tried to activate the second network interface eth1, which also works to log in by ssh.

but now, how to configure apache?

i tried:

NameVirtualHost 192.168.1.99:81
NameVirtualHost 192.168.1.98:80
Listen 81

where 192.168.1.99 is the ip of the lb.

But in order to get it run i need to tell apache to listen also on port 80, which doesn´t work
because og the known error:

(98)Address already in use: make_sock: could not bind to address [::]:80

Last edited by medienlounge; 3rd September 2009 at 14:57.
Reply With Quote
  #4  
Old 4th September 2009, 18:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by medienlounge View Post
i can switch the apache in the lb to e.g. port 81 or 8080?
You can either do this, or make Apache listen on another IP that is not in use by HAProxy (e.g. 192.168.1.98).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 4th September 2009, 19:26
medienlounge medienlounge is offline
Junior Member
 
Join Date: May 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

ok, thanks for the reply, i didn´t work it out, but think i could get it.
if you have any ports.conf advice - that would be very helpful.

another question, don´t know if it fits in here.

but did anyone try or have a tutorial für a system that either has the loadbalancer with apache and the mysql cluster running.

didnßt try it right now, because lack of computers.

but would like to test a setup:
2 loadbalancer
2 apache AND mysql server
1 mysql mgt server

for both are tutorials in running apache or mysql,
but is there a advice for loadbalancer setup for both, apache and mysql?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Loadbalanced High-Availability Apache Cluster Problem jason331 HOWTO-Related Questions 9 27th December 2009 18:49
Problem with mime.types in Apache longvnit Installation/Configuration 6 28th May 2009 12:30
libWand.so.10 error Taxick Installation/Configuration 8 3rd May 2009 02:27
ISPConfig + load balancer xtype2 General 4 3rd December 2008 19:08
Problem Installing Apache 2.2.8, MySQL 5.0 Client and PHP 5.2.5 On Fedora 8 (64-Bit) asyadiqin Installation/Configuration 5 10th April 2008 19:40


All times are GMT +2. The time now is 23:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.