Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th December 2010, 09:59
damir damir is offline
Senior Member
 
Join Date: Jun 2006
Posts: 375
Thanks: 11
Thanked 51 Times in 42 Posts
Default Random Access forbidden while reloading websites.

Hi all,

I have a strange issue with 3 independent sites i host. Every time i reload a site couple of times a get "Access forbidden" message.

On one site images sometime loads, and sometimes they don't.

Im running ISPConfig 3.0.2 on Debian Lenny, all the sites are php fast-cgi + suexec.

The message in error log of apache is "client denied by server configuration"

Other sites works perfectly. Anyone with similar experience ?

Kind regards
Reply With Quote
Sponsored Links
  #2  
Old 8th December 2010, 14:21
damir damir is offline
Senior Member
 
Join Date: Jun 2006
Posts: 375
Thanks: 11
Thanked 51 Times in 42 Posts
Default

I have found that apache2 module mod_dosevasive is causing this strange behavior.

Adding the following to vhost file resolves my problems:

Code:
<IfModule mod_dosevasive.c>
DOSHashTableSize 3097
DOSPageCount 5
DOSSiteCount 100
DOSPageInterval 1
DOSSiteInterval 1
DOSBlockingPeriod 2
</IfModule>
This happens with: Gallery2, Cms Made Simple (with Cataloger module) and OsCommerce.

If someone experiences same issues, this is the solution
Reply With Quote
The Following User Says Thank You to damir For This Useful Post:
falko (9th December 2010)
  #3  
Old 23rd March 2011, 19:22
lewis_saint lewis_saint is offline
Member
 
Join Date: Mar 2007
Posts: 69
Thanks: 0
Thanked 3 Times in 2 Posts
 
Default

Thank you for this. I just had this exact problem! It was driving me crazy!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webmin upgrade lishaw1968 Installation/Configuration 15 26th August 2010 15:23
add web site serr57 Installation/Configuration 18 13th April 2008 11:40
How to access my websites from intranet n1kol1s General 23 1st July 2006 13:01
Web Issues - Access Forbidden! rytech Installation/Configuration 23 22nd June 2006 15:25
Questions in regards to ISP-Server Setup - Ubuntu 5.10 "Breezy Badger" rbrantley HOWTO-Related Questions 16 10th April 2006 18:26


All times are GMT +2. The time now is 14:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.