Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st September 2009, 17:15
infowan infowan is offline
Junior Member
 
Join Date: Sep 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Setting Apache directives (php_admin_value)

Hello,

I followed the excellent tutorial to build my new server (windows independence here I come!) The Perfect Server - Ubuntu 9.04 [ISPConfig 3]. Things went great.

I have set up sites using php_mod and I have only one more task before I put it into production. I wanted to define the following Apache directives:

php_admin_value disable_functions “show_source system shell_exec passthru exec phpinfo popen proc_open”
php_admin_flag allow_url_fopen Off
php_admin_value session.save_path “/var/www/clients/client1/web1/tmp/”
php_admin_value open_basedir “/var/www/clients/client1/web1/”

I have pasted these into the Apache directives field (and modified them according to the site - web1, web2, web3, etc.), but when I check the phpinfo() none of the settings are applied. In fact I shouldn't even be allowed to run phpinfo(), correct?

Am I missing something with the syntax of Apache directives? How do I apply these Apache directives?

Thanks,

Infowan
Reply With Quote
Sponsored Links
  #2  
Old 2nd September 2009, 10:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,036
Thanks: 841
Thanked 5,655 Times in 4,464 Posts
 
Default

Please be aware that it takes some time until the changes are written to the config files. You can check it in the queue of the monitor module to see when your changes have been applied.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
apache directives, ispconfig 3, open_basedir, php_mod

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with suexec gobokster Installation/Configuration 7 7th May 2009 14:33
How to install OpenOficeOrg 3.0.0 in Ubuntu 8.04 ernesthagger HOWTO-Related Questions 43 23rd December 2008 15:42
Can't start apache Musty Server Operation 12 9th March 2008 14:58
Help. Apache don't start payne Server Operation 3 17th August 2007 16:57
Setting new apache directives doesn't work anymore Dennuz666 Installation/Configuration 1 22nd March 2007 12:25


All times are GMT +2. The time now is 07:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.