Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st September 2009, 19:43
tini tini is offline
Junior Member
 
Join Date: Nov 2006
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Default FTP-Login not working

Hi there

I just installed ISPConfig 3.0.1.3 on Virtual Machine in VirtualBox (Ubuntu 9.04) following this tutorial: http://www.howtoforge.com/perfect-se...9.04-ispconfig. The server has a LAN-IP, so does my workstation. There should be no firewall issues.

So I created a new client and for this client i created a new website and a new FTP-user.
Now the problem is, that this FTP-user can not login. I tried both passive and active conenctions. I even tried a local connection on the server.

The FTP-user is correctly in the database (table "ftp_user").

Here is the output of "netstat -tap | grep ftp":

Code:
tcp        0      0 *:ftp                   *:*                     LISTEN      2785/pure-ftpd (SER
tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      2785/pure-ftpd (SER
The output of my FTP-client:

Code:
STATUS:>  	[01.09.2009 18:27:59] Getting listing ""...
STATUS:>  	[01.09.2009 18:27:59] Resolving host name ispconfig.****.ch...
STATUS:>  	[01.09.2009 18:27:59] Host name ispconfig.****.ch resolved: ip = 192.168.0.181.
STATUS:>  	[01.09.2009 18:27:59] Connecting to FTP server... ispconfig.****.ch:21 (ip = 192.168.0.181)...
STATUS:>  	[01.09.2009 18:27:59] Socket connected. Waiting for welcome message...
		[01.09.2009 18:27:59] 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
		220-You are user number 1 of 50 allowed.
		220-Local time is now 18:27. Server port: 21.
		220-This is a private system - No anonymous login
		220-IPv6 connections are also welcome on this server.
		220 You will be disconnected after 15 minutes of inactivity.
STATUS:>  	[01.09.2009 18:27:59] Connected. Authenticating...
COMMAND:>	[01.09.2009 18:27:59] USER democlient3
		[01.09.2009 18:27:59] 331 User democlient3 OK. Password required
COMMAND:>	[01.09.2009 18:27:59] PASS *****
		[01.09.2009 18:27:59] 530 Login authentication failed
ERROR:>   	[01.09.2009 18:27:59] Not logged in.
STATUS:>  	[01.09.2009 18:28:01] Connection closed.
And finally the output of "/var/log/messages":

Code:
Sep  1 18:27:59 server1 pure-ftpd: (?@192.168.0.150) [INFO] New connection from 192.168.0.150
Sep  1 18:27:59 server1 pure-ftpd: (?@192.168.0.150) [WARNING] Authentication failed for user [democlient3]
Sep  1 18:28:03 server1 pure-ftpd: (?@192.168.0.150) [INFO] Logout.
Does anyone have a clue why this isn't working?

Thx

Last edited by tini; 1st September 2009 at 20:44.
Reply With Quote
Sponsored Links
  #2  
Old 2nd September 2009, 10:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,655 Times in 4,464 Posts
Default

Enable logging in mysql and check which SQL queries are sent to the mysql server from pureftpd.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 2nd September 2009, 11:15
tini tini is offline
Junior Member
 
Join Date: Nov 2006
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Default

the following commands are executed. I ran them directly in MySQL and attached its result too:

Code:
SELECT password FROM ftp_user WHERE active = 'y' AND server_id = '1' AND username="democlient3"
Result: Encrypted password.


Code:
SELECT uid FROM ftp_user WHERE active = 'y' AND server_id = '1' AND username="democlient3"
Result: web2

Code:
SELECT gid FROM ftp_user WHERE active = 'y' AND server_id = '1' AND username="democlient3"
Result: client1

Code:
SELECT dir FROM ftp_user WHERE active = 'y' AND server_id = '1' AND username="democlient3"
Result: /var/www/clients/client1/web2

Maybe this should go into another thread, but I just had a look at the server and to my surprise the folder "/var/www/clients/client1/web2" does not exist. Any idea why?

Last edited by tini; 2nd September 2009 at 11:17.
Reply With Quote
  #4  
Old 2nd September 2009, 11:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,655 Times in 4,464 Posts
Default

Thats ok, pure-ftpd is able to connect to the database and gets some valid results. Please check with:

grep web2 /etc/passwd


and

grep client1 /etc/group

if the group and user exist. If they dont exist, then edit the website were the ftp user belongs to, e.g. change the quota and click on save. Then wait a minute and check again. You can see in the jobqueue of the monitor if the changes have been applied or if threre were any errors.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 2nd September 2009, 11:41
tini tini is offline
Junior Member
 
Join Date: Nov 2006
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Default

Both commands didn't return anything, so I tried you suggestion.

I set the Quoto from -1 to 100.
In the Jobqueue I see the following:

2009-09-02 10:35 ispconfig.****.ch Update web_domain

I waited for 10 minutes, but it seems that the user and the group still don't exist.
Reply With Quote
  #6  
Old 2nd September 2009, 11:43
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,655 Times in 4,464 Posts
Default

Is the jobqueue empty now or is the update job still there in the queue?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 2nd September 2009, 11:47
tini tini is offline
Junior Member
 
Join Date: Nov 2006
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Default

There are 2.5 pages of update jobs in the Jobqueue.
This is a problem, isn't it?
Reply With Quote
  #8  
Old 2nd September 2009, 11:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,655 Times in 4,464 Posts
Default

Yes, then no jobs will be executed. Check if there is a error in the systm-log.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 2nd September 2009, 12:13
tini tini is offline
Junior Member
 
Join Date: Nov 2006
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Default

That's what I thought.

The list in "Monitor -> Show System-Log" is empty.

By the way, I changed the server name in /etc/hosts and /etc/hostname after the installation of ISPConfig3.

But I also changed the server name in "System -> Edit Server" and in "System -> Server Config" I changed the Network Configuration (checkbox "Network Configuration" is selected and the new hostname i correct).

Does changing the hostname affect ISPConfig?
Reply With Quote
  #10  
Old 2nd September 2009, 12:17
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,655 Times in 4,464 Posts
 
Default

Quote:
Originally Posted by tini View Post
Does changing the hostname affect ISPConfig?
No.

Please check with:

ps aux | grep php

if there are a lot of php processes running from ispconfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP not working after restore jdg Installation/Configuration 4 31st July 2009 19:04
Cannot connect to anonymus ftp n1kol1s Installation/Configuration 39 15th February 2007 19:36
After Install: Mail not working and FTP strange Raffnix Installation/Configuration 24 8th January 2007 16:51
FTP not working mimic General 4 21st August 2006 17:21
ftp problems tgansert Installation/Configuration 20 27th May 2006 20:06


All times are GMT +2. The time now is 04:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.