Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th August 2009, 21:28
NdK NdK is offline
Member
 
Join Date: Jul 2009
Location: Bologna, ITA
Posts: 41
Thanks: 1
Thanked 3 Times in 1 Post
Default Trouble configuring Google Apps in DNS

Hello all.

I'm having troubles configuring Google Apps in DNS.
I add a cname record from "mail" (w/o final dot) to "ghs.google.com." (w/ final dot).
Then when I dig mail.mydomain.dom I can see it gets only partially resolved:
;; QUESTION SECTION:
;mail.mydomain.dom. IN A

;; ANSWER SECTION:
mail.mydomain.dom. 86400 IN CNAME ghs.google.com.

It misses the following line from ghs.google.com to the actual address.
And even ping doesn't work.
Looking in threads I found that the included DNS is non-resolving except internal addresses, but the machine from where I ping DOES have another DNS configured.

Am I missing something or is it normal (if so it would be REALLY limiting...)?
Reply With Quote
Sponsored Links
  #2  
Old 14th August 2009, 14:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,977
Thanks: 825
Thanked 5,369 Times in 4,216 Posts
Default

Most likely your server ais not authoritive for this domain. To test the local dns server, use:

dig @localhost mail.mydomain.dom
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 14th August 2009, 21:53
NdK NdK is offline
Member
 
Join Date: Jul 2009
Location: Bologna, ITA
Posts: 41
Thanks: 1
Thanked 3 Times in 1 Post
Default

Quote:
Originally Posted by till View Post
Most likely your server ais not authoritive for this domain. To test the local dns server, use:

dig @localhost mail.mydomain.dom
I don't know how to (and if I should) make it authoritative (it should just serve aliased addresses for the local network).

Maybe it's better if I explain the structure of my network (simplifying a bit).
- the modem/router gets the public IP from my ADSL provider and routes all requests from the external network to the server where ISPConfig runs
- the "main" DNS is handled externally by editDNS, together with dynamic dns updates
- the other internal computers should be able to access the server w/o using the external address

The problem is that the modem/router mishandles requests from internal network targeted at pubIP:80, redirecting 'em to its web server for config.
So I think I have to keep an internal DNS more or less synchronized to the external one...

Is there a simpler way?

Tks.
Reply With Quote
  #4  
Old 15th August 2009, 13:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by NdK View Post
- the other internal computers should be able to access the server w/o using the external address
You can either edit the hosts file on your internal computers, or set up an internal DNS server and make your internal computers use that one as the primary DNS.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 15th August 2009, 21:22
NdK NdK is offline
Member
 
Join Date: Jul 2009
Location: Bologna, ITA
Posts: 41
Thanks: 1
Thanked 3 Times in 1 Post
Default

Quote:
Originally Posted by falko View Post
You can either edit the hosts file on your internal computers, or set up an internal DNS server and make your internal computers use that one as the primary DNS.
That's exactly what I was trying to do (internal primary DNS), leveraging ISPConfig's interface to ease management. But it seems I'm still missing something...

My zone records are:
A "" 192.168.3.3 0
CNAME calendar ghs.google.com. 0
CNAME mail ghs.google.com. 0
CNAME pvs test.tst. 0
CNAME www test.tst. 0
MX "" aspmx.l.google.com. 1
MX "" alt1.aspmx.l.google.com. 5
MX "" alt2.aspmx.l.google.com. 5
MX "" aspmx2.googlemail.com. 10
MX "" aspmx3.googlemail.com. 10
NS "" pvs 0

pvs.test.tst is obviously the machine where ISPConfig runs and "" replaces the empty string.

I initially tried a wildcard record like
CNAME * test.tst. 0
But it seems it won't work (is there some alternative? couldn't obtain good results w/ ALIAS records for mail and calendar). So Still no "catch all" record
The problem is that it either resolves correctly internal addresses or external ones...
Reply With Quote
  #6  
Old 1st September 2009, 23:32
ffoorreesstt ffoorreesstt is offline
Junior Member
 
Join Date: Sep 2009
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hello,

first sorry for my english.

I have the same issue, I have configured MyDNS like primary DNS server and Bind 9 like secondary DNS server. From MyDNS gets zones to Bind.

I configure Google Apps in MyDNS with CNAME and then automatic replicated to Bind, but when I trying to reach Google Apps and I have on my PC configured nameserver MyDNS then doesn't function. But when I use Bind like my nameserver on my PC all is OK.

I try to dig to both off server and there is result:

dig to MyDNS

; <<>> DiG 9.5.0-P2 <<>> @ns2.maxtel.cz kalendar.maxtel.cz.
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58737
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;kalendar.maxtel.cz. IN A

;; ANSWER SECTION:
kalendar.maxtel.cz. 86400 IN CNAME ghs.google.com.

;; AUTHORITY SECTION:
maxtel.cz. 86400 IN NS ns1.maxtel.cz.
maxtel.cz. 86400 IN NS ns2.maxtel.cz.

;; ADDITIONAL SECTION:
ns1.maxtel.cz. 86400 IN A 90.183.12.3
ns2.maxtel.cz. 86400 IN A 90.183.12.4

;; Query time: 2 msec
;; SERVER: 90.183.12.4#53(90.183.12.4)
;; WHEN: Tue Sep 1 23:26:37 2009
;; MSG SIZE rcvd: 132


dig to Bind

; <<>> DiG 9.5.0-P2 <<>> @ns1.maxtel.cz kalendar.maxtel.cz.
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38234
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 6, ADDITIONAL: 6

;; QUESTION SECTION:
;kalendar.maxtel.cz. IN A

;; ANSWER SECTION:
kalendar.maxtel.cz. 86400 IN CNAME ghs.google.com.
ghs.google.com. 600362 IN CNAME ghs.l.google.com.
ghs.l.google.com. 300 IN A 74.125.43.121

;; AUTHORITY SECTION:
l.google.com. 81847 IN NS b.l.google.com.
l.google.com. 81847 IN NS f.l.google.com.
l.google.com. 81847 IN NS a.l.google.com.
l.google.com. 81847 IN NS d.l.google.com.
l.google.com. 81847 IN NS g.l.google.com.
l.google.com. 81847 IN NS e.l.google.com.

;; ADDITIONAL SECTION:
f.l.google.com. 168247 IN A 72.14.203.9
d.l.google.com. 81847 IN A 74.125.77.9
e.l.google.com. 81847 IN A 209.85.137.9
a.l.google.com. 168247 IN A 74.125.53.9
b.l.google.com. 168247 IN A 74.125.45.9
g.l.google.com. 81847 IN A 74.125.95.9

;; Query time: 33 msec
;; SERVER: 90.183.12.3#53(90.183.12.3)
;; WHEN: Tue Sep 1 23:27:58 2009
;; MSG SIZE rcvd: 292


You can see differences of queries. But why??
Reply With Quote
  #7  
Old 2nd September 2009, 06:47
NdK NdK is offline
Member
 
Join Date: Jul 2009
Location: Bologna, ITA
Posts: 41
Thanks: 1
Thanked 3 Times in 1 Post
Default

Quote:
Originally Posted by ffoorreesstt View Post
You can see differences of queries. But why??
Maybe because MyDNS is non-recursive, while BIND DOES recurse queries?
So, if you're using MyDNS, it can't be your ONLY nameserver: you have to use another ns to resolve addresses you're not authoritative for.

Hope it helps.
Reply With Quote
  #8  
Old 2nd September 2009, 22:37
ffoorreesstt ffoorreesstt is offline
Junior Member
 
Join Date: Sep 2009
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default Solved

Hello,

MyDNS can do recursive queries, but not by self. You can specify in mydns.conf recursive option for the other DNS server with recursive options.

Now how I to do this.

In my zone in MyDNS, I make A record and then CNAME which is headed to A record (oh my English), better is example:

googleapps A 74.125.43.121
calendar CNAME googleapps
mail CNAME googleapps


and now it's working :-)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unknown MX record and Reverse PTR question for Google Apps email safoo Server Operation 1 31st March 2009 17:26
Xen on Ubuntu kmand HOWTO-Related Questions 17 5th March 2009 18:43
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 19:51
DNS Configuration Problems VMartins Installation/Configuration 10 24th July 2007 14:40
Unable send receive emails vassilis3 Installation/Configuration 15 19th May 2007 14:34


All times are GMT +2. The time now is 01:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.