Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 15th September 2009, 13:42
giftsnake giftsnake is offline
Senior Member
 
Join Date: Jan 2009
Posts: 108
Thanks: 15
Thanked 9 Times in 8 Posts
Default

i think you can change permissions temporarily with chown even if its a mounpoint, and to do it permanently do it in fstab
Reply With Quote
Sponsored Links
  #22  
Old 15th September 2009, 14:29
voltron81 voltron81 is offline
Senior Member
 
Join Date: Sep 2009
Posts: 292
Thanks: 1
Thanked 4 Times in 3 Posts
Default

Without change any permission at the moment, a fast upgrade... hoping that somebody will give me some suggestions...
I said that:
Quote:
Anyway at the moment this is my situation:
When SERVER1 and SERVER2 are up, the mail services are working; the /var/vmail folder is consistent and ISPConfig and Postfix are able to write in that folder. The mysql replication work just fine.
When SERVER1 crash (i switch off it) happens that:

* now /var/vmail is accessible from SERVER2, I can see that there are all the files of the emails. But when I try to check an email from Roundcube of SERVER2, I can enter into the email but it's look like there are no email stored.

* If I try to send an email it's sent, but roundcube webpage is blocked in "sending message" mode. I can see that in "sent folder" there is no trace of this sent. The same happens even when SERVER1 is on. I guess it's because Postfix can't have a permission to write in /var/vmail

* If I send an email to one mail managed by the mailserver and I try to check the email from Roundcube, I can't find it. But if I switch on now the SERVER1 and check that email from Roundcube webpage of SERVER1, I can see all the emails, even the one that was received when SERVER1 was off. Even with SERVER1 on, from Roundcube webpage from SERVER2, I can't find any email
Well, if SERVER1 is on and I'll reboot SERVER2, it start to work properly again...
Reply With Quote
  #23  
Old 15th September 2009, 14:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,422 Times in 4,264 Posts
Default

I guess you should try to contact the glusterfs developers and ask them for the reson of this behaviour.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #24  
Old 15th September 2009, 14:59
voltron81 voltron81 is offline
Senior Member
 
Join Date: Sep 2009
Posts: 292
Thanks: 1
Thanked 4 Times in 3 Posts
Default

Ok summarize it:
BEGINNING: SERVER1 and SERVER2 are online
The master-master replication is working just fine

SERVER1 crash, so SERVER2 is master
I still have all the files in /var/vmail (so I have all the emails), but when I try to check an email with roundcube, I can enter in that email, but I can not see all the stored email.
I can send emails(it is delivered properly), but the roundcube page is blocked in "sending message". If I close the page and enter again in the webmail, in "sent folder" I can't see nothing.
I can not receive emails. If I try to send an email to zzz@zzz.com managed by this mailserver and after I'll check the webmail of that email address, I can't see any email.


SERVER1 is up again

If I'll check zzz@zzz.com webmail page on SERVER1, I can find the emails sent when SERVER1 was down.
If I'll check zzz@zzz.com webmail page on SERVER2, I can not find any email.
If I'll reboot SERVER2, it will start to work properly again...

To be honest I don't think it's something releated with glusterfs and /var/vmail... I think it's something releated with postfix... (because roundcube read the IMAP server).

What do you think?
Come on guys, the howto for a fault tolerance mail server is almost ready...

Cheers
Michele
Reply With Quote
  #25  
Old 16th September 2009, 10:54
voltron81 voltron81 is offline
Senior Member
 
Join Date: Sep 2009
Posts: 292
Thanks: 1
Thanked 4 Times in 3 Posts
Default

I shutdown the SERVER1 and I'm checking from Roundcube webpage an email that had some emails stored. I can not see any of them.
I had a look to the /var/log/mail.log and this is the situation:

Code:
Sep 16 09:44:41 srv2 imapd: Connection, ip=[::ffff:127.0.0.1]
Sep 16 09:44:41 srv2 imapd: LOGIN, user=michele@xxxxxxxx.com, ip=[::ffff:127.0.0.1], port=[44032], protocol=IMAP
Sep 16 09:44:42 srv2 imapd: LOGOUT, user=michele@xxxxxxxx.com, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=71, sent=652, time=1
It's look like a problem of postfix.
Should I change in /etc/postfix/main.cf the word srv1 instead of srv2 for "myhostname" and "mydestination" ????

Thanks
Michele
Reply With Quote
  #26  
Old 16th September 2009, 11:39
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,422 Times in 4,264 Posts
Default

Can you still see the files in /var/vmail on the secondary server on the shell (e.g. with ls) when you shutdown the primary server? If no, its a glusterfs problem.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #27  
Old 16th September 2009, 11:47
voltron81 voltron81 is offline
Senior Member
 
Join Date: Sep 2009
Posts: 292
Thanks: 1
Thanked 4 Times in 3 Posts
Default

Yes I can still see the folder /var/vmail with all the email files...

If, when SERVER1 is down, I enter in ISPConfig on SERVER2 and I create a new email for example, where will be not a new folder for that email... but when I'll switch on again SERVER1, he will create it...

The same with the emails: if I send an email to an email address managed by the mail server when SERVER1 is down, I can not see it from SEVER2, but if I switch on the SERVER1 again, I'll find the email.
The SERVER2 will not work properly till, when SERVER1 is on, I'll reboot it...

Thanks for your help
Michele
Reply With Quote
  #28  
Old 16th September 2009, 18:01
voltron81 voltron81 is offline
Senior Member
 
Join Date: Sep 2009
Posts: 292
Thanks: 1
Thanked 4 Times in 3 Posts
Default

I really don't know that is wrong in this configuration...
Could somebody give me some suggestions?
I'm getting crazy with this mail server...

Thank you very much
Michele

PS: maybe it's better if one of the administrator of the forum change the title of this discussion... maybe the new name could be "master-master replication of the mailserver managed by ISPConfig", so that even for the future could be easier for somebody to find it...

Last edited by voltron81; 16th September 2009 at 18:04.
Reply With Quote
  #29  
Old 17th September 2009, 11:23
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,422 Times in 4,264 Posts
Default

I've changed the title of the thread.

Not sure why it does not work. But as it seems that there is a problem with accessing the shared directory, I would really recommend that you consult the glusterfs developers on that, maybe one of them has an idea why there is a problem with accessing the files.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #30  
Old 17th September 2009, 11:35
voltron81 voltron81 is offline
Senior Member
 
Join Date: Sep 2009
Posts: 292
Thanks: 1
Thanked 4 Times in 3 Posts
 
Default

Thanks for your suggestion.
I've sent an email to glusterfs users mailing list... I'm waiting an answer...

But what I think is: glusterfs just replicare that folder. Once that I can see that files, the job of glusterfs is done. Maybe could be a problem of permissions, but in that case I could solve it with some commands.
So I think I've to focus my mind to the problem between ISPConfig and the /var/vmail folder.
Do you know where I can find some logs about that? I was reading some logs, but I can't see something wrong.
Can you suggest me also some other tests that I could do?

Thanks a lot
Michele
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to use an external mailserver within ISPConfig? Hans General 8 3rd September 2009 19:37
Master master Mysql replication with ignore table wxman HOWTO-Related Questions 2 5th May 2009 22:25
Loads of mysql connections to dbispconfig StrikerNL General 2 5th March 2009 14:31
Mailserver Migration To ISPConfig Server asyadiqin Installation/Configuration 1 9th January 2007 10:33
Security Issue in Mailserver after ISPConfig installation bogdinator Installation/Configuration 8 31st October 2006 12:00


All times are GMT +2. The time now is 17:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.