Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th August 2009, 22:25
Gimly Gimly is offline
HowtoForge Supporter
 
Join Date: Mar 2007
Location: France
Posts: 144
Thanks: 26
Thanked 4 Times in 4 Posts
Default [Multi-server system] Very strange problem

Hi all,

Actually, I meet a very strange problem, my ispconfig doesn't create mail and database. I've multiserver system, which worked fine but since 1 week, the system doesn't work.

When I'm going to look my database, I've look this problem (first picture) :



When I click on database properties, the server list are in grey :



I've look at client limits properties and when I want to select database server, I just have my master server and not my sql server (sql.espace4you.org) :



and when I look at my servers config, it's ok :



I've the same problem with my mail server.

I launch the server.sh and this is the return (same result for mail server) :

Quote:
sql:/home/e4yromain# /usr/local/ispconfig/server/server.sh
finished.
sql:/home/e4yromain#
and I don't use firewall on this servers.

If you have an idea, please ?

Thank you in advance
__________________
4 virtual machines with Debian Lenny updated on proxmox (openvz) with ISPConfig 3.0.1.6

ns1 : http(s), ftp(s), DNS Master, ISPConfig
sql : MySQL database users
mail : All mail system
ns2 : DNS Slave

ISPConfig.be Admin's

Last edited by Gimly; 27th August 2009 at 07:49.
Reply With Quote
Sponsored Links
  #2  
Old 27th August 2009, 13:17
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

I guess that a problem with the current beta. I noticed this today during testing. It affects only new records that were created by clients and not admins. The server_id is missing in these records. Will have to take a look at the code what has caused this.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Gimly (27th August 2009)
  #3  
Old 28th August 2009, 10:58
Gimly Gimly is offline
HowtoForge Supporter
 
Join Date: Mar 2007
Location: France
Posts: 144
Thanks: 26
Thanked 4 Times in 4 Posts
Default

When can I know if the problem is fix ?
__________________
4 virtual machines with Debian Lenny updated on proxmox (openvz) with ISPConfig 3.0.1.6

ns1 : http(s), ftp(s), DNS Master, ISPConfig
sql : MySQL database users
mail : All mail system
ns2 : DNS Slave

ISPConfig.be Admin's
Reply With Quote
  #4  
Old 28th August 2009, 11:03
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

As usual, look at the bugtracker.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Gimly (28th August 2009)
  #5  
Old 28th August 2009, 11:45
Gimly Gimly is offline
HowtoForge Supporter
 
Join Date: Mar 2007
Location: France
Posts: 144
Thanks: 26
Thanked 4 Times in 4 Posts
Default

thanks till
__________________
4 virtual machines with Debian Lenny updated on proxmox (openvz) with ISPConfig 3.0.1.6

ns1 : http(s), ftp(s), DNS Master, ISPConfig
sql : MySQL database users
mail : All mail system
ns2 : DNS Slave

ISPConfig.be Admin's
Reply With Quote
  #6  
Old 28th August 2009, 13:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

The problem now is that I'am not able to reproduce it anymore on my systems. May you please execute this sql query in the ispconfig database e.g. with phpmyadmin and post the output:

SELECT server_id,server_name FROM server WHERE db_server = 1 ORDER BY server_name
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 28th August 2009, 13:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Additional questions:

1) are you logged in as admin, normal user or reseller user when this happens?
2) Post also the output of this mysql query:

SELECT sys_perm_user,sys_perm_group,sys_perm_other FROM server WHERE db_server = 1
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 28th August 2009, 18:57
Gimly Gimly is offline
HowtoForge Supporter
 
Join Date: Mar 2007
Location: France
Posts: 144
Thanks: 26
Thanked 4 Times in 4 Posts
Default

Hi Till,

Thanks for your reply

1)
Quote:
mysql> SELECT server_id,server_name FROM server WHERE db_server = 1 ORDER BY server_name ;
+-----------+--------------------+
| server_id | server_name |
+-----------+--------------------+
| 9 | sql.espace4you.org |
+-----------+--------------------+
2) I'm logged in as user when the problem come, but when I'm in admin I d'ont have this problem

3)
Quote:
mysql> SELECT sys_perm_user,sys_perm_group,sys_perm_other FROM server WHERE db_server = 1 ;
+---------------+----------------+----------------+
| sys_perm_user | sys_perm_group | sys_perm_other |
+---------------+----------------+----------------+
| riud | riud | r |
+---------------+----------------+----------------+
1 row in set (0.00 sec)

mysql>
__________________
4 virtual machines with Debian Lenny updated on proxmox (openvz) with ISPConfig 3.0.1.6

ns1 : http(s), ftp(s), DNS Master, ISPConfig
sql : MySQL database users
mail : All mail system
ns2 : DNS Slave

ISPConfig.be Admin's
Reply With Quote
  #9  
Old 30th August 2009, 11:10
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Thanks. I think I found the problem and fixed it in SVN.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Gimly (30th August 2009)
  #10  
Old 30th August 2009, 12:40
Gimly Gimly is offline
HowtoForge Supporter
 
Join Date: Mar 2007
Location: France
Posts: 144
Thanks: 26
Thanked 4 Times in 4 Posts
 
Default

Thanks Till, I upgrade from last svn version to test it

--- edit : It work fine now, thank you very much Till ---
__________________
4 virtual machines with Debian Lenny updated on proxmox (openvz) with ISPConfig 3.0.1.6

ns1 : http(s), ftp(s), DNS Master, ISPConfig
sql : MySQL database users
mail : All mail system
ns2 : DNS Slave

ISPConfig.be Admin's

Last edited by Gimly; 30th August 2009 at 13:00.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
php Apps email not going through palkat General 8 21st September 2011 05:35
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail -Ubuntu 8.04 c4rdinal HOWTO-Related Questions 112 23rd August 2011 10:49
Problem with keeping Apache alive bobeq Server Operation 3 29th November 2007 16:11
Problems with Postfix Mysql Courier PatrickAdrichem Installation/Configuration 3 13th April 2007 15:44
550-The recipient cannot be verified email problem safoo Installation/Configuration 7 29th November 2006 19:55


All times are GMT +2. The time now is 22:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.