Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th August 2009, 23:47
micrmac micrmac is offline
Junior Member
 
Join Date: Aug 2009
Location: Denver, Colorado
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Ubuntu Remote Desktop from Windows XP

I am a very new Ubuntu user. I have a machine with 9.04 loaded. I need to operate it by remote desktop on my local network from a Windows XP machine. The Howto instructions from several sources are all similar. They tell me to configure my Ubuntu from the menu at System - Preferences - Remote Desktop as follows:

1. Allow other users to view your desktop
2. Allow other users to control your desktop
3. Require the user to enter this password: wwwwwww
4. Configure the network automatically to accept connections.

On my Windows machine I have tried both RealVNC and UltraVNC. I have turned off my firewalls. I have tried to connect using my local address 192.168.2.nnn:0. I get a message on the Windows client that the connection cannot be established.

I am stuck.

Mike
Reply With Quote
Sponsored Links
  #2  
Old 30th August 2009, 02:00
id10t id10t is offline
Senior Member
 
Join Date: Nov 2008
Posts: 240
Thanks: 2
Thanked 22 Times in 22 Posts
Default

On a local network I'd just enable GDM and get a win32 xserver (cygwin-x, etc). Unfortunately, GDM over network is broken in 9.04

You can still ssh in with putty and forward X to your windows machine (still need win32 xserver as above) and launch various applications... not sure what would happen if you tried to launch gnome-desktop...
Reply With Quote
  #3  
Old 30th August 2009, 10:33
Franz Franz is offline
Senior Member
 
Join Date: Jul 2009
Location: Cakovec
Posts: 117
Thanks: 7
Thanked 24 Times in 18 Posts
Send a message via Skype™ to Franz
Default

Quote:
Originally Posted by micrmac View Post
I have tried to connect using my local address 192.168.2.nnn:0. I get a message on the Windows client that the connection cannot be established.
You have to connect on port 5900, not 0:
Code:
192.168.2.nnn:5900
or just
Code:
192.168.2.nnn
becauseport 5900 is default
__________________
my PAGE
VoIP
my IT help blog
Reply With Quote
  #4  
Old 3rd September 2009, 19:09
micrmac micrmac is offline
Junior Member
 
Join Date: Aug 2009
Location: Denver, Colorado
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Thanks, but the fix was different.

Thanks to both id10t and Franz for their suggestions.

The problem turned out to be Firestarter. I had installed it before attempting remote desktop, then I "turned it off". The catch was that it didn't actually turn off. To unblock port 5900 I had to remove it. Since the computer is behind a router, a firewall isn't actually necessary.

I am up and running using Ultra VNC on the Windows machine.

I think Franz overlooked something in his suggestion. On the login line on a typical VNC viewer, the form 192.168.2.nnn:w does not specify the port in the w value. It specifies a screen number. If I were specifying the port the form would be 192.168.2.nnn::5900, with two colons.
Reply With Quote
  #5  
Old 12th October 2009, 22:19
jb1023 jb1023 is offline
Junior Member
 
Join Date: Oct 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I am able to connect to my remote Ubuntu server with UltraVNC just fine. My issue is if there is no user logged onto the server then the connection attempt fails. If there is a user logged on then the connection succeeds. Is there a setting to start the server as a system service rather than a user service, assuming this is what is happening? The reason this is an issue is because if I am working on the server on a weekend/evening, remotely, and I have to reboot the server or even log off for whatever reason then I cannot get back on unless there happens to be somebody in the office and that is highly unlikely. Thanks in advance.
Reply With Quote
Reply

Bookmarks

Tags
desktop, remote, ubuntu, windows

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unbale to login to Postfix from webmail wasimriz HOWTO-Related Questions 5 6th April 2009 13:49
Remote Desktop in Ubuntu golusweet HOWTO-Related Questions 1 9th November 2008 14:18
Getting e-mail working hansoffate Installation/Configuration 29 13th August 2008 16:33
apache2 problem laser144 Server Operation 8 15th March 2007 17:32
Xen 3.0, Ubuntu 5.10, and Windows 2003 Server Jcorrea920 HOWTO-Related Questions 3 4th May 2006 11:26


All times are GMT +2. The time now is 15:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.