Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th August 2009, 09:56
Gigashop Gigashop is offline
Junior Member
 
Join Date: Jul 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default cgi-bin will not working on IPSconfig3

Hello all

I downloaded Perfect Server ISPconfig3 SUSE 11 VmWare Image

All work find, but cgi scripts will not work.
On the Site Config i enabled CGI and SuEXEC.

For Test i upload test.cgi to the cgi-bin folder (755)
(http://www.MyDomain.com/cgi-bin/test.cgi)
But i have Error 403

(Same Test CGI: http://www.rzuser.uni-heidelberg.de/~x22/ht/cgi.cgi )

#!/bin/sh
echo "Content-type: text/html"
echo
echo "<HTML><HEAD>"
echo "<TITLE>Beispiel CGI</TITLE></HEAD>"
echo "<BODY><H1>CGI - Beispiel</H1>"
echo "Das aktuelle Datum ist<HR><PRE>"
date
echo "</PRE><HR></BODY></HTML>"


On Site Options the Apache directives ist empty

Thanke you for Help
Reply With Quote
Sponsored Links
  #2  
Old 30th August 2009, 10:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Take a lookmat the error log file for a detialed error message.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 30th August 2009, 15:17
Gigashop Gigashop is offline
Junior Member
 
Join Date: Jul 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Now after a new manual installation of ispconfig3 x64 Debian 5 i have the same Problem.
The Sites are working but no cgi.

Found in Log :

[Sun Aug 30 14:59:37 2009] [error] [client 192.168.2.4] suexec policy violation: see suexec log for more details
[Sun Aug 30 14:59:37 2009] [error] [client 192.168.2.4] Premature end of script headers: test.cgi

Found in Suexec log

[2009-08-30 14:59:45]: uid: (5003/web3) gid: (5005/client3) cmd: test.cgi
[2009-08-30 14:59:45]: (2)No such file or directory: exec failed (test.cgi)

Thanks

Last edited by Gigashop; 30th August 2009 at 15:32.
Reply With Quote
  #4  
Old 31st August 2009, 11:34
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Please make sure that the script is owned by the user and group of the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 31st August 2009, 11:54
Gigashop Gigashop is offline
Junior Member
 
Join Date: Jul 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

How can i do this ?

I logged with FTP in with Username and Password of the Site Client.

Last edited by Gigashop; 31st August 2009 at 14:02.
Reply With Quote
  #6  
Old 1st September 2009, 11:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
 
Default

Login on the shell and then run:

ls -la

in the cgi-bin directory so that we see the permissions of the file and subdirectory.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CGI Form not working on site pebkac Installation/Configuration 10 10th July 2009 11:00
2.3.3-Dev CGI PHP not working grandpagenocide General 2 25th October 2007 05:35
CGI Scripts not working digitalv General 1 26th July 2007 21:51
CGI Not Working mfiendd Server Operation 7 12th July 2006 12:39
cgi not working tom Installation/Configuration 11 6th May 2006 18:33


All times are GMT +2. The time now is 08:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.