#1  
Old 29th August 2009, 10:13
wabz wabz is offline
Member
 
Join Date: Jul 2009
Posts: 84
Thanks: 4
Thanked 0 Times in 0 Posts
Default Error when starting apache

mail:~ # /etc/init.d/apache2 start
Starting httpd2 (prefork) Warning: DocumentRoot [/srv/www/etrademart.com/web] do es not exist
httpd2-prefork: bad user name web14

The command line was:
/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf
failed
mail:~ #
Reply With Quote
Sponsored Links
  #2  
Old 29th August 2009, 16:06
wabz wabz is offline
Member
 
Join Date: Jul 2009
Posts: 84
Thanks: 4
Thanked 0 Times in 0 Posts
Default solved above. new warning message

I was able to solve the above issue by deleting the conf file for the site. Now i have a warning message

mail:~ # /etc/init.d/apache2 start
Starting httpd2 (prefork) [Sat Aug 29 16:25:28 2009] [warn] NameVirtualHost 196.0.25.202:443 has no VirtualHosts
done
mail:~ #
Reply With Quote
  #3  
Old 29th August 2009, 16:26
gnosti gnosti is offline
Junior Member
 
Join Date: Jun 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

That just saying that that particular IP isn't assigned to any vhost.

I get the same thing on my server...

Quote:
# /etc/init.d/apache2 restart
Restarting web server: apache2[Sat Aug 29 09:21:52 2009] [warn] NameVirtualHost 67.19.86.38:80 has no VirtualHosts
[Sat Aug 29 09:21:52 2009] [warn] NameVirtualHost x.x.x.x:443 has no VirtualHosts
[Sat Aug 29 09:21:52 2009] [warn] NameVirtualHost x.x.x.x:443 has no VirtualHosts
[Sat Aug 29 09:21:52 2009] [warn] NameVirtualHost x.x.x.x:80 has no VirtualHosts
[Sat Aug 29 09:21:52 2009] [warn] NameVirtualHost x.x.x.x:443 has no VirtualHosts
[Sat Aug 29 09:21:52 2009] [warn] NameVirtualHost x.x.x.x:443 has no VirtualHosts
... waiting [Sat Aug 29 09:21:54 2009] [warn] NameVirtualHost 67.19.86.38:80 has no VirtualHosts
[Sat Aug 29 09:21:54 2009] [warn] NameVirtualHost x.x.x.x:443 has no VirtualHosts
[Sat Aug 29 09:21:54 2009] [warn] NameVirtualHost x.x.x.x:443 has no VirtualHosts
[Sat Aug 29 09:21:54 2009] [warn] NameVirtualHost x.x.x.x:80 has no VirtualHosts
[Sat Aug 29 09:21:54 2009] [warn] NameVirtualHost x.x.x.x:443 has no VirtualHosts
[Sat Aug 29 09:21:54 2009] [warn] NameVirtualHost x.x.x.x:443 has no VirtualHosts
done
it can be safely ignored generally, unless you have already setup a vhost on that particular ip. Then in that case you should look in you vhost conf and see whats going on there.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High on Lenny - Lvm Mount Problem Serverman Technical 1 23rd June 2009 16:26
problems with suexec gobokster Installation/Configuration 7 7th May 2009 13:33
CENTOS 5 Ping Problem gAnDo Server Operation 11 28th March 2008 20:58
Apache is not starting at boot LeoLinux Installation/Configuration 3 13th August 2007 12:08
Problem with the installation of Dokeos (LMS) in ISPConfig jofranco General 4 28th April 2006 00:45


All times are GMT +2. The time now is 16:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.