Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th August 2009, 10:49
skirao skirao is offline
Junior Member
 
Join Date: Aug 2008
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
 
Smile Help required in adding Domain Users to Local Powers Users group

Hi all,

Ubuntu 8.04 Server 64-bit edition
Samba 3.0.28a configured as PDC
I have NO WINDOWS NT MACHINE ON THE NETWORK. WinXP clients login to the samba domain and access their home directories as configured.

I am following the instructions in http://www.samba.org/samba/docs/man/...#magicnetlogon to add domain users to the winxp clients Power Users group.

Code:

#!/bin/bash

/usr/bin/net rpc group addmem "Power Users" "DOMAIN_NAME\$1" \
-UAdministrator%secret -S $2

exit 0

[netlogon]
comment = Netlogon Share
path = /export/samba/logon
root preexec = /etc/samba/scripts/autopoweruser.sh %U %m
read only = Yes
guest ok = Yes

I tried executing the net rpc group addmem command manually and here's what happens
#net rpc group addmem "Administrators" "Domain Users" \ -S WINPCO32
Password:
Usage: 'net rpc group addmem <group> <member>

root@sunbox:~# net rpc group addmem "Power Users" "domain_name\username"
Password:
Could not add domain_name\username to Power Users:NT_STATUS_NO_SUCH_ALIAS
(I replaced the domain_name with the name of the domain and username with the appropriate user account.)

#net rpc group addmem "Power Users" "Domain Users" -S 100.100.100.247
Password:
Could not add Domain Users to Power Users: NT_STATUS_ACCESS_DENIED

where 100.100.100.247 is the clients machine IP address

How can i make this work?
Thanks
Avinash

Can anybody help
Avinash
Reply With Quote
Sponsored Links
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
freebsd 7, samba 3, domain controller alexdimarco Suggest HOWTO 6 5th November 2010 16:54
Mail server using Postfix, Dovecot, Mysql... Postfix virtual maps doesn't work?? tarasbuljba HOWTO-Related Questions 33 28th May 2010 14:33
Mail System Error - Returned Mail tristanlee85 General 16 16th March 2008 09:40
Roaming Profile Error with Samba Domain Controller Setup noahlau HOWTO-Related Questions 6 8th March 2008 18:33
ubuntu ispconfig joomla .htaccess steve1084 General 8 6th January 2007 15:55


All times are GMT +2. The time now is 12:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.