Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th August 2009, 21:07
SamTzu SamTzu is offline
HowtoForge Supporter
 
Join Date: Apr 2007
Location: Helsinki
Posts: 424
Thanks: 33
Thanked 50 Times in 35 Posts
Send a message via Skype™ to SamTzu
Default Squirrelmail languages

I'm having trouble in changing the language in Squirrelmail.
I think the problem is with coding.
I believe Squirrel tries to use ISO when my server is using UTF.

How have you solved this issue?
__________________

Sami Mattila
Internet-Content

Telephone:
00358942833310
Email: firstname.lastname@internet-content.org
Shop: http://shop.internet-content.net
Site: http://www.internet-content.net
Blog: http://www.internet-content.net/en/blog
FB: https://www.facebook.com/internetcontent

Reply With Quote
Sponsored Links
  #2  
Old 28th August 2009, 11:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,579
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

Create a new vhost for squirrelmail, install squirrelmail into this vhost and then set the page encoding for this vhost.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 1st September 2009, 09:37
SamTzu SamTzu is offline
HowtoForge Supporter
 
Join Date: Apr 2007
Location: Helsinki
Posts: 424
Thanks: 33
Thanked 50 Times in 35 Posts
Send a message via Skype™ to SamTzu
Default

Sounds complicated. I have never defined an alternative path for a squirrelmail installation.
Can it be done with apt-get ?
__________________

Sami Mattila
Internet-Content

Telephone:
00358942833310
Email: firstname.lastname@internet-content.org
Shop: http://shop.internet-content.net
Site: http://www.internet-content.net
Blog: http://www.internet-content.net/en/blog
FB: https://www.facebook.com/internetcontent

Reply With Quote
  #4  
Old 1st September 2009, 11:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,579
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

I recommed that you just download the squirrelmail tar.gz package from their website and install it in the vhost and do not use apt.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 1st September 2009, 12:22
SamTzu SamTzu is offline
HowtoForge Supporter
 
Join Date: Apr 2007
Location: Helsinki
Posts: 424
Thanks: 33
Thanked 50 Times in 35 Posts
Send a message via Skype™ to SamTzu
Lightbulb

I found an easier way.

Quote:
dpkg-reconfigure locales
Choose ALL
I kept the en_US.UTF-8 as the default.

It will install language support for all the languages (It takes a while but so what

After that is finnished

Quote:
squirrelmail-configure
Language preferences
1. Default Language : fi_FI
2. Default Charset : UTF-8
3. Enable lossy encoding : false

R Return to Main Menu
C Turn color on
S Save data
Q Quit

Command >> s


And now it works...
__________________

Sami Mattila
Internet-Content

Telephone:
00358942833310
Email: firstname.lastname@internet-content.org
Shop: http://shop.internet-content.net
Site: http://www.internet-content.net
Blog: http://www.internet-content.net/en/blog
FB: https://www.facebook.com/internetcontent


Last edited by SamTzu; 1st September 2009 at 12:36.
Reply With Quote
The Following User Says Thank You to SamTzu For This Useful Post:
falko (2nd September 2009)
  #6  
Old 11th February 2010, 21:49
learning-linux learning-linux is offline
Junior Member
 
Join Date: Feb 2010
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

GREAT ! This did it for me Thanx mate
Reply With Quote
  #7  
Old 31st July 2010, 08:31
swiss420 swiss420 is offline
Junior Member
 
Join Date: Jul 2010
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
Default

Dident seem to work for me. Default is now German under "display preferences" but squirrelmail still shows up in english. Using Ubuntu 10.04 with ISPConfig 3.0.2.2 followed the Perfect Server instructions closely.

dpkg-reconfigure locales
Generating locales...
en_AG.UTF-8... up-to-date
en_AU.UTF-8... up-to-date
en_BW.UTF-8... up-to-date
en_CA.UTF-8... up-to-date
en_DK.UTF-8... up-to-date
en_GB.UTF-8... up-to-date
en_HK.UTF-8... up-to-date
en_IE.UTF-8... up-to-date
en_IN.UTF-8... up-to-date
en_NG.UTF-8... up-to-date
en_NZ.UTF-8... up-to-date
en_PH.UTF-8... up-to-date
en_SG.UTF-8... up-to-date
en_US.UTF-8... up-to-date
en_ZA.UTF-8... up-to-date
en_ZW.UTF-8... up-to-date
Generation complete.

SquirrelMail Configuration:
Language preferences
1. Default Language : de_DE
2. Default Charset : UTF-8

Would anyone have a idea what else to try or check?
Reply With Quote
  #8  
Old 1st August 2010, 18:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by swiss420 View Post
dpkg-reconfigure locales
Generating locales...
en_AG.UTF-8... up-to-date
en_AU.UTF-8... up-to-date
en_BW.UTF-8... up-to-date
en_CA.UTF-8... up-to-date
en_DK.UTF-8... up-to-date
en_GB.UTF-8... up-to-date
en_HK.UTF-8... up-to-date
en_IE.UTF-8... up-to-date
en_IN.UTF-8... up-to-date
en_NG.UTF-8... up-to-date
en_NZ.UTF-8... up-to-date
en_PH.UTF-8... up-to-date
en_SG.UTF-8... up-to-date
en_US.UTF-8... up-to-date
en_ZA.UTF-8... up-to-date
en_ZW.UTF-8... up-to-date
Generation complete.
I don't see de_DE here. Are you sure that you enabled it?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 2nd August 2010, 06:14
swiss420 swiss420 is offline
Junior Member
 
Join Date: Jul 2010
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

I have not noticed that, thanks for the pointer. I did try other languages but I guess they are all not listed. I will do some more searching to figure out how to install it. Thanks.

Ok figured it out.

Edit: /var/lib/locales/supported.d/local
Add: de_DE.ISO-8859-1 ISO-8859-1 or de_DE.UTF-8 UTF-8

Run: dpkg-reconfigure locales

Generating locales...
de_DE.UTF-8... done

That worked for me. Further information found here (German - wiki.ubuntuusers.de)


Edit: I did try the above again on a different Server with less luck when I remembered on the last Server I did also modify the german array in /usr/share/squirrelmail/functions/i18n.php and added de_DE.UTF-8 to it. see below for example.

I changed the following:
Quote:
$languages['de_DE']['LOCALE'] = array('de_DE.ISO8859-1','de_DE.ISO-8859-1','de_DE');
to the following:
Quote:
$languages['de_DE']['LOCALE'] = array('de_DE.ISO8859-1','de_DE.ISO-8859-1','de_DE','de_DE.UTF-8');
Now it should definetly work sorry for that. (Your "Inbox" should now be "Posteingang" or whatever language you added above.)

Last edited by swiss420; 6th August 2010 at 08:07.
Reply With Quote
The Following User Says Thank You to swiss420 For This Useful Post:
falko (3rd August 2010)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Using Squirrelmail with ISPConfig 3 dpicella Installation/Configuration 15 7th January 2011 04:30
How do you configure SquirrelMail with ISPConfig 3 adobe Installation/Configuration 8 9th January 2009 11:22
Squirrelmail customization Paladinemishakal Installation/Configuration 5 13th August 2008 10:16
Squirrelmail ERROR: ERROR: Connection dropped by IMAP server. GerardNijboer Server Operation 1 29th August 2007 18:39
Virtual users, domains Postfix.. & Squirrelmail laser144 HOWTO-Related Questions 6 4th May 2006 23:23


All times are GMT +2. The time now is 12:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.