Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 30th August 2009, 19:40
totte_karlsson totte_karlsson is offline
Junior Member
 
Join Date: Mar 2007
Posts: 12
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi changeed the name isp1.example.com in the file /etc/mailname to isp1.monkisoft.com, which is the correct domain.

Now, all outgoing emails have correct from address.

Thanks,
totte
Reply With Quote
Sponsored Links
  #12  
Old 8th January 2010, 13:02
technocp technocp is offline
Junior Member
 
Join Date: Jan 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem with from address

See I have used gmail smtp i.e. smtp.gmail.com

and then I used sasl_passwd file to store

smtp.gmail.com usernameassword

now in from address of all sent emails I get the username that is mentioned as above in sasl_passwd file

I want to change it because if I don't change it all my three different users have same from address in all the emails sent.

can any body please suggest any ideas on resolving this problem
Reply With Quote
  #13  
Old 9th January 2010, 12:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Did you set the correct sender address in your email client?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #14  
Old 11th September 2012, 05:51
razor7 razor7 is offline
Member
 
Join Date: May 2007
Posts: 47
Thanks: 6
Thanked 1 Time in 1 Post
 
Default

Quote:
Originally Posted by totte_karlsson View Post
I got it working!

Here is what I changed. In the main.cf, shown above,
changed/added the following lines

#changed from no to yes (may not matter for sending mail?)
smtpd_tls_auth_only = yes

#Added this line
smtp_tls_security_level = may

I also found a problem in my sasl passwd file:

[smtp.live.com] 'useraccountname:my password'


However, I still have the following problems. If I send an email from a ssh shell, the email from address is
'myloginname'@isp1.example.com.
I can't figure out where isp1.example.com comes from. If I send email using squirrel mail from an account created with ispconfig(3), the email "from" domain is correct.

Also, in the mail.log file, I get this "warning" for each mail that is relayed:
Aug 27 10:30:58 isp1 postfix/smtp[26534]: certificate verification failed for smtp.live.com[65.55.172.254]:25: untrusted issuer /C=US/O=GTE Corporation/OU=GTE CyberTrust Solutions, Inc./CN=GTE CyberTrust Global Root
Not sure how to get rid of that, not sure if I want since mail sending does work now.

Anyone knows where to set example.com to my correct domain?

Thanks,
totte
Well, this just got the thinbg working. Of course, after adding the relay data on ISPConfig server config area.

Best regards!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CGI and FormMail Cracklefish Installation/Configuration 17 13th October 2009 14:40
Help needed error rpmbuild -ba postfix.spec mr_bo Installation/Configuration 2 15th May 2009 10:47
Postfix relay problem asus Server Operation 14 4th January 2009 10:18
Postfix + sasl problem nexon Installation/Configuration 1 1st January 2008 16:43
I broke it.. I think.. Email in is not being delivered? edge Server Operation 1 3rd July 2006 15:22


All times are GMT +2. The time now is 23:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.