#1  
Old 25th August 2009, 17:35
wabz wabz is offline
Member
 
Join Date: Jul 2009
Posts: 84
Thanks: 4
Thanked 0 Times in 0 Posts
Default Webmail problem

I am having the following problem with webmail

Error opening ../data/default_pref
Could not create initial preference file!
/srv/webmail.uwasnet.org/web/data/ should be writable by user wwwrun
Please contact your system administrator and report this error.

File permission is set to 777

When i run the command ls -la /srv/www/webmail.uwasnet.org/web/data

output of the command. I just ran it for a different site with the same problem

mail:/srv/www/webmail.uwasnet.org/web/data # ls -la /srv/www/webmail.uwasnet.org/web/data total 20
drwxrwxrwx 2 web12 client5 4096 Aug 20 15:38 .
drwxr-xr-x 18 web12 client5 4096 Aug 25 14:18 ..
-rwxr-xr-- 1 web12 client5 14 Aug 20 15:38 .htaccess
-rwxr-xr-- 1 web12 client5 41 Aug 20 15:38 default_pref
-rwxr-xr-- 1 web12 client5 485 Aug 20 15:38 index.php

So what next?
Reply With Quote
Sponsored Links
  #2  
Old 26th August 2009, 08:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Run:

chown wwwrun /srv/webmail.uwasnet.org/web/data/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 26th August 2009, 09:21
wabz wabz is offline
Member
 
Join Date: Jul 2009
Posts: 84
Thanks: 4
Thanked 0 Times in 0 Posts
Default Still having the same problem

Even after running the command chown wwwrun /srv/webmail.uwasnet.org/web/data/ I still have the same problem.
There is a .htaccess file which has a deny all in it. Should i change the parameter to accept all?

Last edited by wabz; 26th August 2009 at 09:25.
Reply With Quote
  #4  
Old 26th August 2009, 09:24
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Looks as if you have a problem in your webmail config file somewhere. Compare that paths, you missded the www directory:

The error message says:

/srv/webmail.uwasnet.org/web/data/

but the path is:

/srv/www/webmail.uwasnet.org/web/data
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 26th August 2009, 09:31
wabz wabz is offline
Member
 
Join Date: Jul 2009
Posts: 84
Thanks: 4
Thanked 0 Times in 0 Posts
 
Default

The error message says

Error opening ../data/default_pref
Could not create initial preference file!
/srv/www/webmail.uwasnet.org/data/ should be writable by user wwwrun
Please contact your system administrator and report this error


This is what is in the config file.

$data_dir = '/srv/www/webmail.uwasnet.org/data/';

/**
* Attachments directory
*
* Path to directory used for storing attachments while a mail is
* being sent. There are a few security considerations regarding
* this directory:
* + It should have the permission 733 (rwx-wx-wx) to make it
* impossible for a random person with access to the webserver to
* list files in this directory. Confidential data might be laying
* around there.
* + Since the webserver is not able to list the files in the content
* is also impossible for the webserver to delete files lying around
* there for too long.
* + It should probably be another directory than data_dir.
* @global string $attachment_dir
*/
$attachment_dir = '/srv/www/webmail.uwasnet.org/attach/';
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail -Ubuntu 8.04 c4rdinal HOWTO-Related Questions 112 23rd August 2011 10:49
problem with webmail infused General 3 11th October 2007 01:58
Postfix+MySQL Problem jasutton Installation/Configuration 1 15th June 2006 16:06
Website of Created User not working and Webmail Login Problem techman83 Installation/Configuration 5 28th February 2006 15:05
webmail klient quota problem? jernis Installation/Configuration 9 30th November 2005 22:14


All times are GMT +2. The time now is 04:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.