Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 31st August 2009, 15:24
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,269 Times in 4,130 Posts
Default

Please check the directory names in:

/var/vmail

and

/var/vmail/xxx.com

if any of them are capitalized.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #12  
Old 31st August 2009, 15:32
magborges magborges is offline
Junior Member
 
Join Date: Aug 2009
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Please check the directory names in:

/var/vmail

and

/var/vmail/xxx.com

if any of them are capitalized.

Till,

"xxx" stands for any of my domains. And NO: I have no capitalized names into /var/vmail nor /var/vmail/any_of_my_domains.

The fail just started after the update from ISPConfig 3.0.1.3 to 3.0.1.4 Beta 2.

Márcio
Reply With Quote
  #13  
Old 2nd September 2009, 20:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,269 Times in 4,130 Posts
Default

Quote:
Originally Posted by magborges View Post
Hello!

I'm not an expert, so I filled a lot of days to solve this little problem. update.php changed /var/vmail/.mailfilter:

LOGNAME=tolower("$LOGNAME")
EXTENSION="$1"
RECIPIENT=tolower("$2")
USER=("$3")
HOST=("$4")
SENDER="$5"
DEFAULT="/var/vmail/$HOST/$USER/."


to

LOGNAME=tolower("$LOGNAME")
EXTENSION="$1"
RECIPIENT=tolower("$2")
USER=tolower("$3")
HOST=tolower("$4")
SENDER="$5"
DEFAULT="/var/vmail/$HOST/$USER/."


I don't know why, but maildrop doesn't liked this:

"(temporary failure. Command output: /usr/bin/maildrop: Unable to open mailbox. )"

After a lot of comparisons, I removed "tolower" from USER and HOST and voilŕ! Maildrop stands to life!

I just wanna know if it is a trick of my Fedora 10 or some else more complicated...

Márcio Arnaldo Borges
Looks as if there is some kind of bug in maildrop when compiled with specific gcc options which might cause this:

http://groups.google.com/group/linux...2ac6e476d39246

I will try to find a workaround for this.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.

Last edited by till; 2nd September 2009 at 20:43.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
magborges (2nd September 2009)
  #14  
Old 3rd September 2009, 00:10
RomaSvcs RomaSvcs is offline
Junior Member
 
Join Date: Apr 2009
Location: Vancouver,BC
Posts: 20
Thanks: 7
Thanked 0 Times in 0 Posts
Talking ISPConfig 3.0.1.4 Beta 2 released for testing-Centos 5.3

[QUOTE=RomaSvcs;202577]
Quote:
Originally Posted by till View Post
run:

apache2 -t
Do not work. But I tryed httpd -t and answered Syntax OK

Did you made any custom modifications to the prior installation like making port 8080 available via ssl? yes it was available via ssl.

It was not conecting via ssl but I just enabled the ssl connection to the port 8080 but still is showing the Web-Server: offline after restart.

Though I have a Question can I Update the version backwards (using previous versions) to test if it start working again? and if Yes, is the procedure the same as a regular update?

Thanks
Hi Till

I don't know if this info will be usefull but in case some body else come up with the same problem at least will not spend so many days trying to solve it. so the issue with the:

Web-Server: offline using this beta 2 version was solved....

by reinstalling the ISPConfig-3-stable.tar.gz and after rebooting I had the same issue

Web-Server: Offline
FTP-Server: Online
SMTP-Server: Offline
POP3-Server: Online
IMAP-Server: Online
myDNS-Server: Online
mySQL-Server: Online

Changed
system/edit server ip/ add new ip address
from 192.168.0.100
to 127.0.0.1
save it
/etc/init.d/httpd restart

Then I got:
Web-Server: Online

Changed back
system/edit server ip/ add new ip address
from 127.0.0.1
to 192.168.0.100
save it
/etc/init.d/httpd restart
and is OK!!! even works after rebooting!

Now the Question is ... Is this a BUG???

After Rebooting:

Web-Server: Online
FTP-Server: Online
SMTP-Server: Online
POP3-Server: Online
IMAP-Server: Online
myDNS-Server: Online
mySQL-Server: Online

#But THERE IS 2 *:8080 VServers one at http.conf and the other @ ispconfig.vhost so did this to get ride of one and reboot and still OK!!

NameVirtualHost *:80
NameVirtualHost *:443
Include /etc/httpd/conf/sites-enabled/

<VirtualHost _default_:80>
</VirtualHost>

<VirtualHost 192.168.0.100:443>
DocumentRoot "/var/www/html"
<Directory "/var/www/html">
allow from all
Options +Indexes
</Directory>
</VirtualHost>

<VirtualHost 192.168.0.100:80>
DocumentRoot "/var/www/html"
<Directory "/var/www/html">
allow from all
Options +Indexes
</Directory>
</VirtualHost>

<VirtualHost *:443>
DocumentRoot "/var/www/html"
<Directory "/var/www/html">
allow from all
Options +Indexes
</Directory>
</VirtualHost>

#<VirtualHost *:8080>
#DocumentRoot /usr/local/ispconfig/interface/web/
#SSLEngine on
#SSLCertificateFile /etc/pki/server1/ssl.crt/server1.crt
#SSLCertificateKeyFile /etc/pki/server1/ssl.privkey/server1.key
#</VirtualHost>

<VirtualHost 127.0.0.1:80>
DocumentRoot "/var/www"
<Directory "/var/www">
allow from all
Options +Indexes
</Directory>
</VirtualHost>

#--------------This section moved from /etc/httpd/conf/sites-available/ispconfig.vhost
to /etc/httpd/conf/http.conf

Listen 8080
Listen 127.0.0.1:80
NameVirtualHost *:8080

<VirtualHost _default_:8080>
ServerAdmin webmaster@localhost

<IfModule mod_fcgid.c>
DocumentRoot /var/www/ispconfig/
SuexecUserGroup ispconfig ispconfig
<Directory /var/www/ispconfig/>
Options Indexes FollowSymLinks MultiViews +ExecCGI
AllowOverride AuthConfig Indexes Limit Options FileInfo
AddHandler fcgid-script .php
FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
Order allow,deny
Allow from all
</Directory>
</IfModule>

<IfModule mod_php5.c>
DocumentRoot /usr/local/ispconfig/interface/web/
AddType application/x-httpd-php .php
<Directory /usr/local/ispconfig/interface/web>
Options FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
php_value magic_quotes_gpc 0
</Directory>
</IfModule>

# ErrorLog /var/log/apache2/error.log
# CustomLog /var/log/apache2/access.log combined
ServerSignature Off

</VirtualHost>
#----------------------------

Hoppe this info will help some body!!

Thanks Carlos Barrera
Reply With Quote
  #15  
Old 3rd September 2009, 10:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,269 Times in 4,130 Posts
Default

Quote:
Now the Question is ... Is this a BUG???
No, at least not in ISPConfig. Every default installation of apache is listening on 127.0.0.1, so if your dont do that, it must have ben reconfigured to not listen on 127.0.0.1.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #16  
Old 4th September 2009, 09:45
stevenbg stevenbg is offline
Junior Member
 
Join Date: Sep 2009
Posts: 4
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
This is the second beta version of the upcoming ISPConfig 3.0.1.4 release.
Several bugs from the first beta has been fixed.

Changelog
------------------------------------

http://bugtracker.ispconfig.org/inde...losed&do=index


New Installation
------------------------------------

Execute the following commands as root user on the shell:

Code:
cd /tmp
wget http://www.ispconfig.org/downloads/ISPConfig-3.0.1.4-beta-2.tar.gz
tar xvfz ISPConfig-3.0.1.4-beta-2.tar.gz
cd ispconfig3_install/install/
php -q install.php
cd /tmp/
rm -rf ispconfig3_install
rm -f ISPConfig-3.0.1.4-beta-2.tar.gz

Update of an existing ISPConfig installation
Installation
------------------------------------

Execute the following commands as root user on the shell:

Code:
cd /tmp
wget http://www.ispconfig.org/downloads/ISPConfig-3.0.1.4-beta-2.tar.gz
tar xvfz ISPConfig-3.0.1.4-beta-2.tar.gz
cd ispconfig3_install/install/
php -q update.php
cd /tmp/
rm -rf ispconfig3_install
rm -f ISPConfig-3.0.1.4-beta-2.tar.gz
Hi 2 ALL
Is this a final version or still is beta 2?
Regards

P.S. Link from http://ispconfig.org/news.htm (2009-09-03
ISPConfig 3.0.1.4 final released) send me to download ISPConfig-3.0.1.4-beta-2.tar.gz.
Reply With Quote
  #17  
Old 4th September 2009, 09:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,269 Times in 4,130 Posts
 
Default

Sorry, there was a wrong link in the news. The final version is here:

http://www.howtoforge.com/forums/showthread.php?t=38795

or just go to downloads on ispconfig.org.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 2.2.13 released till General 35 23rd July 2007 16:28
ISPConfig 2.2.14 released till General 48 19th July 2007 23:46
ISPConfig 2.2.4 released till General 25 18th July 2006 13:04
ISPConfig 2.2.1 released till General 11 28th May 2006 10:39
ISPConfig remoting plugin Beta 2 released till General 14 29th April 2006 14:13


All times are GMT +2. The time now is 06:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.