Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Plugins/Modules/Addons

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
View Poll Results: Would you like to see a mailuser interface for Roundcube & Squirrelmail?
Yes 211 98.60%
No 3 1.40%
Voters: 214. You may not vote on this poll

Reply
 
Thread Tools Display Modes
  #401  
Old 16th December 2011, 01:48
radim_h radim_h is offline
Senior Member
 
Join Date: Jan 2007
Location: Prague, Czech
Posts: 420
Thanks: 33
Thanked 24 Times in 19 Posts
Send a message via ICQ to radim_h
Default Roundcube 0.7

I have just installed new version Roundcube 0.7 and everything is working OK!
Reply With Quote
Sponsored Links
  #402  
Old 29th December 2011, 18:21
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 392
Thanks: 29
Thanked 58 Times in 50 Posts
Default

I finally had a chance to install the Roundcube plug-in. It's fantastic! Thank you to everyone whose hard work has gone into its development.

I apologize in advance if these questions have already been asked/addressed elsewhere in this thread. At 41 pages and growing, it's becoming difficult to digest.

1.) The overall page layout when viewing the plug-in's Account tab appears to be missing a header include or similar. Please see attached screenshot.

2.) I receive the following message when I first hit the Junk section or attempt to save a password change:

Code:
Soap Error: You do not have permission to access this function.
Fetchmail, Autoreply, and Mail Filter all function as expected.

Are the permissions outlined in the installation guide ( http://www.howtoforge.com/forums/sho...9&postcount=20 ) sufficient? Per the guide, the permissions relevant to SPAM/Junk rules appear to be:

Code:
mail_spamfilter_user_get,mail_spamfilter_user_add,mail_spamfilter_user_update
Did I miss something during the installation?

I'm happy to assist with implementing solutions if these are "real" problems and not simply "operator error".

Thanks!
Attached Images
 
Reply With Quote
  #403  
Old 29th December 2011, 18:44
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 392
Thanks: 29
Thanked 58 Times in 50 Posts
Default

I resolved the first issue by modifying /ispconfig3_account/skins/default/templates/account.html, line 22, and changing

Code:
<div id="mainscreen">
to

Code:
<div id="prefsscreen">
Is this a change that should be committed?
Reply With Quote
  #404  
Old 29th December 2011, 19:23
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 392
Thanks: 29
Thanked 58 Times in 50 Posts
Default

As to my second issue, I was able to resolve it by applying the correct Remote User permissions.

I determined that the following checkboxes in the Remote User interface allowed each section of the plug-in to function properly:

General
  • Mail alias functions

Password
  • Client functions

Fetchmail
  • Mail fetchmail functions

Autoreply
  • Mail user functions

Mail Filter
  • Mail user filter functions

Junk
  • Mail user functions
  • Mail spamfilter user functions
  • Mail spamfilter policy functions
  • Mail spamfilter whitelist functions
  • Mail spamfilter blacklist functions

Obviously, setting the checkboxes via the ISPConfig Remote User interface overwrites the values that were inserted manually during installation. So, either one should set the values during installation using the interface, or the instructions should be updated to include all of the necessary permission flags.

Perhaps at some point in the past the necessary permission checkboxes had not yet been added to the interface, but at this point, I see no reason to insert the values manually during installation. Using the interface seems to be far less error-prone.

EDIT: I realized that I was following outdated instructions. Horfic's post at http://www.howtoforge.com/forums/sho...926#post235926 is newer than the one I was using (NeeChee's at http://www.howtoforge.com/forums/sho...9&postcount=20 ). Horfic does mention which permissions need to be enabled for the Remote User, although his list is longer than mine. I don't receive any errors in the Roundcube plug-in with the shorter list of permissions enabled, but it's possible that something isn't working behind-the-scenes.

Last edited by cbj4074; 30th December 2011 at 18:44.
Reply With Quote
  #405  
Old 30th December 2011, 09:22
rkhalil rkhalil is offline
Junior Member
 
Join Date: Dec 2011
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Default soap error: login_error_regex

I always get a

"soap error: login_error_regex"

when I try to use any of the ispconfig plugis for roundcube. I'm using Ubuntu 10.04, ISPconfig 3.0.4.1, followed the guide http://www.howtoforge.com/forums/sho...926#post235926 from Horfic and tried roundcube 0.3 and 0.4 from Subversion 115 revision. The problem is that have no idea where to look for the logs to solve the problem, nothing in apache logs, nothing in ispconfig logs.... Any idea?

Thanks for your great job.
Reply With Quote
  #406  
Old 30th December 2011, 18:39
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 392
Thanks: 29
Thanked 58 Times in 50 Posts
Default

One of the core developers would probably know exactly what the issue is, but in their absence, we're left to troubleshoot on our own.

I searched the ISPConfig source-code for that error string and it's found in interface/web/mail/form/mail_user.tform.php (line 90).

From what I can tell, the error is triggered because the local portion of the email address fails the designated regular expression check, which is as follows:

Code:
^[a-z0-9][\w\.\-_\+@]{1,63}$
The part I don't understand is why this code is even being executed when you're using the Roundcube webmail plug-in. I can't even find any reference to the string "validators" in the Roundcube plug-in source code. Again, one of the developers would know more.

Out of curiosity, what email address are you using (just the first part)?
Reply With Quote
  #407  
Old 1st January 2012, 19:02
skuli434 skuli434 is offline
Junior Member
 
Join Date: Dec 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by jamesy View Post
hello, the latest version of the trunk still needs



Code:
'login' => $mail_user[0]['login'],
added on line below

Code:
'name' => $mail_user[0]['name'],

in : Ispconfig3_pass.php


otherwise you will get soap error: Login_error_regex

thanks for the great work!:d

thanks for the tip!!!!
Reply With Quote
  #408  
Old 1st January 2012, 19:06
maumar maumar is offline
Senior Member
 
Join Date: May 2009
Location: San Costanzo (PU - Italy)
Posts: 136
Thanks: 8
Thanked 11 Times in 11 Posts
Send a message via MSN to maumar Send a message via Skype™ to maumar
Lightbulb

i think that is better to take howto updated than to read 41 pages of this thread
Reply With Quote
  #409  
Old 1st January 2012, 19:24
maumar maumar is offline
Senior Member
 
Join Date: May 2009
Location: San Costanzo (PU - Italy)
Posts: 136
Thanks: 8
Thanked 11 Times in 11 Posts
Send a message via MSN to maumar Send a message via Skype™ to maumar
Default

Quote:
Originally Posted by Burge View Post
now i overwrite the file with the newst svn and i got a new error while try to change password.

the exception is now: Soap Error: email_error_isemail.

Is there any way to easy debug this problem?
you should debug

Code:
/usr/local/ispconfig/interface/lib/classes/remoting_lib.inc.php
as i did, it was helpful to me
Reply With Quote
  #410  
Old 1st January 2012, 19:42
maumar maumar is offline
Senior Member
 
Join Date: May 2009
Location: San Costanzo (PU - Italy)
Posts: 136
Thanks: 8
Thanked 11 Times in 11 Posts
Send a message via MSN to maumar Send a message via Skype™ to maumar
 
Default

here
-> ispconfig 3.0.4.1
-> rc 0.7

Quote:
Originally Posted by cbj4074 View Post
I resolved the first issue by modifying /ispconfig3_account/skins/default/templates/account.html, line 22, and changing

Code:
<div id="mainscreen">
to

Code:
<div id="prefsscreen">
Is this a change that should be committed?
i did it, but still i have the isssue
did u changed anything else?

Last edited by maumar; 1st January 2012 at 19:44.
Reply With Quote
Reply

Bookmarks

Tags
interface, ispconfig 3, mail, roundcube, squirrelmail, webmail

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 17:26
Debian Lenny: waiting for interface eth0:1 before doing NFS mounts (warning) edge Installation/Configuration 2 9th June 2009 07:55
IPtables rule to let PPTP access LAN brianwebb01 Installation/Configuration 0 1st May 2008 21:23
How to create a dhcp server for intranet (with multi-homed alias)? zenny HOWTO-Related Questions 8 29th February 2008 15:16
No DHCP on second LAN interface DrJohn Server Operation 2 8th November 2007 02:58


All times are GMT +2. The time now is 05:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.