Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Plugins/Modules/Addons

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
View Poll Results: Would you like to see a mailuser interface for Roundcube & Squirrelmail?
Yes 211 98.60%
No 3 1.40%
Voters: 214. You may not vote on this poll

Reply
 
Thread Tools Display Modes
  #251  
Old 31st August 2010, 20:12
logicasrl logicasrl is offline
Junior Member
 
Join Date: Aug 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Lightbulb

Quote:
Originally Posted by HyperAtom View Post
I also had the permission denied error, I gave access to Horfic so he fixed the problem for me. Not sure what he did but he told me to use his dev trunk for the most up to date plugin.
I've read this thread a little more and probably the solution has already been posted by Horfic some days ago: take a look here:
http://www.howtoforge.net/forums/showthread.php?t=46134
http://howtoforge.com/forums/showthr...926#post235926

Tomorrow I'll give these suggestions a try and make you all know the result.

Luca
Reply With Quote
Sponsored Links
  #252  
Old 1st September 2010, 10:08
logicasrl logicasrl is offline
Junior Member
 
Join Date: Aug 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Smile NOW almost everything is working right

Well,

I have followed the directives given by Horfic in the following link:
http://howtoforge.com/forums/showthr...926#post235926

and now EVERYTHING (with one exception) is working correctly. Thank you to Horfic
Password, autoreply, filter and spam are ALL OK.

The last problem is in the "white/black list" addon: in this case the "SOAP error: you do not have the permissions to access this function" remains.

I'm using ISPConfig 3.0.2.2, Roundcube 0.4 and the addon downloaded from "http://svn.web-wack.at/ispconfig3_roundcube/branches/rouncube4/" and installed by Subversion (svn).

Here is it the content of the "remote_functions" field in the "remote_user" table of the "dbispconfig" database:
mail_domain_get,mail_domain_add,mail_domain_update ,mail_domain_delete;mail_user_get,mail_user_add,ma il_user_update,mail_user_delete;mail_alias_get,mai l_alias_add,mail_alias_update,mail_alias_delete;ma il_forward_get,mail_forward_add,mail_forward_updat e,mail_forward_delete;mail_catchall_get,mail_catch all_add,mail_catchall_update,mail_catchall_delete; mail_transport_get,mail_transport_add,mail_transpo rt_update,mail_transport_delete;mail_whitelist_get ,mail_whitelist_add,mail_whitelist_update,mail_whi telist_delete;mail_blacklist_get,mail_blacklist_ad d,mail_blacklist_update,mail_blacklist_delete;mail _spamfilter_user_get,mail_spamfilter_user_add,mail _spamfilter_user_update,mail_spamfilter_user_delet e;mail_policy_get,mail_policy_add,mail_policy_upda te,mail_policy_delete;mail_fetchmail_get,mail_fetc hmail_add,mail_fetchmail_update,mail_fetchmail_del ete;mail_user_filter_get,mail_user_filter_add,mail _user_filter_update,mail_user_filter_delete;mail_f ilter_get,mail_filter_add,mail_filter_update,mail_ filter_delete;client_get,client_add,client_update, client_delete

Is there something else to control?

Thank you again,
Luca
Reply With Quote
  #253  
Old 1st September 2010, 10:55
logicasrl logicasrl is offline
Junior Member
 
Join Date: Aug 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up Eureka!

Solved the last problem on the "white/black list" addon

Simply used the SQL suggested by Horfic here "http://howtoforge.com/forums/showthread.php?p=235926#post235926".

It is necessary to execute this instruction directly in the "dbispconfig" DB (through phpmyadmin, for example):
UPDATE `remote_user` SET `remote_functions` = 'mail_domain_get,mail_domain_add,mail_domain_updat e,mail_domain_delete;mail_user_get,mail_user_add,m ail_user_update,mail_user_delete;mail_alias_get,ma il_alias_add,mail_alias_update,mail_alias_delete;m ail_forward_get,mail_forward_add,mail_forward_upda te,mail_forward_delete;mail_spamfilter_whitelist_g et,mail_spamfilter_whitelist_add,mail_spamfilter_w hitelist_update,mail_spamfilter_whitelist_delete;m ail_spamfilter_blacklist_get,mail_spamfilter_black list_add,mail_spamfilter_blacklist_update,mail_spa mfilter_blacklist_delete;mail_spamfilter_user_get, mail_spamfilter_user_add,mail_spamfilter_user_upda te,mail_spamfilter_user_delete;mail_policy_get,mai l_policy_add,mail_policy_update,mail_policy_delete ;mail_fetchmail_get,mail_fetchmail_add,mail_fetchm ail_update,mail_fetchmail_delete;mail_user_filter_ get,mail_user_filter_add,mail_user_filter_update,m ail_user_filter_delete;client_get,client_get_id,cl ient_add,client_update,client_delete;server_get' WHERE `remote_user`.`remote_username` = '<<REMOTE USERNAME>>' LIMIT 1 ;

For some strange reason, activate the following list in the remote user profile in ISPConfig is NOT sufficient:
Mail domain functions
Mail user functions
Mail alias functions
Mail forward functions
Mail catchall functions
Mail transport functions
Mail whitelist functions
Mail blacklist functions
Mail spamfilter user functions
Mail spamfilter policy functions
Mail fetchmail functions
Mail user filter functions
Mail filter functions
Client functions
probably because in my ISPConfig version (3.0.2.2) the voice "Server functions" is NOT present...

In any case, now all is working perfectly

Luca
Reply With Quote
  #254  
Old 1st September 2010, 13:39
007007 007007 is offline
Senior Member
 
Join Date: Jul 2010
Posts: 139
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by logicasrl View Post
It is necessary to execute this instruction directly in the "dbispconfig" DB (through phpmyadmin, for example):
UPDATE `remote_user` SET `remote_functions` = 'mail_domain_get,mail_domain_add,mail_domain_updat e,mail_domain_delete;mail_user_get,mail_user_add,m ail_user_update,mail_user_delete;mail_alias_get,ma il_alias_add,mail_alias_update,mail_alias_delete;m ail_forward_get,mail_forward_add,mail_forward_upda te,mail_forward_delete;mail_spamfilter_whitelist_g et,mail_spamfilter_whitelist_add,mail_spamfilter_w hitelist_update,mail_spamfilter_whitelist_delete;m ail_spamfilter_blacklist_get,mail_spamfilter_black list_add,mail_spamfilter_blacklist_update,mail_spa mfilter_blacklist_delete;mail_spamfilter_user_get, mail_spamfilter_user_add,mail_spamfilter_user_upda te,mail_spamfilter_user_delete;mail_policy_get,mai l_policy_add,mail_policy_update,mail_policy_delete ;mail_fetchmail_get,mail_fetchmail_add,mail_fetchm ail_update,mail_fetchmail_delete;mail_user_filter_ get,mail_user_filter_add,mail_user_filter_update,m ail_user_filter_delete;client_get,client_get_id,cl ient_add,client_update,client_delete;server_get' WHERE `remote_user`.`remote_username` = '<<REMOTE USERNAME>>' LIMIT 1 ;
this is only for ispconfig3.2.2, it's not worked for me (ispconfig3.0.3)
Reply With Quote
  #255  
Old 1st September 2010, 13:56
letic letic is offline
HowtoForge Supporter
 
Join Date: Jul 2006
Posts: 28
Thanks: 10
Thanked 3 Times in 3 Posts
Default

Hey Horfic,

Here is my small contribution. You will find the updated French UTF-8 translation for your plugins. At the moment we are only using 3.0.2 but as soon as 3.0.3 is released I'll make sure that all plugins that do not work with 3.0.2 are correctly translated as well.

Hope this help
Cheers
LeTic
Attached Files
File Type: gz fr_FR.tar.gz (1.7 KB, 153 views)
Reply With Quote
The Following User Says Thank You to letic For This Useful Post:
Horfic (1st September 2010)
  #256  
Old 6th September 2010, 12:02
SeberIT SeberIT is offline
Junior Member
 
Join Date: May 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default adding forward clears mail filter/custom rules

I have a problem with the forward plugin. When I fill out a forward address (without enabling it), my custom rules view in the CP for the user gets empty. When I click and save all mail filters one by one, the custom rules field is filled again.
Reply With Quote
  #257  
Old 8th September 2010, 12:16
blackangel blackangel is offline
Junior Member
 
Join Date: Sep 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello.

I got a 404 error when I try to use the official SVN repo at
http://svn.web-wack.at/ispconfig3_roundcube3/

I don't find the code anywhere else.

Any clue ?

Thank you.
Reply With Quote
  #258  
Old 8th September 2010, 12:27
Horfic Horfic is offline
Senior Member
 
Join Date: Mar 2009
Location: Austria
Posts: 325
Thanks: 55
Thanked 95 Times in 60 Posts
Send a message via Skype™ to Horfic
Default

@blackangel
You obviously didn't read the last release post. We changed the repo.

Please refer to the release post.
http://howtoforge.com/forums/showpos...&postcount=220
__________________
web wack creations - We create your custom web application
Mailuser interface for ISPConfig 3
Reply With Quote
  #259  
Old 8th September 2010, 13:42
blackangel blackangel is offline
Junior Member
 
Join Date: Sep 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Horfic View Post
@blackangel
You obviously didn't read the last release post. We changed the repo.
Yep, thank you for this link

What I did:
- I was on http://www.ispconfig.org/ispconfig-3/download/
- I've clicked on "SPConfig 3 mailuser interface for roundcube [Info + Download]"
- and I was redirected to
http://howtoforge.com/forums/showpos...9&postcount=20

I think they should update this link on the official website and also on sourceforge:
http://sourceforge.net/projects/roun...lugin/develop/

Thanks again.
Cdric
Reply With Quote
  #260  
Old 28th September 2010, 11:49
Rupert Rupert is offline
Junior Member
 
Join Date: Feb 2008
Posts: 26
Thanks: 1
Thanked 1 Time in 1 Post
 
Default

Hello,

im still having problems getting the svn checkout:


Code:
# svn checkout  http://svn.web-wack.at/ispconfig3_roundcube/branches/rouncube4/ .
svn: OPTIONS of 'http://svn.web-wack.at/ispconfig3_roundcube/branches/rouncube4': could not connect to server (http://svn.web-wack.at)
websvn works fine
isnt there a packed file to download for people having svn trouble?
Reply With Quote
Reply

Bookmarks

Tags
interface, ispconfig 3, mail, roundcube, squirrelmail, webmail

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 17:26
Debian Lenny: waiting for interface eth0:1 before doing NFS mounts (warning) edge Installation/Configuration 2 9th June 2009 07:55
IPtables rule to let PPTP access LAN brianwebb01 Installation/Configuration 0 1st May 2008 21:23
How to create a dhcp server for intranet (with multi-homed alias)? zenny HOWTO-Related Questions 8 29th February 2008 15:16
No DHCP on second LAN interface DrJohn Server Operation 2 8th November 2007 02:58


All times are GMT +2. The time now is 00:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.