Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th January 2006, 20:26
saialkesh saialkesh is offline
Junior Member
 
Join Date: Jan 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Angry unable to login root in GUI Mode in Suse10

Hi
I have managed to install Suse10 on my pc. The installation was fine and immediately after the installation i was able to login in KDE as root and worked on the GUI desktop.
After having shutdown and restarted the machine, now am unable to login as root in GUI. i can login as other user but not as root. TTY allows me to login as root.

I need to login as root in GUI.

Any suggestions whats to be done.
Reply With Quote
Sponsored Links
  #2  
Old 14th January 2006, 23:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,486
Thanks: 813
Thanked 5,256 Times in 4,121 Posts
Default

You can try to login as root in TTY and the run the command "startx".

But one question, why do you need root login in KDE?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 15th January 2006, 11:17
saialkesh saialkesh is offline
Junior Member
 
Join Date: Jan 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks Till. Will try with startx.

I want to know what to do if root wants to log in in KDE. It did allow me immediately after the installation, but stopped on restart.

For knowledge sake, need to know what to do in a scenario like this.

[Till] Sorry, edited your post instead of mine. Redone the changes

Last edited by till; 15th January 2006 at 12:39.
Reply With Quote
  #4  
Old 15th January 2006, 12:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,486
Thanks: 813
Thanked 5,256 Times in 4,121 Posts
Default

Quote:
Originally Posted by saialkesh
For knowledge sake, need to know what to do in a scenario like this.
Edit /etc/opt/kde3/share/config/kdm/kdmrc, find the line with AllowRootLogin
and set it to true and restart kdm with "rcxdm restart".
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 15th January 2006, 20:16
saialkesh saialkesh is offline
Junior Member
 
Join Date: Jan 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

checked the file and it does say allowrootlogin=true. But strangely i still cannot login.

Strange !!!

I did not have this problem in 9.3 Is this something related to Ver 10.0.

I agree its not a good security practice to let root login, but whats making me curious is what is it thats blocking it ?
Reply With Quote
  #6  
Old 4th March 2006, 14:43
jchajecki jchajecki is offline
Junior Member
 
Join Date: Mar 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm not sure its just a version 10 issue. I'm on 9.3 and I recently started having a similar problem. I start up the machine and I get the GUI login. I log in a root and get what looks like a command window. If I type startkde the desktop then starts up. The copmmand window has the title 'Failsafe'. This only happens loggining in as root. Like yourself, I can log in as another user and KDE starts automatocally, but not for root. I have also checked my kdmrc and AllowRootLogin is set to 'true'. I'm still digging around but I'm equally baffled.
Reply With Quote
  #7  
Old 4th March 2006, 18:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Maybe this is some kind of security measure on SuSE?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 5th March 2006, 17:31
jchajecki jchajecki is offline
Junior Member
 
Join Date: Mar 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Maybe this is some kind of security measure on SuSE?
Some distros do indeed disable this be default, and arguably one shouldn't do this, but SuSE hasn't up to now. Mine worked fine until a couple of days ago. I can do as suggested above (have changed to runlevel 3 and log into the text screen then type startx) and it works fine. I will probably stick to this now as it is safer.
Reply With Quote
  #9  
Old 5th March 2006, 18:11
jchajecki jchajecki is offline
Junior Member
 
Join Date: Mar 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just found this. It may explain why some of us are suddenly finding this situation.

http://wiki.suselinuxsupport.de/wikk...wToLoginasroot
Reply With Quote
  #10  
Old 6th March 2006, 18:41
jchajecki jchajecki is offline
Junior Member
 
Join Date: Mar 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Just to point out that the article in the link above seems to have been edited and no longer mentions that SuSE released an update to apply this. As`a result, anyone who has autoupdate enabled and configured may find that all of a sudden their root login to GUI starts a restriced xterm rather than the KDE desktop.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix error dianer Installation/Configuration 22 8th May 2006 00:31
ispconfig and mambo shajazzi Installation/Configuration 70 28th March 2006 19:29
Users Cannot Delete Files in FTP Ran2004 Server Operation 9 19th January 2006 06:36
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 14:42
ISPConfig pop3 problem mphayesuk General 21 31st October 2005 10:53


All times are GMT +2. The time now is 19:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.