Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > MyDNSConfig > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd February 2009, 06:32
gcambull gcambull is offline
Junior Member
 
Join Date: Jan 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default MyDNS startup failed

during the initial ISPConfig install the failure of MyDNS to start up was present, I put it aside for a couple weeks, as I had other projects. Now that I have the time, I booted the server and the same failure occurs with MyDNS connecting to Mysql, here is the error after I used the Interactive startup:

Code:
Start Service MyDNS: [Y]es/[N]o/[C]ontinue

Starting MyDNS: mydns[2347]: error connecting to Mysql Server at localhost: Can't connect to local Mysql Server through socket '/var/lib/mysql/mysql.sock' (2) (errno=2)      [FAILED]
FYI Mysql start up comes after Mydns, could that be a factor and how to correct it.

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 23rd February 2009, 18:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by gcambull View Post
FYI Mysql start up comes after Mydns, could that be a factor and how to correct it.
Try
Code:
/etc/init.d/mydns restart
Does it start then?
Which distribution are you using?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 23rd February 2009, 18:31
gcambull gcambull is offline
Junior Member
 
Join Date: Jan 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Falko,

After searching for other answers I came across one of the same question but in the ISPconfig cat, and saw that you asked the same question. And yes it did restart, first it failed on stopping then it said start was ok. I was also curious why it stated it was failing on startup, but ISPConifg stated it was working.

Answer is yes.

Thanks

Using CentOs5.2

Last edited by gcambull; 23rd February 2009 at 18:33. Reason: add link to other question
Reply With Quote
  #4  
Old 3rd March 2009, 02:06
binaryrogue binaryrogue is offline
Member
 
Join Date: Apr 2008
Posts: 89
Thanks: 5
Thanked 0 Times in 0 Posts
Default

I'm also experiencing the same issue. ONLY During startup, myDNS would not start. If I restart services as mentioned, it will start fine.. I'm using Fedora 9.

Mar 2 08:57:35 ispc1 mydns[1890]: Error connecting to MySQL server at localhost: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) (errno=2)

After doing a "service mydns restart"

Mar 2 09:08:01 ispc1 mydns[2648]: mydns 1.1.0 started Mon Mar 2 09:08:01 2009 (listening on 3 addresses)

Last edited by binaryrogue; 3rd March 2009 at 02:08.
Reply With Quote
  #5  
Old 3rd March 2009, 02:26
binaryrogue binaryrogue is offline
Member
 
Join Date: Apr 2008
Posts: 89
Thanks: 5
Thanked 0 Times in 0 Posts
Default

mydns does appears to start before mysql. I just changed the startup order around in the rc3.d/ directory.
Reply With Quote
  #6  
Old 3rd March 2009, 05:43
gcambull gcambull is offline
Junior Member
 
Join Date: Jan 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by binaryrogue View Post
mydns does appears to start before mysql. I just changed the startup order around in the rc3.d/ directory.
...and how do you do that? The problem I had went away, but like someone also said, wait and it will begin to play (so to speak), but how do you change the order?

Thanks

oh wait ur using Fed 9, me using CentOs5.2, hmm

Last edited by gcambull; 3rd March 2009 at 05:44. Reason: different os
Reply With Quote
  #7  
Old 3rd March 2009, 08:22
binaryrogue binaryrogue is offline
Member
 
Join Date: Apr 2008
Posts: 89
Thanks: 5
Thanked 0 Times in 0 Posts
Default

The /etc/rc.d/rc3.d/ directory list all services that starts up on run level 3. I changed the order by giving mysqld a higher priority.

Before the change -
S64mydns
S52mysqld

After the change -
S63mysqld
S64mydns
Reply With Quote
  #8  
Old 12th May 2009, 11:05
baskin baskin is offline
Senior Member
 
Join Date: Jan 2008
Location: Syros, Greece
Posts: 118
Thanks: 9
Thanked 8 Times in 8 Posts
Default

I have the same problem on Opensuse 11.1.

Mydns fails on startup but it runs ok if i execute it after the boot.

The strange with me is that in my /etc/rc.d/rc3.d i have:

S08mysql
S11mydns

but it fails to load on boot.

Any suggestions?
Reply With Quote
  #9  
Old 12th May 2009, 17:56
nikita nikita is offline
Junior Member
 
Join Date: May 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Exact same problem here. I even tried installing on defferent machines(4) and... same problem. I've also change the name to S99mydns to be sure, but no effect. tried to edit the /etc/rc.d/rc3.d/S11mydns to put a dependency to start after mysql... no luck. All-in-all i've spent 5 days trying to find a solution. Any help from some openSUSE gurus?
Reply With Quote
  #10  
Old 13th May 2009, 12:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

I'd try to change S11mydns to S99mydns.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freebsd 6.1 support misterm Installation/Configuration 10 9th April 2009 09:29
Anyone figured out to integrate FuzzyOCR into ISPConfig on Ubuntu? friday Installation/Configuration 16 10th May 2007 16:25
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 22:40


All times are GMT +2. The time now is 21:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.