Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th April 2009, 15:11
efree_unix efree_unix is offline
Junior Member
 
Join Date: Apr 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Question How To Set Up apache2 With mod_fcgid And PHP5 On CentOS 5.2 (With ispConfig 2)?

Hi, I have read your good tutorial with the topic "How To Set Up apache2 With mod_fcgid And PHP5 On CentOS 5.2."

I want to install mod_fcgid on my server. but I have installed apache2, PHP5, and ispConfig 2 on centos 5.2 and it ran smoothly. can I follow that tutorial? or there are somethings that I need to do because I use ispConfig maybe?

I really need your explanation. thank you very much...
Reply With Quote
Sponsored Links
  #2  
Old 17th April 2009, 17:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,726 Times in 2,565 Posts
Default

ISPConfig 2 doesn't support mod_fcgid, so you'd have to add the configuration directives for mod_fcgid to the Apache Directives field of each web site in ISPConfig.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 18th April 2009, 05:08
efree_unix efree_unix is offline
Junior Member
 
Join Date: Apr 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

How? Could you give an example?
Reply With Quote
  #4  
Old 19th April 2009, 15:47
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,726 Times in 2,565 Posts
Default

You can find an example here: http://www.howtoforge.com/how-to-set...-on-centos-5.2
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 20th April 2009, 04:27
efree_unix efree_unix is offline
Junior Member
 
Join Date: Apr 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks falko. all running smoothly.
but there is one that makes me confused. if I commented out the "#LoadModule php5_module modules/libphp5.so" in "/etc/httpd/conf.d/php.conf", then when I tried to restart httpd service, the error message would appear like this:
Starting httpd: Syntax error on line 50 of /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf:
Invalid command 'php_admin_flag', perhaps misspelled or defined by a module not included in the server configuration
[Failed]
.

but if I did not comment out "LoadModule php5_module modules/libphp5.so", all running smoothly. Do you know the problem?
Reply With Quote
  #6  
Old 20th April 2009, 12:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,726 Times in 2,565 Posts
 
Default

php_admin_flag works only with mod_php.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 06:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.