Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th August 2009, 14:47
n3ls0n n3ls0n is offline
Junior Member
 
Join Date: Aug 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Question cannot read from above directory

Hi all,

i am sure some of you had already stumped on a case similar to mine, but i cannot find any pointers to the right directorion.
The problem is this: I have a file conf.inc.php, which has the credentials to access the Mysql Database. According to some experts, this kind of file should not reside in the same directory has the website, but instead in a upper directory, for security reasons. I have done that, but it seems that although i have a include in the index.php file, the conf.inc.php never gets read and a Apache error appears on the webpage (Access denied for user 'apache'@'localhost' (using password: NO)).
The directory tree is this:
/html
conf.inc.php
/site
index.php

Odd stuff:
1) if i copy the conf.inc.php into the /site directory, the website works perfectly (although the include file points to the above directory) can´t understand this behaviour.
2) if i add the apache user to mysql, the error says that there is no database selected.

Any help would be appreciated.

Thanks in advance,
Nelson.
Reply With Quote
Sponsored Links
  #2  
Old 14th August 2009, 12:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

Can you go to the html directory and post the output of
Code:
ls -la
?
Can you also post the Apache vhost configuration here?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Install failure -- Apache 1.3 missing? Allen15 Installation/Configuration 11 24th February 2009 10:53
can't help ispconfig to install please help steve51184 Installation/Configuration 17 20th February 2009 11:37
ISPConfig install issues... flyingaggie Installation/Configuration 2 18th July 2008 11:46
add web site serr57 Installation/Configuration 18 13th April 2008 12:40
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 18:17


All times are GMT +2. The time now is 00:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.