Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th September 2006, 12:58
io_freak io_freak is offline
Junior Member
 
Join Date: Sep 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Mail goes to /var/mail instead of $HOME/Maildir/

I have ISPConfig installed since 1 year now and all were working well. I used maildir in ispconfig and the mails were successfully delivered to $HOME/Maildir. Recently, i got a strange problem with my mail reception, all my mails for my users are being sent to /var/mail/USER.

I have checked my config file:
After the installation of ispconfig, i have tick, Maildir in management -> server -> settings -> Email -> maildir

/etc/postfix/main.cf
home_mailbox = Maildir/
mailbox_command =

Please some helps because my users can no longer receive their mails....
Reply With Quote
Sponsored Links
  #2  
Old 9th September 2006, 18:26
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,482
Thanks: 835
Thanked 5,524 Times in 4,345 Posts
Default

Please post an excerpt of your mail log.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 13th September 2006, 16:32
io_freak io_freak is offline
Junior Member
 
Join Date: Sep 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

In fact, i have indentified the problem.

My server has the domaine hostname.mydomain.com and i have a virtual domain as vitualdomain.com

When I send an email to user@virtualdomain.com, the mail does not go to the virtual domain instead it goes to user@hostname.mydomain.com. That's why instead to send the mail to the maildir of the user it sends it to /var/mail...

any help will be much appreciated.

Thanks
Reply With Quote
  #4  
Old 13th September 2006, 20:44
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,482
Thanks: 835
Thanked 5,524 Times in 4,345 Posts
Default

Quote:
Originally Posted by io_freak
When I send an email to user@virtualdomain.com, the mail does not go to the virtual domain instead it goes to user@hostname.mydomain.com. That's why instead to send the mail to the maildir of the user it sends it to /var/mail...
Thats ok! Please check the Maildir checkbox in ISPConfig under management > server > settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 14th September 2006, 09:22
io_freak io_freak is offline
Junior Member
 
Join Date: Sep 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have already checked the box for Maildir part in Management -> server -> settings -> Email.

But the problem persists.

I am using the version 2.1.2

Thanks
Reply With Quote
  #6  
Old 14th September 2006, 09:34
io_freak io_freak is offline
Junior Member
 
Join Date: Sep 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here is an extract of my log file file:

Sep 14 06:45:16 hostname postfix/smtpd[15284]: 69841133F0: client=unknown[202.123.24.165]
Sep 14 06:45:17 hostname postfix/cleanup[30573]: 69841133F0: message-id=<FD158B6EDD235A4DA4D120233FAA5783021C1FFF@sun.c o.mu>
Sep 14 06:45:17 hostname postfix/qmgr[7890]: 69841133F0: from=<reservation.mu@oneandonlyresorts.mu>, size=12709, nrcpt=2 (queue active)
Sep 14 06:45:29 hostname postfix/local[13711]: 69841133F0: to=<c2_matilda@hostname.mydomaine.com>, orig_to=<matilda@virtualdomaine.com>, relay=local, delay=14, status=sent (delivered to command: /usr/bin/procmail -f-)
Sep 14 06:45:29 hostname postfix/qmgr[7890]: 69841133F0: removed


And now i just started to receive a quota exceed mesg:

Sep 14 07:18:46 trinity imaplogin: Failed to create cache file: maildir_lock (c2_matilda)
Sep 14 07:18:46 trinity imaplogin: Error: Disk quota exceeded
Sep 14 07:19:47 trinity imaplogin: Failed to create cache file: maildir_lock (c2_matilda)
Sep 14 07:19:47 trinity imaplogin: Error: Disk quota exceeded
Sep 14 07:20:47 trinity imaplogin: Failed to create cache file: maildir_lock (c2_matilda)
Sep 14 07:20:47 trinity imaplogin: Error: Disk quota exceeded

Please some helps...

Last edited by io_freak; 14th September 2006 at 09:48.
Reply With Quote
  #7  
Old 14th September 2006, 09:53
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,482
Thanks: 835
Thanked 5,524 Times in 4,345 Posts
Default

Ok, then it is clear. Set the disk quota in ISPConfig for the user c2_matilda and / or the website to a higher level and your email will work.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 14th September 2006, 10:18
io_freak io_freak is offline
Junior Member
 
Join Date: Sep 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Usually what i do is that, i give a disk allocation to /, which is (www.paradis.com) and all the users do not have any limitation.

In this case, I have given a disk space 1.2 Go for a set of 12 users.
For each user, in the WebSpace MB, i give -1 (ie no limit) and for / Space MB is 1280.

So each time i cannot increase the limit as you said each time a client exceed its quota.
I can increase it to see if the problem persist or not.

NB: Before the system ISP functions, then i got an exceed of quota for this client and then the mail no longer go to Maildir but to /var/mail/$USER

please....

thanks till
Reply With Quote
  #9  
Old 14th September 2006, 10:26
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,482
Thanks: 835
Thanked 5,524 Times in 4,345 Posts
Default

Please set the quota to a higher value as I posted above and check if the mail arrives again in the maildir.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 14th September 2006, 10:49
io_freak io_freak is offline
Junior Member
 
Join Date: Sep 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

yes Till, I have just done what you asked. I have put the quota from 1200 to 3000 MB.

Now, all the mails are entering in the Maildir account. Its working .....

So what i need to do really when getting these problems again

thanks till
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Not receiving any incoming mail. Jcorrea920 General 11 3rd April 2010 14:08
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 09:27
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 13:16
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs mholownych HOWTO-Related Questions 10 29th May 2006 04:39
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 12:47


All times are GMT +2. The time now is 14:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.