Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th August 2009, 12:19
wabz wabz is offline
Member
 
Join Date: Jul 2009
Posts: 84
Thanks: 4
Thanked 0 Times in 0 Posts
Default Joomla and Ispconfig

Guy the server works the problem is getting joomla to work........get the following error

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@uwasnet.org and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


This stuff aint easy. I am using suse 11.1, suphp and ispconfig 3. Please help
Reply With Quote
Sponsored Links
  #2  
Old 13th August 2009, 09:02
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,769
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

If you get an error, look at the error log of the site to find the reason.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 14th August 2009, 11:35
wabz wabz is offline
Member
 
Join Date: Jul 2009
Posts: 84
Thanks: 4
Thanked 0 Times in 0 Posts
Default Checking

how do i check the logs?
Reply With Quote
  #4  
Old 15th August 2009, 08:51
wabz wabz is offline
Member
 
Join Date: Jul 2009
Posts: 84
Thanks: 4
Thanked 0 Times in 0 Posts
Default Checked

My error log has the following recurring all through

error log
[Sat Aug 15 09:06:24 2009] [error] [client 65.55.106.184] File does not exist: /usr/share/apache2/error/500.html
[Sat Aug 15 09:07:50 2009] [alert] [client 192.168.1.6] /srv/www/uwasnet.org/web/.htaccess: RewriteEngine not allowed here
[Sat Aug 15 09:07:50 2009] [error] [client 192.168.1.6] File does not exist: /usr/share/apache2/error/500.html


access log

65.55.106.184 - - [15/Aug/2009:09:06:24 +0300] "GET /aboutus.html HTTP/1.0" 404 - "-" "msnbot/2.0b (+http://search.msn.com/msnbot.htm)"
192.168.1.6 - - [15/Aug/2009:09:07:50 +0300] "GET / HTTP/1.1" 404 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.13) Gecko/2009073022 Firefox/3.0.13"
~


tried following the thread http://www.howtoforge.com/forums/showthread.php?t=33805 and apparently it aint getting me results. I am using suse 11.1, joomla 1.5.11 and ispconfig 3.
Reply With Quote
  #5  
Old 15th August 2009, 12:56
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by wabz View Post
[Sat Aug 15 09:07:50 2009] [alert] [client 192.168.1.6] /srv/www/uwasnet.org/web/.htaccess: RewriteEngine not allowed here
Try this in the Apache Directives field of that web site in ISPConfig:

Code:
<Directory srv/www/uwasnet.org/web>
        Options All
        AllowOverride All
        Order allow,deny
        Allow from all
</Directory>
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 16th August 2009, 22:19
wabz wabz is offline
Member
 
Join Date: Jul 2009
Posts: 84
Thanks: 4
Thanked 0 Times in 0 Posts
Default which file?

Which file do i add the directive
Reply With Quote
  #7  
Old 17th August 2009, 09:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,769
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

As Falko mentioned above, this has to be added to the apache directives field in ispconfig and not in a file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 17th August 2009, 10:14
wabz wabz is offline
Member
 
Join Date: Jul 2009
Posts: 84
Thanks: 4
Thanked 0 Times in 0 Posts
Default So how

So how do i get there as in adding the directive to ispconfig.

Ok ignore the question i figured it out

Last edited by wabz; 17th August 2009 at 10:28.
Reply With Quote
  #9  
Old 17th August 2009, 10:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,769
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Take a look at the website settings. there is just one field with this name on the options tab.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 17th August 2009, 15:33
wabz wabz is offline
Member
 
Join Date: Jul 2009
Posts: 84
Thanks: 4
Thanked 0 Times in 0 Posts
 
Default New Error

Now i have a new error

[Mon Aug 17 15:32:43 2009] [error] [client 192.168.1.6] SecurityException in Application.cpp:437: Handler not found in configuration
[Mon Aug 17 15:32:43 2009] [error] [client 192.168.1.6] Caused by KeyNotFoundException in Configuration.cpp:234: Handler "x-httpd-suphp" not found
[Mon Aug 17 15:32:43 2009] [error] [client 192.168.1.6] Premature end of script headers: index.php
[Mon Aug 17 15:32:43 2009] [error] [client 192.168.1.6] File does not exist: /usr/share/apache2/error/500.html


So what do i do now? By the way will searching the forum i found this thread http://www.howtoforge.com/forums/showthread.php?t=35799. I went on to check mu suphp.conf and found this line


x-httpd-php=php:/srv/www/cgi-bin/php5 should it be x-httpd-suphp=php:/usr/bin/php-cgi

Last edited by wabz; 17th August 2009 at 15:44.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with ISPconfig / joomla tremor General 4 31st May 2009 23:35
ISPConfig 2.x & Joomla! pjdevries Developers' Forum 4 25th November 2008 08:28
ISPCONFIG - JOOMLA - extensions (images) issue grazman HOWTO-Related Questions 11 9th June 2007 12:11
ubuntu ispconfig joomla .htaccess steve1084 General 8 6th January 2007 15:55
Joomla & ISPconfig ikaros General 7 3rd October 2006 12:16


All times are GMT +2. The time now is 17:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.