#1  
Old 29th July 2009, 11:37
v2k v2k is offline
Member
 
Join Date: Sep 2007
Location: Vancouver, Canada
Posts: 93
Thanks: 3
Thanked 1 Time in 1 Post
Default google apps gmail

I'm using google's gmail app to manage my server's email.

So externally, v2k@example.com goes to google's mail server and that gmail account.

However, on example.com, if I email to v2k@example.com it goes to the localhost (as expected).

How do I get local mail to go to google as well? I'm using postfix on fedora.

Linux 2.6.23.17-88.fc7 #1 SMP Thu May 15 00:02:29 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux
Reply With Quote
Sponsored Links
  #2  
Old 30th July 2009, 20:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

You must remove example.com from mydestination in /etc/postfix/main.cf.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
v2k (31st July 2009)
  #3  
Old 30th July 2009, 20:28
v2k v2k is offline
Member
 
Join Date: Sep 2007
Location: Vancouver, Canada
Posts: 93
Thanks: 3
Thanked 1 Time in 1 Post
Default

Thanks, I will try that. This is the only information I found on the subject:

http://www.postfix.org/STANDARD_CONF...ON_README.html

Quote:
A null client is a machine that can only send mail. It receives no mail from the network, and it does not deliver any mail locally. A null client typically uses POP, IMAP or NFS for mailbox access.

In this example we assume that the Internet domain name is "example.com" and that the machine is named "nullclient.example.com". As usual, the examples show only parameters that are not left at their default settings.

1 /etc/postfix/main.cf:
2 myorigin = $mydomain
3 relayhost = $mydomain
4 inet_interfaces = loopback-only
5 local_transport = error:local delivery is disabled
6
7 /etc/postfix/master.cf:
8 Comment out the local delivery agent entry
Reply With Quote
  #4  
Old 31st July 2009, 00:14
v2k v2k is offline
Member
 
Join Date: Sep 2007
Location: Vancouver, Canada
Posts: 93
Thanks: 3
Thanked 1 Time in 1 Post
Default

Thanks, your solution worked
Reply With Quote
  #5  
Old 12th August 2009, 19:59
v2k v2k is offline
Member
 
Join Date: Sep 2007
Location: Vancouver, Canada
Posts: 93
Thanks: 3
Thanked 1 Time in 1 Post
 
Default

I'm trying to do this on another server, but I'm not having any luck.

It's running CentOS 5 with Plesk 9; qmail and postfix; although I'm not sure postfix is being used. I didn't setup the server from scratch, it's a VDS.

It's hosting "server.com" with a vhost for a subdomain of "example.com"; example.com is hosted elsewhere. So subdomain.example.com is a vhost on server.com

From "server.com"

[root@server control]# echo hey | sendmail myname@gmail.com
[root@server control]# echo hey | sendmail myname@example.com

The 1st line works, the 2nd doesn't - I assume it's because I'm hosting subdomain.example.com on the vhost; at least that's my only guess.

I'd like to set it up to use gmail to handle all the incoming mail, so I only need to be able to send mail.

From reading about qmail, I thought the issue would be that local-host-names contained example.com. However, /etc/mail/local-host-names only lists server.com.

Edit: all the mail sent to example.com sits in the mail queue which is visible in plesk.

Last edited by v2k; 12th August 2009 at 20:48.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig3 plugable mail subsystem (for Google Apps) and nginx as alternative eugenesan Developers' Forum 49 20th February 2011 20:04
Setting up Google Apps for my Domain meekish Installation/Configuration 11 15th April 2009 18:41
Unknown MX record and Reverse PTR question for Google Apps email safoo Server Operation 1 31st March 2009 18:26
Cannot set up Google Apps Email. Please Help! alexwalkey Installation/Configuration 6 8th April 2008 10:43
ispconfig & google apps & ddns lain27 Installation/Configuration 3 29th October 2007 17:10


All times are GMT +2. The time now is 23:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.