Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th August 2009, 05:56
markerman markerman is offline
Member
 
Join Date: Dec 2007
Posts: 33
Thanks: 1
Thanked 0 Times in 0 Posts
Default The Perfect SpamSnake - Ubuntu Jaunty Jackalope

Hi Rocky,
Trying to build a new spamsnake server, but running into the same issue over and over again. I am doing it in VMware ESXi so I can revert back to snapshot when it goes bad. So I have tried 4 times following the instructions without deviation just in case I missed something, but I keep getting stuck at the same place. When I move Pyzor I get the following errors...

root@spamsnake:/# mv /var/lib/python-support/python2.6/pyzor-* /var/lib/python-support/python2.5/

mv: cannot move `/var/lib/python-support/python2.6/pyzor-0.4.0.egg-info' to `/var/lib/python-support/python2.5/': Not a directory

next line results in the following error...

root@spamsnake:/# mv /var/lib/python-support/python2.6/pyzor* /var/lib/python-support/python2.5/pyzor/

mv: target `/var/lib/python-support/python2.5/pyzor/' is not a directory


For the second line I create the /python2.5/pyzor dir in the /var/lib/python-support dir. Then the

root@spamsnake:/# mv /var/lib/python-support/python2.6/pyzor* /var/lib/python-support/python2.5/pyzor/
succeeds...

I then try to do the

pyzor --homedir /var/lib/MailScanner discover

and I get

-bash: /usr/bin/pyzor: /usr/bin/python: bad interpreter: No such file or directory

I think something is missing in the instructions or the commands

mv /usr/bin/python /usr/bin/python26
ln -s /usr/bin/python2.5 /usr/bin/python

or the chmod commands are not doing the right thing. seems like python 2.5 is not installed. Thoughts on what I do now?

James
Reply With Quote
Sponsored Links
  #2  
Old 5th August 2009, 19:33
markerman markerman is offline
Member
 
Join Date: Dec 2007
Posts: 33
Thanks: 1
Thanked 0 Times in 0 Posts
Default I fixed this initial error but I'm getting other errors in the mail.log

I searched the forums for this error, found some threads, but I have not been able to resolve the issue. I get the following errors in my mail.log

Aug 5 09:29:26 spamsnake MailScanner[4641]: Read 850 hostnames from the phishing whitelist
Aug 5 09:29:26 spamsnake MailScanner[4641]: Read 5821 hostnames from the phishing blacklist
Aug 5 09:29:27 spamsnake MailScanner[4641]: Using SpamAssassin results cache
Aug 5 09:29:27 spamsnake MailScanner[4641]: Could not create SpamAssassin cache database /var/spool/MailScanner/incoming/SpamAssassin.cache.db
Aug 5 09:29:27 spamsnake MailScanner[4641]: Enabling SpamAssassin auto-whitelist functionality...
Aug 5 09:29:28 spamsnake MailScanner[4638]: /var/spool/mqueue is not owned by user 110 !
Aug 5 09:29:31 spamsnake MailScanner[4643]: MailScanner E-Mail Virus Scanner version 4.75.11 starting...
Aug 5 09:29:31 spamsnake MailScanner[4643]: Could not read directory Outgoing
Aug 5 09:29:31 spamsnake MailScanner[4643]: Error in configuration file line 153, directory Outgoing Queue Dir = /var/spool/postfix/incoming for outqueuedir does not exist (or is not readable)

Rocky, you there?

James
Reply With Quote
  #3  
Old 6th August 2009, 14:51
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

Hey,

Please double check that you did everything in section 16 and also section 17. It must be permission issues.

Rocky
__________________
Home of the SpamSnake

Last edited by Rocky; 6th August 2009 at 14:57.
Reply With Quote
  #4  
Old 6th August 2009, 18:38
markerman markerman is offline
Member
 
Join Date: Dec 2007
Posts: 33
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default Permissions

I'm starting over again...

I got permissions so messed up It would take more time for me to figure it out than to revert back to snapshot and start over.

Thanks.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The Perfect Spamsnake - Ubuntu Jaunty Pyzor Error -- Author Rocky moomooboy HOWTO-Related Questions 8 16th June 2009 12:13
The Perfect Server - Ubuntu Jaunty Jackalope (Ubuntu 9.04) [ISPConfig 2] AsDsL HOWTO-Related Questions 5 10th May 2009 19:06
Unbale to login to Postfix from webmail wasimriz HOWTO-Related Questions 5 6th April 2009 14:49
Howtoforge the perfect Server(links) rini90 Installation/Configuration 0 14th December 2008 11:58
SpamSnake SpamAssassin not working? getrav HOWTO-Related Questions 5 24th June 2008 00:02


All times are GMT +2. The time now is 20:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.