Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th July 2009, 08:20
rebeltaz rebeltaz is offline
Member
 
Join Date: Oct 2007
Posts: 31
Thanks: 1
Thanked 0 Times in 0 Posts
Default why are additional FTP users unable to see files?

I have set up a guest account on my FTP server, which allows users to upload files to the 'incoming' directory. They are able to do so with no problem, but nothing in that directory is visible to the guest account - not even the files that they just uploaded!

If I log in as the administrator and navigate to that directory, I can see the files just fine.

How do I make it where the guest account can see their own files?
________
XL200
________
Sativa strains

Last edited by rebeltaz; 19th March 2011 at 20:37.
Reply With Quote
Sponsored Links
  #2  
Old 30th July 2009, 09:15
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,561
Thanks: 791
Thanked 4,978 Times in 3,899 Posts
Default

Quote:
I have set up a guest account on my FTP server, which allows users to upload files to the 'incoming' directory. They are able to do so with no problem, but nothing in that directory is visible to the guest account - not even the files that they just uploaded!
This is the normal behaviour for an anonymous FTP account and it is recommended that you dont change it. At least if your server is connected to the internet.

If you want to change it anyway, take a look at the configuration file of your ftp daemon, there must be some settings for the anonymous accounts.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 30th July 2009, 17:35
rebeltaz rebeltaz is offline
Member
 
Join Date: Oct 2007
Posts: 31
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by till View Post
This is the normal behaviour for an anonymous FTP account and it is recommended that you dont change it. At least if your server is connected to the internet.

If you want to change it anyway, take a look at the configuration file of your ftp daemon, there must be some settings for the anonymous accounts.
Well, it's not exactly an anonymous account. I added 'guest' as a user. Come to think of it, though, I do have allow anonymous FTP checked. Maybe if I uncheck that? But that shouldn't have any effect on actual users, should it?
________
R1100S

Last edited by rebeltaz; 27th January 2011 at 12:02.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubleshooting FTP bswinnerton Installation/Configuration 4 10th October 2008 19:34
Cacti and ISPConfig: Monitoring Tool VMartins Tips/Tricks/Mods 11 9th August 2008 18:37
FTP shared access , no anonymous tonysch Tips/Tricks/Mods 5 5th February 2008 21:51
Cannot connect to anonymus ftp n1kol1s Installation/Configuration 39 15th February 2007 18:36
FTP + MYSQL users cant overwrite files williamp0044 HOWTO-Related Questions 6 21st July 2006 13:34


All times are GMT +2. The time now is 10:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.