Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th May 2009, 15:15
ravx ravx is offline
Junior Member
 
Join Date: Nov 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Spamsnake help needed.. postfix relay.

hi all,

i'v followed the SPAMSnake guide and "almost" got it to work in my domain...

finish all the instructions from start to end, now when i start the spamsnake server in my domain , in mail.log i can see the postfix handle the mail and sorting it :

May 24 15:35:02 vol-spam postfix/qmgr[18933]: 153821601B3:
from=<root@volta.com>, size=854, nrcpt=1 (queue active) May 24 15:35:02 vol-spam postfix/smtp[18986]: 153821601B3:
to=<root@volta.com>, orig_to=<root>, relay=192.168.2.1[192.168.2.1]:25, delay=0.11, delays=0.04/0/0/0.07, dsn=2.6.0, status=sent (250 2.6.0 <20090524123502.153821601B3@vol-spam.volta.com> Queued mail for delivery)

this is an example of a good mai queued for delivery but i dont see it in MailWatch or its transfer to my mail server.

if i send a test mail with telnet vol-spam.volta.com 25 then i can see it in MailWatch and its beeing delivered to the user mailbox.

i guess somthing wrong with the postfix configuration, its dosent release the mail for sending or the mailscanner is not working properly...

any help woud be appriciated..

thanks
ravx
Reply With Quote
Sponsored Links
  #2  
Old 26th May 2009, 17:13
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

Hey,

What's in your /etc/postfix/transport file?

Rocky
__________________
Home of the SpamSnake
Reply With Quote
  #3  
Old 27th May 2009, 08:20
ravx ravx is offline
Junior Member
 
Join Date: Nov 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for your help rocky,
my transport has 1 line that look like this ;

volta.com smtp:[192.168.2.1]

and the relay_domains looks like

volta.com OK

any idea what more i should look for ?
Reply With Quote
  #4  
Old 27th May 2009, 08:26
ravx ravx is offline
Junior Member
 
Join Date: Nov 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i found something that might help to understand my situation

when i added in MailWatch under whitelist an email adress, it directly pass to my inside mailbox and logged in MAilWatch as safe (green) but nothing else is logged (spam or grey) like the Spamsnake is rejecting anything that aint in whitelist....

any idea ?
Reply With Quote
  #5  
Old 27th May 2009, 09:03
ravx ravx is offline
Junior Member
 
Join Date: Nov 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

OMG !

iv done step 9.1 again :

9.11 Fix to allow MailWatch to work with Postfix Inbound/Outbound Queue
Download the patch from http://www.gbnetwork.co.uk/mailscann...fixmail.tar.gz
cd /usr/src
wget http://www.gbnetwork.co.uk/mailscann...fixmail.tar.gz
tar xvfz postfixmail.tar.gz
cd postfixmail
cp postfix* /var/www/mailscanner
patch /var/www/mailscanner/functions.php functions.php.diff

the patch tells me :

patching file /var/www/mailscanner/functions.php
Hunk #2 FAILED at 221.
Hunk #3 FAILED at 225.
2 out of 3 hunks FAILED -- saving rejects to file /var/www/mailscanner/functions.php.rej


and now MailWatch dont load with error :

Fatal error: Cannot redeclare postfixinq() (previously declared in /var/www/mailscanner/postfix.inc:5) in /var/www/mailscanner/postfix.inc on line 17

please help !
Reply With Quote
  #6  
Old 29th May 2009, 15:18
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

Ravx,

I've sent over the updated SpamSnake tutorial for Falko to post on the site. Look for it as it's been thorougly rewritten and should be more promising and easy to install.

It supports ugrading and has all the lasted software packages.

It'll probably take a day or two, as Falko is a very busy man...lol

Rocky
__________________
Home of the SpamSnake
Reply With Quote
  #7  
Old 31st May 2009, 06:50
ravx ravx is offline
Junior Member
 
Join Date: Nov 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks Rocky for you help and your fine tutorials !!!!

Regards,

rAvx
Reply With Quote
  #8  
Old 2nd August 2009, 09:30
linz linz is offline
Junior Member
 
Join Date: Aug 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Firstly, I have to mention that I am very impressed with this howto document.

Brilliant, there was an error before with the version of mailwatch and one of it's dependencies which would have been a gotcha like this problem here.

If this is a wiki and I had access, then I would be more than happy to update what I did and how to get back on track.


The problem presented here is to do with this...

Download the patch from http://www.gbnetwork.co.uk/mailscann...fixmail.tar.gz

cd /usr/src
wget http://www.gbnetwork.co.uk/mailscann...fixmail.tar.gz
tar xvfz postfixmail.tar.gz
cd postfixmail
cp postfix* /var/www/mailscanner
patch /var/www/mailscanner/functions.php functions.php.diff


It's broken, but for me, it's a nice to have rather than a must have so I rolled back and everything works fine.

Obviously another area that needs to be brought up to date.


But, in summary, still got a few things that I need to go to complete although my spam problems have gone, but a first class effort here



Quote:
Originally Posted by ravx View Post
hi all,

i'v followed the SPAMSnake guide and "almost" got it to work in my domain...

finish all the instructions from start to end, now when i start the spamsnake server in my domain , in mail.log i can see the postfix handle the mail and sorting it :

May 24 15:35:02 vol-spam postfix/qmgr[18933]: 153821601B3:
from=<root@volta.com>, size=854, nrcpt=1 (queue active) May 24 15:35:02 vol-spam postfix/smtp[18986]: 153821601B3:
to=<root@volta.com>, orig_to=<root>, relay=192.168.2.1[192.168.2.1]:25, delay=0.11, delays=0.04/0/0/0.07, dsn=2.6.0, status=sent (250 2.6.0 <20090524123502.153821601B3@vol-spam.volta.com> Queued mail for delivery)

this is an example of a good mai queued for delivery but i dont see it in MailWatch or its transfer to my mail server.

if i send a test mail with telnet vol-spam.volta.com 25 then i can see it in MailWatch and its beeing delivered to the user mailbox.

i guess somthing wrong with the postfix configuration, its dosent release the mail for sending or the mailscanner is not working properly...

any help woud be appriciated..

thanks
ravx
Reply With Quote
  #9  
Old 3rd August 2009, 04:40
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
 
Default

Hey,

Happy to know that you're using the guide. Hope it's proving helpful in your fight against spam.

I haven't had much time lately to work out the kinks in the guide, but you are more than welcome to present your suggestions and/or solutions to any problems you come across.

I will look at and update the section you mentioned.

Thanks,

Rocky
__________________
Home of the SpamSnake
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix not responding to telnet CarbonCopy Server Operation 6 8th May 2009 05:39
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39
SpamSnake SpamAssassin not working? getrav HOWTO-Related Questions 5 23rd June 2008 23:02
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36


All times are GMT +2. The time now is 15:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.