#1  
Old 23rd July 2009, 17:53
muucest muucest is offline
Junior Member
 
Join Date: Jul 2009
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default ffmpeg & ffmpeg-php

I'm trying to install ffmpeg with ffmpeg-php support on CentOS 5.3 64 bit installed by "the perfect server" tutorial.

I have installed FFMPEG using YUM (yum install ffmpeg ffmpeg-devel ffmpeg-libpostproc) and when i type "ffmpeg --help" it says:

Code:
FFmpeg version 0.5, Copyright (c) 2000-2009 Fabrice Bellard, et al.
  configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64 --mandir=/usr/share/man --incdir=/usr/include/ffmpeg --disable-static --extra-cflags=-fPIC --enable-libamr-nb --enable-libamr-wb --enable-libdirac --enable-libfaac --enable-libfaad --enable-libmp3lame --enable-libtheora --enable-libx264 --enable-gpl --enable-nonfree --enable-postproc --enable-pthreads --enable-shared --enable-swscale --enable-x11grab
  libavutil     49.15. 0 / 49.15. 0
  libavcodec    52.20. 0 / 52.20. 0
  libavformat   52.31. 0 / 52.31. 0
  libavdevice   52. 1. 0 / 52. 1. 0
  libswscale     0. 7. 1 /  0. 7. 1
  libpostproc   51. 2. 0 / 51. 2. 0
But when trying to ./configure ffmpeg-php (0.6.0) I keep getting an error message saying:

Code:
error: ffmpeg headers not found. Make sure you've built ffmpeg as shared libs using the --enable-shared option
Reply With Quote
Sponsored Links
  #2  
Old 25th July 2009, 00:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

The headers should be installed already (package ffmpeg-devel). I guess that the configure script looks in the wrong directory...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 25th July 2009, 11:06
muucest muucest is offline
Junior Member
 
Join Date: Jul 2009
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I have tried using "./configure --prefix=/usr" but still getting the same result.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FFMPEG maybe not an php library? Mkipz Installation/Configuration 2 14th September 2009 22:13
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 09:20
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 14:06
ispconfig php 5 errors itamarjp Installation/Configuration 8 25th April 2008 11:20
Apache2 Freezes celtic Server Operation 31 28th May 2007 18:18


All times are GMT +2. The time now is 09:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.