Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st April 2006, 19:18
RicochetPeter RicochetPeter is offline
Member
 
Join Date: Apr 2006
Posts: 41
Thanks: 3
Thanked 1 Time in 1 Post
Default Server accepts mail for mail@ - addresses

Hi,

I have a working configuration with Ubuntu 5.10 and ISPConfig 2.2.0. Everything seems to be alright, except one strange thing:

The server accepts mail addressed to addresses of the form mail@[domain] where [domain] is all of the domains set up on this server. Postfix (or is it procmail?) puts the mails to /var/mail/Maildir/ and I simply don't understand why this is so. Any hints?
Reply With Quote
Sponsored Links
  #2  
Old 21st April 2006, 19:27
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,177
Thanks: 829
Thanked 5,414 Times in 4,257 Posts
Default

Is the "mail" email address listed in one of the postfix config files, for example the aliases or virtusertable?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 21st April 2006, 20:09
RicochetPeter RicochetPeter is offline
Member
 
Join Date: Apr 2006
Posts: 41
Thanks: 3
Thanked 1 Time in 1 Post
Default

nope, that's why I find it so strange.

here's my main.cf:
Quote:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

myhostname = s02.xxxxx.xxx
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
#mydestination = s02.xxxxx.xxx, localhost.xxxxx.xxx, localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/
mailbox_command =
virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names
Quote:
root@s02:/etc/postfix# cat virtusertable | grep -i mail
root@s02:/etc/postfix#
Reply With Quote
  #4  
Old 22nd April 2006, 16:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's in /etc/aliases? Is mail a user in /etc/passwd?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 23rd April 2006, 00:57
RicochetPeter RicochetPeter is offline
Member
 
Join Date: Apr 2006
Posts: 41
Thanks: 3
Thanked 1 Time in 1 Post
Default

Yes falko, mail is a user in /etc/passwd. Can postfix be forced to only accept mail to addresses in the virtusertable?

Come to think of it, I do not want that either, cos a few minutes ago I figured out how to make mailman work with the ISPConfig setup...

As a hint to all who want to do this too, with Ubuntu 5.10/ISPConfig:

I chose a certain domain for being the mailman domain. Let's call it lists.bla.com

1) Create web for this domain in ISPConfig
1.1) You need to add these Apache Directives in the base data for the web:
Quote:
ScriptAlias /mailman/ /usr/lib/cgi-bin/mailman/
Alias /pipermail/ /var/lib/mailman/archives/public/
2) apt-get install mailman

3) make the changes to the postfix config files as mentioned in /etc/mailman/postfix-to-mailman.py, except for the relay_domains paramter, you don't need that.

4) yes, you have to make the change in master.cf like it's written in that script, so the line needs to be
Quote:
mailman unix - n n - - pipe flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py ${nexthop} ${user}
(note the fourth value is not a dash, but an n, and all of this is one line - or indented second/third lines)

5) do a postconf -e 'local_recipient_maps ='
If you don't, your postfix will not accept a single mail for the mailman domain. Heck, this cost me like two hours or so!

6) change /etc/mailman/mm_cfg.py to
Quote:
DEFAULT_URL_PATTERN = 'http://%s/mailman/'
PRIVATE_ARCHIVE_URL = '/mailman/private'
IMAGE_LOGOS = '/images/mailman/'
You will need to copy the three images to that location inside the web directory. There might be more clever ways...

7) now you could do a "newlist mailman" and the an /etc/init.d/mailman start

Last edited by RicochetPeter; 23rd April 2006 at 01:00.
Reply With Quote
  #6  
Old 23rd April 2006, 12:47
oliver.blaha oliver.blaha is offline
Member
 
Join Date: Apr 2006
Posts: 37
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by RicochetPeter
Can postfix be forced to only accept mail to addresses in the virtusertable?
Yes

In /home/admispconfig/ispconfig/lib/config.inc.php you can switch an option from sendmail style to postfix style. Just do this and your sorrows will be gone
Reply With Quote
  #7  
Old 23rd April 2006, 16:05
RicochetPeter RicochetPeter is offline
Member
 
Join Date: Apr 2006
Posts: 41
Thanks: 3
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by oliver.blaha
Yes

In /home/admispconfig/ispconfig/lib/config.inc.php you can switch an option from sendmail style to postfix style. Just do this and your sorrows will be gone
That's nice to hear, Oliver. I belive you're talking about this line here
Quote:
$go_info["server"]["postfix_config"] = 1; // 1 = SENDMAIL-STYLE, 2 = POSTFIX-STYLE
Next question: what will happen when I change this from 1 to 2, or: where can I find info about what this value does?
Reply With Quote
  #8  
Old 23rd April 2006, 16:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by RicochetPeter
Next question: what will happen when I change this from 1 to 2, or: where can I find info about what this value does?
The format of /etc/postfix/virtusertable and 7etc/postfix/local-host-names will change, that's all.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 23rd April 2006, 16:34
oliver.blaha oliver.blaha is offline
Member
 
Join Date: Apr 2006
Posts: 37
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
The format of /etc/postfix/virtusertable and 7etc/postfix/local-host-names will change, that's all.
The result of the changed format is that your virtual domains won't be treated as local domains anymore, so they won't accept local accounts as mail aliases.
You won't need to change anything else.
Reply With Quote
  #10  
Old 23rd April 2006, 17:27
RicochetPeter RicochetPeter is offline
Member
 
Join Date: Apr 2006
Posts: 41
Thanks: 3
Thanked 1 Time in 1 Post
 
Default

OK, this actually solved the problem I opened this thread for. But created another one: my listserver domain is now a VIRTUALDOMAIN, which seems to take precedence over the transport_map.

Is there any chance of ISPConfig not listing any of the domains it knows in the virtusertable as "VIRTUALDOMAIN"? Or other ideas?

OK, for those who followed my little mailman howto:

You will now have to deal with aliases

In the virtusertable you will need to add the entries for all the list addresses in postfix format in the MANUAL sesction, i.e.:
Quote:
test01@lists.bla.com test01
test01-admin@lists.bla.com test01-admin
and so on.

In /etc/aliases you will need to add all the command lines needed for mailman:
Quote:
test01: "|/var/lib/mailman/mail/mailman post test01"
test01-admin: "|/var/lib/mailman/mail/mailman admin test01"
and so on...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47
Email - Ueb-Miau mazhar Installation/Configuration 5 21st December 2005 10:01
Mail server jas_esp Server Operation 1 7th December 2005 18:17
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 02:30


All times are GMT +2. The time now is 02:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.