#1  
Old 8th July 2009, 23:28
lifeisboost lifeisboost is offline
Senior Member
 
Join Date: Feb 2006
Posts: 122
Thanks: 0
Thanked 2 Times in 2 Posts
Default webalizer

Hello everyone,

I have a site that webalizer has all of a sudden just stopped. I have doen every fix i have found but it will not fix it. The log file is not over 2 gigs, webalizer works fine for all other sites in the server. it has been a month since this sites statistics have been updated. I even tried to manually setup a webalizer config file through webmin for this site and it still will not creat a statistics page. the site is not out of space either and webalizer is checked in the isp control panel.

The server is F9 and ispconfig 2.2.29, im at a loss on this one as it works fine on all other sites for this server, just this one site has the issue of no stats.
Reply With Quote
Sponsored Links
  #2  
Old 9th July 2009, 10:57
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,385 Times in 4,231 Posts
Default

Does the access log for this specific website contains the latest log lines (one day old)?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 9th July 2009, 15:04
lifeisboost lifeisboost is offline
Senior Member
 
Join Date: Feb 2006
Posts: 122
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by till View Post
Does the access log for this specific website contains the latest log lines (one day old)?

yes it does and it rotates monthly like it should. I have manually run webalizer for this site and run webalizer.php with no errors or output.
Reply With Quote
  #4  
Old 10th July 2009, 10:17
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,385 Times in 4,231 Posts
Default

And do the statistics got created after you had run it manually?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 11th July 2009, 08:20
lifeisboost lifeisboost is offline
Senior Member
 
Join Date: Feb 2006
Posts: 122
Thanks: 0
Thanked 2 Times in 2 Posts
Default

No stats are ever produced, but for every other site on this server it works as it should. only 1 site out of 100 others has an issue where webalizer will not work.
Reply With Quote
  #6  
Old 11th July 2009, 08:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,385 Times in 4,231 Posts
Default

Ok, thats starange. Please ckeck that the site has a symlink with its domain name in /var/www (or were your sites are) that points to the we[ID] folder of the website like all other sites.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 11th July 2009, 09:02
lifeisboost lifeisboost is offline
Senior Member
 
Join Date: Feb 2006
Posts: 122
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Yes the symbolic link is correct. i have even pointed directly to the log file in that month under log/2009 and still no report.
Reply With Quote
  #8  
Old 11th July 2009, 09:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,385 Times in 4,231 Posts
Default

The symlink in /var/www may not point to the logfile! It has to point to the website directory. Please do not mix this up with the symlink in the logs folder which points to the logfile.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 11th July 2009, 09:28
lifeisboost lifeisboost is offline
Senior Member
 
Join Date: Feb 2006
Posts: 122
Thanks: 0
Thanked 2 Times in 2 Posts
Default

I know, i should have clarified, i have pointed webalizer directly to the log file for the month/ year when i tried to manually run webalizer.

web.log -> /home/www/www.xxxxxxxxx.com/log/2009/07/web.log

www.xxxxxxxxx.com -> /home/www/web5
Reply With Quote
  #10  
Old 11th July 2009, 09:32
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,385 Times in 4,231 Posts
 
Default

Ok. And if you look into the file /home/www/www.xxxxxxxxx.com/log/2009/07/web.log, it contains current log entries?

If yes, then please delete the webalizer.hist and webalizer.current files in the stats directory of this site. Maybe there was a wrong line with a date in the future in one of the older logs and webalizer skips now all records until this future date is reached. Please be aware that tis might delete some older stats for this site, so make a backup of the satta directory if you need them.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to disable webalizer? npodesign General 1 12th May 2009 20:28
missing webalizer stats bolero Installation/Configuration 15 12th November 2008 16:28
Disable Webalizer stats bixtro General 2 10th September 2008 09:09
Howto: Make Webalizer show full QueryString!! Zoon Tips/Tricks/Mods 1 5th November 2007 02:12
Webalizer problem MacPC Server Operation 3 15th May 2007 13:53


All times are GMT +2. The time now is 00:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.