#1  
Old 15th July 2009, 15:18
zond zond is offline
Junior Member
 
Join Date: Jul 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default maildrop problem

ISPconfig 3.0.1.3
maillog says
temporary failure. Command output: /usr/bin/maildrop: Unable to open mailbox

master.cf contain

Code:
 
maildrop  unix  -	   n	   n	   -	   -	   pipe
  flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient} ${extension} ${recipient} ${user} ${nexthop} ${sender}

cat /etc/issue | sudo -u vmail maildrop -V 9 -d XXX@XXX.com
Code:
 
maildrop: authlib: groupid=5000
maildrop: authlib: userid=5000
maildrop: authlib: logname=XXX@XXX.com, home=/var/vmail, mail=/var/vmail/XXX.com/XXX
maildrop: Changing to /var/vmail
Message start at 0 bytes, envelope sender=XXX@XXX.com
maildrop: Attempting .mailfilter
maildrop: signal 0x16
maildrop -V 4 -d XXX@XXX.com </aquota.user

Code:
 
maildrop: authlib: groupid=5000
maildrop: authlib: userid=5000
maildrop: authlib: logname=XXX@XXX.com, home=/var/vmail, mail=/var/vmail/XXX.com/XXX
maildrop: Changing to /var/vmail
Message start at 0 bytes, envelope sender=XXX@XXX.com
maildrop: Attempting .mailfilter
.mailfilter(5): LOGNAME="XXX@XXX.com"

.mailfilter(6): EXTENSION=""
.mailfilter(7): RECIPIENT=""
.mailfilter(8): USER=""
.mailfilter(9): HOST=""
.mailfilter(10): SENDER=""

.mailfilter(11): DEFAULT="/var/vmail///."
.mailfilter(13): Evaluating IF condition.
.mailfilter(13): IF evaluated, result=0
.mailfilter(18): Evaluating IF condition.
.mailfilter(18): IF evaluated, result=1
.mailfilter(20): SENDER="<>"
maildrop: Filtering through `test -e /var/vmail/$HOST`
.mailfilter(28): Evaluating IF condition.
.mailfilter(28): IF evaluated, result=0
maildrop: Filtering through `test -e /var/vmail/$HOST/$USER`
.mailfilter(34): Evaluating IF condition.
.mailfilter(34): IF evaluated, result=0
maildrop: Filtering through `test -f /var/vmail/mailfilters/$HOST/$USER/.autoresponder`
.mailfilter(43): Evaluating IF condition.
.mailfilter(43): IF evaluated, result=0
maildrop: Filtering through `echo $SIZE >> /var/vmail/$HOST/$USER/ispconfig_mailsize`
maildrop: Filtering through `test -f /var/vmail/mailfilters/$HOST/$USER/.mailfilter`
.mailfilter(60): Evaluating IF condition.
.mailfilter(60): IF evaluated, result=0
.mailfilter(66): Evaluating IF condition.
.mailfilter(66): IF evaluated, result=1
ls -l /var |grep vmail
Code:
drwxrwxr-x  4 vmail  mail   4096 Июл 15 00:21 vmail
maildrop can't get $1 $2 ... variables from master.cf

Plz help me to solve this problem.
Reply With Quote
Sponsored Links
  #2  
Old 15th July 2009, 16:24
zond zond is offline
Junior Member
 
Join Date: Jul 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

form example i have domain example.com and user example
ls -lR /var/vmail
Code:
/var/vmail:
итого 12
drwxrwxr-x 3 vmail vmail 4096 Июл 14 12:19 example.com
-rw-rw---- 1 vmail vmail  183 Июл 15 18:27 ispconfig_mailsize
drwxrwxrwx 3 vmail vmail 4096 Июл 14 12:19 mailfilters

/var/vmail/example.com:
итого 4
drwxrwxrwx 2 vmail vmail 4096 Июл 15 00:30 example

/var/vmail/example.com/example:
итого 12
-rw-rw---- 1 vmail vmail 10047 Июл 15 20:15 ispconfig_mailsize

/var/vmail/mailfilters:
итого 4
drwxrwx--- 3 vmail root 4096 Июл 14 12:19 example.com

/var/vmail/mailfilters/example.com:
итого 4
drwxrwx--- 2 vmail root 4096 Июл 15 03:02 example

/var/vmail/mailfilters/example.com/example:
итого 0
Reply With Quote
  #3  
Old 16th July 2009, 11:00
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: LŁneburg, Germany
Posts: 35,460
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
 
Default

The maildir is not initiated correctly. Please delete the mail user and recreate it. This has been fixed in SVN already.

By the way, your problem that you have here is not related to the problem in the other thread were you set a link to this thread. The other guy changed his maildir path and so messed up his setup.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 14:15
saslauthd problem: bind: Address already in use fitti70 Server Operation 4 14th May 2007 21:51
postfix mysql on fedora core5 igongora Installation/Configuration 7 17th April 2007 04:40
postfix+mysql and maildrop filter problem osanet Installation/Configuration 1 2nd June 2006 11:50
SMTP TLS Problem with Mail Client dschmid Installation/Configuration 1 9th December 2005 01:56


All times are GMT +2. The time now is 12:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.