Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th April 2006, 02:17
DaddyFix DaddyFix is offline
Member
 
Join Date: Jan 2006
Location: Canada
Posts: 35
Thanks: 0
Thanked 1 Time in 1 Post
Default proftpd virtual host not working

I am having serious problems with ProFTPd Version 1.2.10 and ISPconfig Version: 2.1.2 on Mandriva 2005 LE.

I can't seem to get proftpd started in my server. here is my config and the errors I am getting. I have tried searching for a solution for this in this section of the forum but I don't get an answer that works.

Code:
ServerName                      "Webenergy.ca FTP"
ServerType                      standalone
DefaultServer                   on
AllowStoreRestart               on

Port                            21
Umask                           022
MaxInstances                    30

# Set the user and group under which the server will run.
User                            nobody
Group                           nogroup

DefaultRoot ~
AllowOverwrite          on

<Limit SITE_CHMOD>
  DenyAll
</Limit>

PersistentPasswd              off
<Global>
AllowOverwrite on
</Global>
DisplayGoAway "Too Many Connections. Try Later."
DisplayLogin "Login Successful"
DisplayQuit "Goodbye"

<Anonymous ~hockeypool>
   User         ftp
   Group        nogroup
   UserAlias    hockeypool ftp
   HideNoAccess on
   <Limit LOGIN>
        Allow   All
   </Limit>
   <Limit ALL>
        Deny    All
   </Limit>
   <Limit PWD CWD LIST RETR>
        Allow   ALL
   </Limit>
   <Directory /home/hockeypool>
       Umask   022  022
      <Limit MKD STOR>
        Allow   All
      </Limit>
   </Directory>
</Anonymous>

Include /etc/proftpd_ispconfig.conf

###################################
#
# ISPConfig proftpd Configuration File
#         Version 1.0
#
###################################
<VirtualHost 192.168.1.100>
        DefaultRoot             ~
        AllowOverwrite          on
        Umask                   002
</VirtualHost>
<VirtualHost 192.168.1.101>
        DefaultRoot             ~
        AllowOverwrite          on
        Umask                   002
</VirtualHost>
This is my syslog results
Code:
Apr 16 20:13:54 webenegy proftpd: proftpd shutdown succeeded
Apr 16 20:13:54 webenegy proftpd[10147]: webenergy.ca - notice: 'Webenergy.ca FTP' (192.168.1.100:21) already bound to 'Webenergy.ca FTP'
Apr 16 20:13:54 webenegy proftpd[10147]: webenergy.ca - bindings.c:913: notice: unable to create ipbind '192.168.1.100': Address already in use
Apr 16 20:13:54 webenegy proftpd[10147]: webenergy.ca - ProFTPD 1.2.10 (stable) (built Mon Aug 15 12:35:14 MDT 2005) standalone mode STARTUP
Apr 16 20:13:54 webenegy proftpd[10147]: webenergy.ca - listen() failed in inet_listen(): Address already in use
Apr 16 20:13:54 webenegy proftpd: proftpd startup succeeded
Apr 16 20:14:27 webenegy proftpd: proftpd shutdown failed
Apr 16 20:14:27 webenegy proftpd[10324]: webenergy.ca - notice: 'Webenergy.ca FTP' (192.168.1.100:21) already bound to 'Webenergy.ca FTP'
Apr 16 20:14:27 webenegy proftpd[10324]: webenergy.ca - bindings.c:913: notice: unable to create ipbind '192.168.1.100': Address already in use
Apr 16 20:14:27 webenegy proftpd[10324]: webenergy.ca - ProFTPD 1.2.10 (stable) (built Mon Aug 15 12:35:14 MDT 2005) standalone mode STARTUP
Apr 16 20:14:27 webenegy proftpd[10324]: webenergy.ca - listen() failed in inet_listen(): Address already in use
Apr 16 20:14:27 webenegy proftpd: proftpd startup succeeded
Please help. I have checked all my firewall rules and I can't figure out why this is not working. I think it started to fail after I did a ISPConfig update and then just recently an init 6 reboot, then the errors started to show up.
Reply With Quote
Sponsored Links
  #2  
Old 17th April 2006, 05:52
sbovisjb1 sbovisjb1 is offline
Senior Member
 
Join Date: Feb 2006
Posts: 175
Thanks: 0
Thanked 1 Time in 1 Post
Default

<Limit LOGIN>
Allow All
</Limit>
<Limit ALL>
Deny All
</Limit>
<Limit PWD CWD LIST RETR>
Allow ALL

Thats interesting and you;re address is already being used by ISPConfig, you just need to allow the permissions /etc/proftpd_[IP_ADDRESS].conf <--- adds the included file. http://www.howtoforge.com/forums/showthread.php?t=518

And dont give aways so much info, it leaves you open to be brute forced...
Reply With Quote
  #3  
Old 17th April 2006, 18:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Have a look here: http://www.howtoforge.com/forums/sho...27&postcount=2
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 17th April 2006, 21:22
DaddyFix DaddyFix is offline
Member
 
Join Date: Jan 2006
Location: Canada
Posts: 35
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by sbovisjb1
<Limit LOGIN>
Allow All
</Limit>
<Limit ALL>
Deny All
</Limit>
<Limit PWD CWD LIST RETR>
Allow ALL
I took out all of the above
Quote:
Thats interesting and you;re address is already being used by ISPConfig, you just need to allow the permissions /etc/proftpd_[IP_ADDRESS].conf <--- adds the included file. http://www.howtoforge.com/forums/showthread.php?t=518
The permissions are the exact same as the proftpd.conf. And there is no proftpd_[IP_ADDRESS].conf file in the /etc dir.
Reply With Quote
  #5  
Old 18th April 2006, 11:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Did you have a look at the link I posted above?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 19th April 2006, 18:03
DaddyFix DaddyFix is offline
Member
 
Join Date: Jan 2006
Location: Canada
Posts: 35
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko
Did you have a look at the link I posted above?
Yes, I added the directive ...
Code:
SocketBindTight on
to the proftpd.conf file.

I am beginning to think this might be a DNS issue or soemthing else other than ISPConfig settings.... Hmmmmm. any ideas of where to check?
Reply With Quote
The Following User Says Thank You to DaddyFix For This Useful Post:
AbannyvabVask (20th December 2013)
  #7  
Old 19th April 2006, 19:59
DaddyFix DaddyFix is offline
Member
 
Join Date: Jan 2006
Location: Canada
Posts: 35
Thanks: 0
Thanked 1 Time in 1 Post
 
Default Solution?

Im not sure if ISPConfig had anything at all to do with proftpd running or not. This is what I recently did and how I think things might have gotten fixed.

Before I noticed that PROFTPD was running I ...

I cleanned up my /ETC/HOSTS file. I didn't have 127.0.0.1 defined as localhost
I don't thing this is what fixed it, but who knows???
After this I restarted SYSLOGD the daemon.
I had not restarted the daemon since fixing a typo in my /ETC/HOSTS file about a month ago. I think there might have been and DNS conflict when PROFTPD tried to start and there was no setting in the hosts file for the domain in memory
Hope this helps anyone.
ALSO, THANKS YOU FALCO for being patient with me...! I LOVE ISPCONFIG!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Hosting With Proftpd And MySQL (Incl. Quota) pontifex HOWTO-Related Questions 56 22nd June 2007 13:29
Virtual Host for Shared IP Tribal-Dolphin Feature Requests 3 24th October 2005 20:55
postfix config jmroth Installation/Configuration 6 18th September 2005 15:58
default virtual host jmroth Installation/Configuration 3 17th September 2005 20:29
Virtual hosts not working erik Installation/Configuration 1 25th August 2005 15:45


All times are GMT +2. The time now is 16:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.