Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th July 2009, 21:29
truent truent is offline
Junior Member
 
Join Date: Jul 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Question Virtual user postfix mailserver problems

Hey, first off.. just wanted to thank you guys for the awesome site, this may be my first post, but i've been enjoying the site for years..

I followed falko's post on installing/configuring postfix with virtual users on ubuntu 9.04, I'm at work currently, but when I get home I can give more detailed configuration file dumps and error logs etc.. so please let me know what will help..

Anyway I followed another guide to install straight up postfix with system users etc, and quickly realized when there was another option for virtual users, that would be better.. so i tried to uninstall/remove completely all the old stuff, but I think i may have botched it somehow because I followed the virtual user tutorial to a t and it's not working..

first off.. falko says in the tutorial that when you telnet into the smtp port, and ehlo, you should see 250-AUTH LOGIN PLAIN, mine has other options, wondering if that has anything to do with it..

netcat localhost 25
Code:
220 domain.com ESMTP Postfix (Ubuntu)
ehlo domain.com
250-domain.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN NTLM CRAM-MD5 DIGEST-MD5 PLAIN
250-AUTH=LOGIN NTLM CRAM-MD5 DIGEST-MD5 PLAIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
But when i send mail to a virtual user, it doesn't create any folders in /home/vmail, and of course when I try and login to pop etc, I get something like ERR chdir Directory not found.. any thoughts?

Also I have no problem wiping all this stuff clean so i can restart the tutorial with a fresh slate.. but thinking maybe a past configuration is making its way through, so how would i do that?

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 13th July 2009, 21:34
truent truent is offline
Junior Member
 
Join Date: Jul 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Oh i forgot, the only thing i realized i skipped was disabling apparmor.. didn't do that until the second time he mentioned disabling it as it was installed as a dependency, that have anything to do with it?..
Reply With Quote
  #3  
Old 14th July 2009, 13:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

What's in /etc/postfix/main.cf?
Did you compare all other configuration files with the ones from the tutorial?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 14th July 2009, 18:01
truent truent is offline
Junior Member
 
Join Date: Jul 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

whew, got it to work.. i was going crazy thinking about it at work yesterday, just had to get home and dive in..

the problem with directories etc not working.. the mysql*.cf config files had permissions problems,

and as far as me not having "AUTH PLAIN LOGIN".. that was because i mistyped /etc/postfix/sasl/smtpd.conf as /etc/postfix/sasl/smtp.conf


ok, so i can receive mails fine, but i think my outbound 25 is getting blocked.. having problems sending to gmail.. get to call my ISP yay!

anyways thanks for the quick response.. just got some things to work out now
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix: "unknown user" with mysql auth. Kruser Server Operation 3 18th June 2009 18:20
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39
The system is currently updating the configuration files. warlock General 8 21st February 2009 18:15
quota.txt file for postfix virtual user setup cannot be found sicnarf HOWTO-Related Questions 3 12th August 2007 17:29
postfix config jmroth Installation/Configuration 6 18th September 2005 15:58


All times are GMT +2. The time now is 20:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.