Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th July 2009, 11:09
baby_ghost baby_ghost is offline
Junior Member
 
Join Date: Jul 2009
Posts: 5
Thanks: 4
Thanked 0 Times in 0 Posts
Default E-mail send not true!??

Hi everybody, I'm using CentOS 5.3 with ISPconfig 2.2.32. Installing progess has not any error and ISPconfig run perfect! But I have a problem in e-mail services, I'm using squirremail webmail and when login webmail to send any e-mail, sender disaplay is not my domain!

I added a site with domain abc.com, and creat an e-mail for it: info@abc.com. Then i logged in webmail and send a test e-mail to my gmail, sending successfully, but when I receive e-mail in Gmail, sender is not my domain





What's step which I wrong?
Reply With Quote
Sponsored Links
  #2  
Old 8th July 2009, 11:26
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

it's saying "@example.com" so i think you rushed through the config files a bit to fast :P

the default config is saying:
$domain = 'example.com';

so i think there's your problem?
Reply With Quote
The Following User Says Thank You to Mark_NL For This Useful Post:
baby_ghost (8th July 2009)
  #3  
Old 8th July 2009, 11:34
baby_ghost baby_ghost is offline
Junior Member
 
Join Date: Jul 2009
Posts: 5
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Mark_NL View Post
it's saying "@example.com" so i think you rushed through the config files a bit to fast :P

the default config is saying:
$domain = 'example.com';

so i think there's your problem?
Before I look at config file, I run this command to add my own hostname
Quote:
postconf -e 'myhostname = server1.example.com'
then
Quote:
service postfix restart
ok, retry, hix T__T has nothing change

Then I looked at my config file
Quote:
vi /etc/postfix/main.cf
but I can't found:
Quote:
the default config is saying:
$domain = 'example.com';
Reply With Quote
  #4  
Old 8th July 2009, 11:53
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

Quote:
Originally Posted by baby_ghost View Post
I'm using squirremail webmail...
I was referring to your squirrelmail configuration
Reply With Quote
The Following User Says Thank You to Mark_NL For This Useful Post:
baby_ghost (8th July 2009)
  #5  
Old 8th July 2009, 12:45
baby_ghost baby_ghost is offline
Junior Member
 
Join Date: Jul 2009
Posts: 5
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Mark_NL View Post
I was referring to your squirrelmail configuration
Yeah, that's my problem, I modified my squirrelmail configuration and now it sent email with true domain, but user was wrong!?

When creat e-mail user in ispconfig, we have two choice:
E-mail: abc@domain.com
and user: Prefix_user

We use e-mail and password to log in squirrelmail, but when send, it use username to send mail: prefix_user@domain.com but the true e-mail is: abc@domain.com

Another problem, I fixed wrong domain error, but now, an error occur from that. I have some sites hosted on my server runing ispconfig. Each site have e-mail with site's domain. But any user from any site using webmail were sent mail with only one domain which define in configuration file! So what should I do?
Reply With Quote
  #6  
Old 8th July 2009, 14:07
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

hehe i understand your problem .. what you _could_ do, is patch the php config file, so it reads the hostname, strips of the "www." part and uses that as $domain = ''; (this will only work if all clients can use: www.client_domain.com/webmail .. so set as alias for all websites, i've put instructions on that here before, it's (it's the same way but then for roundcube webmail): http://www.howtoforge.com/forums/sho...583#post197583 )

i think something like this should work:
Code:
preg_match('/.*?\.(.*)/', $_SERVER['SERVER_NAME'], $aMatch);
$domain = $aMatch[1];

Last edited by Mark_NL; 8th July 2009 at 14:09.
Reply With Quote
The Following User Says Thank You to Mark_NL For This Useful Post:
baby_ghost (8th July 2009)
  #7  
Old 9th July 2009, 13:33
baby_ghost baby_ghost is offline
Junior Member
 
Join Date: Jul 2009
Posts: 5
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Mark_NL View Post
hehe i understand your problem .. what you _could_ do, is patch the php config file, so it reads the hostname, strips of the "www." part and uses that as $domain = ''; (this will only work if all clients can use: www.client_domain.com/webmail .. so set as alias for all websites, i've put instructions on that here before, it's (it's the same way but then for roundcube webmail): http://www.howtoforge.com/forums/sho...583#post197583 )

i think something like this should work:
Code:
preg_match('/.*?\.(.*)/', $_SERVER['SERVER_NAME'], $aMatch);
$domain = $aMatch[1];
Maybe I have to install webmail for each site when creat

I have problem seem as thread owner: http://www.howtoforge.com/forums/sho...583#post197583

Keep getting 404 error although config alias in httpd
Reply With Quote
  #8  
Old 9th July 2009, 16:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

You must set the correct sender address in your email client (e.g. Squirrelmail or Uebimiau).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
baby_ghost (9th July 2009)
  #9  
Old 9th July 2009, 20:00
baby_ghost baby_ghost is offline
Junior Member
 
Join Date: Jul 2009
Posts: 5
Thanks: 4
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by falko View Post
You must set the correct sender address in your email client (e.g. Squirrelmail or Uebimiau).
Yeah, if I manula config my name, my e-mail in options page of squirrelmail, e-mail was sent with true value, maybe we won't have an automatic system Thanks for any response of you
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix problem and few questions Gimly Installation/Configuration 12 7th July 2009 16:27
Postfix + postfixadmin = SMTP errors... Rashef Server Operation 4 25th June 2009 16:12
just the last step...and it works. Postfix...need help config. ubuntusr Installation/Configuration 1 5th January 2009 09:50
Problem with dcc-client installation (Postfix) swap-as Installation/Configuration 9 18th September 2008 20:47
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 12:16


All times are GMT +2. The time now is 19:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.