#1  
Old 7th July 2009, 19:58
Samir Samir is offline
Junior Member
 
Join Date: Jul 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Error: Replication failed

Hi,

I posted my problem in the german forum, but I did'n get an adequate solution yet.

My Configuration:
I've installed Centos 5.3 on a virtual machine (Hyper-V) as described in the perfect server tutorial from howtoforge. After that, I've installed ISPConfig 3 (latest Version from SVN). I want to set up a multiserver-configuration.

My Problem:
The installation on master server went off without any problems. Also, there were no problems during the installation of the slave server: I first configured the local MySQL-DB and after the question about the multiserver setup, I entered the access-data of the master server. After the installation is completed, there are no errors in the log-files and the Monitoring reports no problems (I've installed only a Web-Interface on the master-server)

But my problem always appears after I setup a website or a client. The Error messages are nearly the same (it is definetely the same problem), for example:

26.06.2009-16:19 - ERROR - Replication failed. Error: (sys_group) UPDATE command denied to user 'ispcsrv2'@'192.168.80.81' for table 'server' # SQL: REPLACE INTO sys_group (`groupid`,`name`,`description`,`client_id`) VALUES ('2','test','','1')

192.168.80.81 is the IP Adress of the master server and the user ispcsrv2 only exists on the master servers DB.

I suggest that this is a bug! I posted it in the bugtracker, but they told me, that I did the installation wrong. but I assume, that I did not.

Because: After I grant the needed userrights (UPDATE on tables sys_group and server), the problem will not appear anymore. That's why I patched the installation-script. But there is one problem I cannot fix: The status of data in the table sys_datalog keeps beeing "pending", but the job-queue (in the webinterface) is empty.

Does anybody know how to solve this problem? is it a bug or did I make a mistake during the installation? Will I get any problems with the pending jobs in the sys_datalog?

I Hope i explained it well, my english is not the best!

Thank you in anticipation!
Reply With Quote
Sponsored Links
  #2  
Old 8th July 2009, 00:30
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,394
Thanks: 833
Thanked 5,489 Times in 4,321 Posts
 
Default

1) Do not use svn versions on production systems. SVN versions may work or may not work. They are only for development and not for real use on servers.
2) Use the hostname and not the IP when you specify the hostname of the master server.
3) The status field of the sys_datalog table is not used for anything and is always pending.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is my postfix is hacked? bzzik Server Operation 21 15th July 2009 14:13
Freebsd 6.1 support misterm Installation/Configuration 10 9th April 2009 09:29
Anyone figured out to integrate FuzzyOCR into ISPConfig on Ubuntu? friday Installation/Configuration 16 10th May 2007 16:25
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 22:40


All times are GMT +2. The time now is 19:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.