#1  
Old 7th July 2009, 13:30
robertlouwen robertlouwen is offline
Senior Member
 
Join Date: Apr 2009
Location: Brielle, Netherlands
Posts: 141
Thanks: 20
Thanked 3 Times in 2 Posts
Default SSL and internal server error

Gentlemen,

I am on Fedora 10 with ISPConfig 3.0.1.3 and "host" 3 domains ( something.nl, something.nu and somethig.org )

when I browse to https://www.something.nl or https://www.something.nu first I see a warning about certificates and safety then I click continue to website and the server returns a error 500 ( internal server error )
when I browse to https://www.something.org first I see a warning about certificates and safety then I click continue to website and the server returns a error 404 ( page not found )

When I view the certificates it says: : "issued to localhost.localdomain" and "issued by localhost.localdomain"

Can anyone help me with this ?
__________________
With Respect, Robert
------------------------------------------------
Fedora 15 - ISPConfig v3.0.3.3
On Dell Optiplex GX270, Pentium 4, 2.8 GHz, 1024 Mb
Reply With Quote
Sponsored Links
  #2  
Old 7th July 2009, 13:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,381
Thanks: 833
Thanked 5,482 Times in 4,316 Posts
Default

When you get an error, look at the error log of the website zo find out why you get this error.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 7th July 2009, 14:56
robertlouwen robertlouwen is offline
Senior Member
 
Join Date: Apr 2009
Location: Brielle, Netherlands
Posts: 141
Thanks: 20
Thanked 3 Times in 2 Posts
Default

@ Till,

Will I find the log in ISPConfig ? or will I find it in /var/www/clients/clientx/webx/log ?
__________________
With Respect, Robert
------------------------------------------------
Fedora 15 - ISPConfig v3.0.3.3
On Dell Optiplex GX270, Pentium 4, 2.8 GHz, 1024 Mb
Reply With Quote
  #4  
Old 7th July 2009, 15:18
Croydon Croydon is offline
ISPConfig Developer
 
Join Date: Jul 2007
Location: Koblenz, Germany
Posts: 932
Thanks: 16
Thanked 262 Times in 208 Posts
Default

Quote:
Originally Posted by robertlouwen View Post
@ Till,

Will I find the log in ISPConfig ? or will I find it in /var/www/clients/clientx/webx/log ?
try searching in
/var/log/ispconfig/httpd/MYDOMAIN/error.log
Reply With Quote
  #5  
Old 7th July 2009, 16:10
robertlouwen robertlouwen is offline
Senior Member
 
Join Date: Apr 2009
Location: Brielle, Netherlands
Posts: 141
Thanks: 20
Thanked 3 Times in 2 Posts
Default

@ Croydon,

In error.log "louwen.nu" there is nothing after June 17 ???
In error.log "louwen.org" there are a lot of errors but I can't see ( don't know ) wich is related to my problem.
In error.log "runningchef.nl" there are the following errors:
Code:
Tue Jul 07 13:09:49 2009 [error] [client 192.168.0.1] SecurityException in Application.cpp:496: Handler not found in configuration
Tue Jul 07 13:09:49 2009 [error] [client 192.168.0.1] Caused by KeyNotFoundException in configuration.cpp:234 Handler "x-httpdphp"not found
Tue Jul 07 13:09:49 2009 [error] [client 192.168.0.1] Premature end of script headers: index.php File does not exist: /var/www/error/500.html
I hope all this is helpfull to you
__________________
With Respect, Robert
------------------------------------------------
Fedora 15 - ISPConfig v3.0.3.3
On Dell Optiplex GX270, Pentium 4, 2.8 GHz, 1024 Mb
Reply With Quote
  #6  
Old 8th July 2009, 14:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Are you using suPHP? If so, what's in /etc/suphp.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 9th July 2009, 12:56
robertlouwen robertlouwen is offline
Senior Member
 
Join Date: Apr 2009
Location: Brielle, Netherlands
Posts: 141
Thanks: 20
Thanked 3 Times in 2 Posts
 
Default Re,

@ Falko,

I have enabled suPHP for all three domains in ISPconfig panel, if it works I don't know.

The content of suphp.conf in attached .txt file.

Thank you, again, for your time
Robert
Attached Files
File Type: txt suphp.txt (865 Bytes, 320 views)
__________________
With Respect, Robert
------------------------------------------------
Fedora 15 - ISPConfig v3.0.3.3
On Dell Optiplex GX270, Pentium 4, 2.8 GHz, 1024 Mb
Reply With Quote
Reply

Bookmarks

Tags
fedora 10, ispconfig 3.0.1.3, ssl

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
All my mail is going to /var/mail/vmail _sluimers_ Installation/Configuration 21 10th January 2011 13:21
FTP cannot open remote folder!?! andysm849 Server Operation 23 16th October 2008 23:34
Can't start apache Musty Server Operation 12 9th March 2008 13:58
Disable SSL on the ISPConfig Apache server lespaul49 Installation/Configuration 1 24th July 2007 14:15
PHP Binary error during SSL haberg Installation/Configuration 1 21st July 2007 22:59


All times are GMT +2. The time now is 19:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.