Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th June 2009, 22:47
toolswizard toolswizard is offline
Junior Member
 
Join Date: Aug 2007
Posts: 27
Thanks: 1
Thanked 0 Times in 0 Posts
Default Postfix Recipient address rejected: User unknown in local recipient table

I am running version 2.2.29 of ISP Config.
I followed the instructions for The Perfect Server using Ubuntu 8.4 LTS server.
I thought postfix was working, but I was not really using it. I have new IP's and a new router. Configuring it to forward to my server and testing, I found that my email was not working.

My host is set up independant as hostdomain.com. I have 3 virtual domains on this server virtual1.com virtual2.com virtual3.com.

When I send an email to joesmith@virtual2.com, I get a 550 error that states web2_joe@hostdomain.com does not exist.

I looked at the virtusertable and for every virtual domain there exists a joesmith and a web2_joe, but it appears to only look for the hostdomain.com.

The email is being rewrittin as the user@hostdomain.com which ther is no user.

What am I missing?
Reply With Quote
Sponsored Links
  #2  
Old 29th June 2009, 08:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,982 Times in 3,903 Posts
Default

Quote:
I looked at the virtusertable and for every virtual domain there exists a joesmith and a web2_joe, but it appears to only look for the hostdomain.com.

The email is being rewrittin as the user@hostdomain.com which ther is no user.
This is absoluetely ok as web2_joe is a system user, so it does exist in /etc/passwd and not the virtusertable. The problem is most likely that hostdomain.com is not in the local-host-names file. Please add it at the end of the file and restart postfix.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 29th June 2009, 12:08
toolswizard toolswizard is offline
Junior Member
 
Join Date: Aug 2007
Posts: 27
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thank you Till,

I looked at the local-host-names I saw many variations of hostdomain.com in the file..... but not one just for the hostdomain.com. I added it to the bottom of the file and the email was received.

Now on to the next problem... only 2 of the 3 domains are making it to the server. so now I need to find the routing problems.

Thanks again.
Reply With Quote
  #4  
Old 29th June 2009, 12:13
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,982 Times in 3,903 Posts
Default

What is not working (web, mail?) and for which domain? The domain of the host or a virtual domain?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 10th July 2009, 18:01
toolswizard toolswizard is offline
Junior Member
 
Join Date: Aug 2007
Posts: 27
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Till,

I have most everything working now, except I have one problem.

Out of three domains on a server, one will not rebuild the virtusertable. I have three hosts on each domain, blank, www, and mail. Only the www shows for the one domain. I have tried making changes, even to the email name, but the old one stays in the virtusertable.

Help pleas!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Recipient address rejected: User unknown in local recipient table hcreeves Installation/Configuration 3 5th February 2009 20:46
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06
Recipient address rejected: User unknown in local recipent table. adrenalinic Installation/Configuration 15 25th April 2006 16:26
postfix config jmroth Installation/Configuration 6 18th September 2005 15:58


All times are GMT +2. The time now is 18:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.